This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] [GDBserver] Replace "reinsert_breakpoint" with "singlestep_breakpoint"

On 09/01/2016 10:01 AM, Yao Qi wrote:
> reinsert_breakpoint is used for software single step, so it is more
> clear to rename it to singleste_breakpoint.  This was pointed out in
> the review
> I don't rename "other_breakpoint" in this patch.


> 2016-09-01  Yao Qi  <>
> 	* linux-low.c: Replace "reinsert_breakpoints" with
> 	"singlestep_breakpoints".  Replace "reinsert breakpoints"
> 	with "singlestep breakpoints".
> 	* mem-break.c: Likewise.
> 	* mem-break.h: Likewise.

I hate to be this picky, but I have to say that it itches me that both
gdb and gdbserver currently largely use "single-step" instead of "singlestep"
in comments and largely uses "single_step" instead of "singlestep" in
function signatures:

 $ cd gdb
 $ grep -rn "single-step" --exclude='ChangeLog*' --exclude="gdbarch.c" --exclude="gdbarch.h" | wc -l
 $ grep -rn "single_step" --exclude='ChangeLog*' --exclude="gdbarch.c" --exclude="gdbarch.h" | wc -l
 $ grep -rn "singlestep" --exclude='ChangeLog*' --exclude="gdbarch.c" --exclude="gdbarch.h" | wc -l

Did you consider following this scheme?

Pedro Alves

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]