This is the mail archive of the
gdb-patches@sourceware.org
mailing list for the GDB project.
Re: [PATCH 01/12] regcache: Add functions suitable for regset_supply/collect.
- From: Yao Qi <yao at codesourcery dot com>
- To: Andreas Arnez <arnez at linux dot vnet dot ibm dot com>
- Cc: <gdb-patches at sourceware dot org>
- Date: Tue, 27 May 2014 20:20:13 +0800
- Subject: Re: [PATCH 01/12] regcache: Add functions suitable for regset_supply/collect.
- Authentication-results: sourceware.org; auth=none
- References: <1401122208-2481-1-git-send-email-arnez at linux dot vnet dot ibm dot com> <1401122208-2481-2-git-send-email-arnez at linux dot vnet dot ibm dot com> <5383FC9B dot 4040400 at codesourcery dot com> <877g5777zd dot fsf at br87z6lw dot de dot ibm dot com>
On 05/27/2014 07:53 PM, Andreas Arnez wrote:
> Correct. Maybe it's better to rephrase the whole comment like this:
>
Yes, that is much better.
> /* Mapping between register numbers and offsets in a buffer, for use
> in the '*regset' functions below. In an array of
> 'regcache_map_entry' each element is interpreted like follows:
>
> - If 'regno' is a register number: Map register 'regno' to the
> current offset (starting with 0) and increase the current offset
> by the register's size. Repeat this with consecutive register
> numbers up to 'regno+count-1'.
>
> - If 'regno' has the special value REGCACHE_MAP_SKIP_BYTES: Add
> 'count' to the current offset.
Nit: I'd say "If 'regno' is REGCACHE_MAP_SKIP_BYTES, 'count' is the
increased offset". This is just my suggestion, which may be worse
than yours.
>
> - If count=0: End of the map. */
>
>> >
>>> >> +/* Transfer a set of registers (as described by REGSET) between
>>> >> + REGCACHE and BUF. If REGNUM == -1, transfer all registers
>>> >> + belonging to the regset, otherwise just the register numbered
>>> >> + REGNUM. The REGSET's 'descr' field must point to an array of
>>> >> + 'struct regcache_map_entry'.
>> >
>> > IWBN to update the comments to 'descr' field, and go a step further,
>> > rename field 'descr'.
> With the new name being something like 'map' or 'regmap', I guess? If
> that's what you mean, I tend to agree, and I could provide a separate
> patch for that.
>
'regmap' sounds good to me. I don't have other comments.
--
Yao (éå)