This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA] Rename "read_reg" into "read_addr_from_reg" in struct dwarf_expr_context_funcs

On 11/16/2013 03:50 AM, Joel Brobecker wrote:
> Hello,
> This implements the suggestion discussed at:
> ~~~
> This is to help make it slightly clearer how this method is expected
> to extract data from the given register.
> gdb/ChangeLog:
>         * dwarf2expr.h (struct dwarf_expr_context_funcs)
>         <read_addr_from_reg>: Renames "read_reg".
>         * dwarf2-frame.c (read_addr_from_reg): Renames "read_reg".
>         Adjust comment.
>         (dwarf2_frame_ctx_funcs, execute_stack_op, dwarf2_frame_cache):
>         Use read_addr_from_reg in place of read_reg.
>         * dwarf2expr.c (execute_stack_op): Use read_addr_from_reg
>         in place of read_reg.
>         * dwarf2loc.c (dwarf_expr_read_addr_from_reg): Renames
>         dwarf_expr_read_reg.
>         (dwarf_expr_ctx_funcs): Replace dwarf_expr_read_reg
>         with dwarf_expr_read_addr_from_reg.
>         (needs_frame_read_addr_from_reg): Renames needs_frame_read_reg.
>         (needs_frame_ctx_funcs): Replace needs_frame_read_reg with
>         needs_frame_read_addr_from_reg.
> Tested on x86_64-linux.  OK to commit?

Looks good to me.  Thanks!

Pedro Alves

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]