This is the mail archive of the
mailing list for the GDB project.
Re: [PATCH 22/348] Fix -Wsahdow warnings
On Tue, Nov 22, 2011 at 8:20 AM, Mike Frysinger <firstname.lastname@example.org> wrote:
>> > your ChangeLogs are also incorrect. ?it should not be:
>> > ? ? * bcache.c (expand_hash_table): Fix -Wshadow warnings.
>> > but rather:
>> > ? ? * bcache.c (expand_hash_table): Rename bcache to cache.
>> I'm 50/50 on this. I don't mind either way. What do others think?
>> Is that really that important that we must create boring extra work
>> for Andrey?
> it's my understanding that the GNU changelog style is "document what changed"
> and not "why". ?i think that's largely stupid, but i'm not the one in control
> of said policy.
For little things like this, at least for those that are internal to a function,
I've seen a lot of leeway and I think that's ok.