This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 3/6] New commands for loading and unloading a reader.


> From: Sanjoy Das <sanjoy@playingwithpointers.com>
> Cc: Sanjoy Das <sanjoy@playingwithpointers.com>
> Date: Sat, 20 Aug 2011 11:57:12 +0530
> 
> +  add_com ("load-jit-reader", no_class, load_jit_reader_command, _("\
> +Try to load file FILE as a debug info reader (and unwinder) for\n\
> +JIT compiled code from " LIBDIR "/gdb\n\
> +Usage is `load-jit-reader FILE`."));

The first line of a doc string should be a complete sentence, because
it is displayed by help commands such as apropos.  I suggest

 Load FILE as debug info reader and unwinder for JIT compiled code.

Then you can have the more detailed information in the rest of the doc
string.

> +  add_com ("unload-jit-reader", no_class, unload_jit_reader_command, _("\
> +Unload the currently loaded JIT reader (loaded using load-jit-reader)\n\
> +Usage is `unload-jit-reader`."));

The reference to load-jit-reader in the first line looks redundant.
And the usage is trivial.  How about this instead?

 Unload the currently loaded JIT debug info reader.
 See load-jit-reader for how to load JIT debug readers.

Thanks.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]