This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch] gdbserver: Add support for Z0/Z1 packets

On Wednesday 24 June 2009 20:25:35, Aleksandar Ristovski wrote:
> So, I would make it something like I proposed (if either is 
> NULL, it's unsupported - also makes a clear statement to new 
> target implementors).

IMO, hardly a real problem.  Even if one implements both callbacks
one needs to be sure to handle e.g., one of z2 and Z2 on each
of them.  It just looks unnecessary cautiousness to me.  We've not
cared for that for a long while in server.c, and don't see much of
a point we have to now --- it's not like someone adding support
for inserting HW breakpoint wouldn't notice that she missed adding
support for removing it.  OTOH, it makes the code a bit more tidy
to not care about it --- it's just mostly about avoiding a NULL
deference as is.

I've checked the patch in.  If we need to split this up, it's
really a trivial change, so let's worry about it then, and move

As for naming, thinking about the GDB side, GDB is a bit stuck to
calling everything "breakpoints" --- breakpoints, watchpoints, catchpoints,
and now tracepoints are all subsets of "breakpoints".  The HPD spec,
Frysk and TotalView (well both of these are HPD influenced) at least,
call all these "actionpoints".  Personally, I wish we'd call
them actionpoints too, and have "info actionpoints" show all of
those, "info breakpoints" show only breakpoints, "info watchpoints"
show only watchpoints, etc.  But I'm sure it is not a practical
change at this point ( is it ?? :-) )

Pedro Alves

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]