This is the mail archive of the
mailing list for the GDB project.
Re: Make target_ops->to_has_FOO functions instead of variables.
On Friday 05 June 2009 19:41:04, Tom Tromey wrote:
> Pedro> The patch below addresses this, by rewriting the target_has_FOO
> Pedro> properties as methods, so that they can return a different
> Pedro> result depending on the current inferior/program.
> Everything in there that I understand seems reasonable to me.
Many thanks for taking a look.
> Pedro> +extern int target_has_all_memory_1 (void);
> Pedro> +#define target_has_all_memory target_has_all_memory_1 ()
> What do you think of a mechanical follow-up patch that changes
> "target_has_*" to "target_has_* ()"?
Yeah, perfectly reasonable. I avoided doing those mechanical
changes in case I was taking a wrong turn. :-)