This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA] Renam sutruct using_direct members

>>>>> "Sami" == Sami Wagiaalla <> writes:

Sami> struct using_direct
Sami> {
Sami>    char *inner;
Sami>    char *outer;
Sami>    struct using_direct *next;
Sami> };

Sami> The names inner and outer are not very clear. I certainly found it
Sami> unintuitive while working on namespace support. This patch renames them
Sami> no import_src and import_dest respectively

Seems reasonable.  I agree that these names are not very clear.

Sami> 2009-05-25  Sami Wagiaalla  <>
Sami> 	* cp-support.h (struct using_direct): renamed members inner, and
Sami>          outer to import_src, and import_dest respectively.
Sami> 	Updated all reverences.

A few nits about the ChangeLog... It should mention all files that
were changed.  Descriptions should start with a capital letter.  All
lines should start with a single TAB (the second one did not in the

For this one I would write:

2009-05-25  Sami Wagiaalla  <>

	* cp-support.h (struct using_direct): Rename members inner and
	outer to import_src, and import_dest respectively.
	* cp-namespace.c (cp_add_using_directive): Update.
	(cp_add_using): Update.
	(cp_copy_usings): Update.
	(cp_lookup_symbol_namespace): Update.
	* cp-support.c (make_symbol_overload_list_using): Update.

Also, your patch seems to have been wrapped at some places... wrong
MUA setting somewhere?

This is ok with an updated ChangeLog.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]