This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA] Darwin/x86 port (v2 - part 3: i386-darwin files)

On Nov 12, 2008, at 1:42 PM, Mark Kettenis wrote:
void i386_darwin_fetch_gp_registers (struct regcache *regcache, i386_thread_state_t *sp_regs);
void i386_darwin_store_gp_registers (struct regcache *regcache, i386_thread_state_t *sp_regs);
void x86_64_darwin_fetch_gp_registers (struct regcache *regcache, x86_thread_state64_t *sp_regs);
void x86_64_darwin_store_gp_registers (struct regcache *regcache, x86_thread_state64_t *sp_regs);
void i386_darwin_fetch_fp_registers (struct regcache *regcache, i386_float_state_t *fp_regs);
int i386_darwin_store_fp_registers (struct regcache *regcache, i386_float_state_t *fp_regs);
void x86_64_darwin_fetch_fp_registers (struct regcache *regcache, x86_float_state64_t *fp_regs);
int x86_64_darwin_store_fp_registers (struct regcache *regcache, x86_float_state64_t *fp_regs);

Can you do a s/x86_64/amd64/ on the function/variable names in your new code? That's more consistent with other code in GDB.



As far as I can tell, this define isn't used. Can you remove it?


I will resubmit this part.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]