This is the mail archive of the
mailing list for the GDB project.
Re: [RFC] Move/Rename include/wait.h ("wait.h")
- To: Andrew Cagney <ac131313 at cygnus dot com>
- Subject: Re: [RFC] Move/Rename include/wait.h ("wait.h")
- From: jtc at redback dot com (J.T. Conklin)
- Date: 09 Dec 1999 10:53:48 -0800
- Cc: GCC Patches <gcc-patches at gcc dot gnu dot org>, GDB Patches <gdb-patches at sourceware dot cygnus dot com>
- References: <384F481D.A77D2CEF@cygnus.com>
- Reply-To: jtc at redback dot com
>>>>> "Andrew" == Andrew Cagney <email@example.com> writes:
Andrew> I'd like to put forward the proposal that the file
Andrew> ``include/wait.h'' be either:
Andrew> o renamed to include/gnu-wait.h (?)
Andrew> o moved to gdb/gdb-wait.h
If it's not used by other programs, I'd recommend that it be moved to
gdb_wait.h (with an underscore, not a dash). I created gdb_string.h
and gdb_stat.h long ago for the same sort of reasons.
We might also want to consider creating a gdb_fcntl.h header to wrap
fcntl.h. It would would define O_BINARY to 0 on hosts that don't
distinguish between text and binary files; instead of having that
definition scattered throughout various *.c files.