This is the mail archive of the elfutils-devel@sourceware.org mailing list for the elfutils project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug general/25227] "eu-nm --extern" skips first symbol


https://sourceware.org/bugzilla/show_bug.cgi?id=25227

--- Comment #5 from Mark Wielaard <mark at klomp dot org> ---
(In reply to Enzo Matsumiya from comment #4)
> Ping?
> 
> We're looking to roll out this fix internally, but we need upstream to
> acknowledge/release it first.

Sorry, I forgot. Like I said in comment #3 I created some testcases and noticed
the output of eu-nm didn't always match binutils nm. I wanted to look deeper
into that but then other stuff came up.

I have pushed the patch to simply fix this issue now:

commit 62e3c37afd5828466f9192bd19217de835a3620f (HEAD -> master)
Author: Mark Wielaard <mark@klomp.org>
Date:   Thu Jan 16 23:33:52 2020 +0100

    nm: Fix nm --external sysv format output.

    Partial revert of commit 66f4c37d497bdde040a33f299b12163f044b1bf2.
    If index zero wasn't a real symbol it has already been filtered out
    in show_symbols so don't skip it in show_symbols_sysv.

    https://sourceware.org/bugzilla/show_bug.cgi?id=25227

    Reported-by: Enzo Matsumiya <ematsumiya@suse.com>
    Signed-off-by: Mark Wielaard <mark@klomp.org>

But if you don't mind I'll keep this bug open to remind myself I need to
checkout the other discrepancies with binutils nm.

-- 
You are receiving this mail because:
You are on the CC list for the bug.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]