This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Libtool 2.2.2

Angelo Graziosi wrote:

> If this is the case, perhaps, there is some problem in setup.ini.
> cygport requires libtool1.5 and libguile17 requires libltdl3.
> So it looks that the set libtool1.5+libltdl3 cannot be removed in favor
> of libtool2.2+libltdl7 (if one needs cygport, libguile17+ dependences).

I may not have been clear.  The libltdl runtime packages should be fine
on their own, it's just the libtool developer packages that are
incompatible.  I don't think there should be a problem if you have
installed libltdl3+libltdl6+libltdl7+(one of libtool1.5 or libtool2.2). 
I'm not sure what libltdl6 is doing in the distro though as nothing
'requires:' it.

This shouldn't be too big of a problem as the libtool packages are only
needed if you relibtoolize something -- which you normally do not when
building from a tarball, only from a VCS checkout.  Though building any
cygport-ized package seems to force the issue since it likes to forcibly
"autoreconf -fvi".


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]