This is the mail archive of the cygwin@sources.redhat.com mailing list for the Cygwin project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: [Perl 5.6] Cpan.pm


If you're using the cygutils version of perl, go here:
  http://cygutils.netpedia.net/V1.1/perl-5.6.0/modules.html

By using the rpm available here: 
   http://cygutils.netpedia.net/V1.1/rpm-3.0.3/index.html

you can install modules into your exising perl (without compiling by
hand).  This ONLY works with the cygutils perl, and using the cygutils
rpm.  I'm not sure why, but Michael's or ReBuM's rpm won't do this
right.

available modules: (libnet is one)

     DBI-1.13-2 
     Data-ShowTable-3.3-2 
     DateManip-5.37-2 
     DelimMatch-1.04-2 
     Digest-MD5-2.09-2 
     HTML-Parser-3.07-1 
     MIME-Base64-2.11-2 
     Msql-Mysql-modules-1.2211-1 
     Parse-Yapp-1.01-1 
     String-CRC-1.0-2 
     String-CRC32-1.2-2 
     URI-1.06-1 
     XML-Grove-0.46alpha-2 
     XML-Parser-2.28-1 
     libnet-1.0703-1 
     libwww-perl-5.48-1 
     libxml-enno-1.00-2 
     libxml-perl-0.07-2 

--Chuck



" Gerrit Haase ?" wrote:
> 
> Hi there Cygwinners,
> 
> anybody out there who tried to install Perlmodules with Cpan.pm?
> 
> I've tried several times, my last hope is to reboot and try again,
> tomorrow.
> 
> I called Cpan.pm like this, set all defaults and tried to:
> install Bundle::CPAN
> 
> i got this error:
> Please, install Net::FTP as soon as possible. CPAN.pm installs it for
> you
> if you just type
>     install Bundle::libnet
> 
> as i tried to install this too, i got the same errors as before,
> kit is complete, no configure found, no makefile:
> 
>   CPAN.pm: Going to build G/GB/GBARR/libnet-1.0703.tar.gz
> 
> Use of uninitialized value in string eq at
> /usr/lib/perl5/5.6.0/ExtUtils/MM_Unix.pm line 110.
> Checking for Socket...ok
> Checking for IO::Socket...ok
> Checking if your kit is complete...
> Looks good
> Can't open perl script "Configure": No such file or directory
> Writing Makefile for Net
> make: *** No targets specified and no makefile found.  Stop.
>   /usr/bin/make  -- NOT OK
> Running make test
>   Oops, make had returned bad status
> Running make install
>   Oops, make had returned bad status
> Bundle summary: The following items in bundle Bundle::libnet had
> installation problems:
>   Net::Telnet
> Use of uninitialized value in chdir at /usr/lib/perl5/5.6.0/CPAN.pm
> line 183.
> 
> ciao,
> 
> - gph -
> 
> --
> Gerrit Peter Haase
> 
> --
> Want to unsubscribe from this list?
> Send a message to cygwin-unsubscribe@sourceware.cygnus.com

--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]