This is the mail archive of the
mailing list for the Cygwin project.
Re: [Patch] cygcheck: Make keyeprint more versatile.
- From: Bas van Gompel <cygwin-patches dot buzz at bavag dot tmfweb dot nl>
- To: cygwin-patches at cygwin dot com
- Date: Thu, 11 Nov 2004 02:49:35 +0100 (MET)
- Subject: Re: [Patch] cygcheck: Make keyeprint more versatile.
- Organisation: Ehm...
- References: <email@example.com> <20041111003551.GA6196@trixie.casa.cgf.cx>
- Reply-to: cygwin-patches mailing-list <cygwin-patches at cygwin dot com>
Op Wed, 10 Nov 2004 19:35:51 -0500 schreef Christopher Faylor
: > * cygcheck.cc (keyeprint): New optional parameters: show_error and
: > print_failed.
: Please check in. Thanks.
: Have I mentioned that I don't like the name 'keyeprint'? It seems like an odd
: name to me.
Well, why don't you change it to something sensible, then?
May I suggest:
sed -i -e 's/keyeprint/display_error/' src/winsup/utils/cygcheck.cc
(I'd post a patch, but am afraid it'd be too large...)
* cygcheck.cc (keyeprint): Rename to display_error.
(display_error): Renamed from keyeprint.
(add_path): keyeprint is now called display_error.
) | | ---/ ---/ Yes, this | This message consists of true | I do not
-- | | / / really is | and false bits entirely. | mail for
) | | / / a 72 by 4 +-------------------------------+ any1 but
-- \--| /--- /--- .sigfile. | |perl -pe "s.u(z)\1.as." | me. 4^re