This is the mail archive of the
mailing list for the Cygwin project.
Re: [Patch] Rebase: new switch --ephemeral
- From: Christopher Faylor <cgf-use-the-mailinglist-please at cygwin dot com>
- To: cygwin-apps at cygwin dot com, Jason Tishler <jason at tishler dot net>
- Date: Mon, 2 Jul 2012 11:49:08 -0400
- Subject: Re: [Patch] Rebase: new switch --ephemeral
- References: <20120620093317.GE15883@calimero.vinschen.de> <17196509.ObZ0OWi6Wo@rainer> <20120702093203.GB19239@calimero.vinschen.de>
- Reply-to: cygwin-apps at cygwin dot com
On Mon, Jul 02, 2012 at 11:32:03AM +0200, Corinna Vinschen wrote:
>On Jun 30 06:45, Achim Gratz wrote:
>> On Wednesday 20 June 2012, 11:33:17, Corinna Vinschen wrote:
>> > If you really want -E to be an exclusive option, then what I'm missing
>> > is the enforcement on the command line.
>> Here's a reworked patch (against rebase-4.2.0-1) that enforces mutual
>> exclusivity between -T and -E; extra files given on the command line are
>> processed with the list and the description has been altered to hopefully be
>> more clear in that respect. This change also forces that only a single such
>> option is present on the command line instead of silently using the last one
>> Typical use of this new option would be:
>> cygport $p compile
>> find $p -name \*.dll -o -name \*.so | rebase -sE -
>> cygport $p test
>> Recording the ephemeral files in the database properly would likely require
>> a new database format and more support functions, so I'm skipping that for
>> now, I also don't see any need for that at the moment.
>You could also just mark them internally in the bitfield (which you
>kinda already do) and then tweak the merge function to sort the
>ephemeral ones independent of the persistent DLLs so the persistent DLLs
>are always compacted from the start base address downwards with
>the ephemeral ones following. Then you just store the persistent ones.
>Jason, it's your call now. You didn't chime in at all so far. I'm not
>sure this is really necessary functionality but it doesn't hurt either
>and it appears to help in some scenarios.
I'm not paying close attention but I have to say that I really don't like
the name "ephemeral" for a switch. Couldn't it be named more precisely
to indicate what it is doing like --no-update-db or something like that?