This is the mail archive of the
mailing list for the Cygwin project.
Re: irssi on cygwin on vista 64bit crashes with 0x00000135 in cygperl5_8.dll
- From: Reini Urban <rurban at x-ray dot at>
- To: cygwin-apps at cygwin dot com, Reini Urban <rurban at x-ray dot at>
- Date: Mon, 14 Jul 2008 19:22:13 +0200
- Subject: Re: irssi on cygwin on vista 64bit crashes with 0x00000135 in cygperl5_8.dll
- References: <email@example.com> <20080714100937.GB28868@calimero.vinschen.de> <20080714101829.GA30660@calimero.vinschen.de>
Corinna Vinschen schrieb:
On Jul 14 12:09, Corinna Vinschen wrote:
On Jul 14 02:33, TB2 wrote:
It's a fresh vista ultimate 64bit install and I installed cygwin with
standard options + irssi, screen and rxvt. Everything working; rxvt and even
screen, but irssi crashes instantly upon execution, no matter if I use cmd
or rxvt as the shell, or if I start it remotely over ssh.
The error code is 0x00000135
I assume it's 0xC0000135 and it means DLL not found. It looks like you
need Perl 5.8 for irssi to run. Try to downgrade perl to 5.8.8-4 using
setup.exe for now.
irssi needs to be upgraded. This was out of my radar. It uses an
embedded perl interpreter.
this sounds like a serious problem with the new perl release to me.
It breaks backward compatibility be just removing a DLL other packages
might rely upon.
But we'd need a full parallel perl-5.8 installation for this issue, not
just the dll in a seperate libperl58 package, which could be added to
the perl dependencies.
In theory I can prepare it, because I use dozens of parallel perls right
now, to test various packages against older versions.
But I rather want to break older packages and force those to be upgraded.
BTW: For me irssi works fine, because I have the dll and the full
If perl 5.10 is meant to be backward compatible with
5.8, shouldn't it offer a cygperl5_8.dll as well, for instance, a
hardlink? However, wouldn't it be better in the long run to have a
No, we are not binary ABI compatible with 5.8 anymore.
We just can support only the non-XS packages.
But we cannot support packages linking to the old 5.8 dll and not
packages using old 5.8 XS code.