]> sourceware.org Git - systemtap.git/blame - systemtap.spec
stapdyn: Fixed the verbose logging of probes found
[systemtap.git] / systemtap.spec
CommitLineData
11059140
RM
1%{!?with_sqlite: %global with_sqlite 1}
2%{!?with_docs: %global with_docs 1}
38105915 3%{!?with_crash: %global with_crash 1}
11059140
RM
4%{!?with_rpm: %global with_rpm 1}
5%{!?with_bundled_elfutils: %global with_bundled_elfutils 0}
e050d62f 6%{!?elfutils_version: %global elfutils_version 0.142}
11059140 7%{!?pie_supported: %global pie_supported 1}
11059140
RM
8%{!?with_boost: %global with_boost 0}
9%{!?with_publican: %global with_publican 1}
60c784bc
FCE
10%if 0%{?rhel}
11%{!?publican_brand: %global publican_brand RedHat}
12%else
11059140 13%{!?publican_brand: %global publican_brand fedora}
60c784bc 14%endif
a40f6057 15%{!?with_dyninst: %global with_dyninst 0%{?fedora} >= 18 || 0%{?rhel} >= 7}
1074f79d 16
a2c9eba7 17Name: systemtap
03f593dc 18Version: 2.1
27aba29a 19Release: 1%{?dist}
59b30bda 20# for version, see also configure.ac
016a35ea
FCE
21
22
23# Packaging abstract:
24#
25# systemtap empty req:-client req:-devel
26# systemtap-server /usr/bin/stap-server*, req:-devel
27# systemtap-devel /usr/bin/stap, runtime, tapset, req:kernel-devel
4b682f2a 28# systemtap-runtime /usr/bin/staprun, /usr/bin/stapsh, /usr/bin/stapdyn
016a35ea
FCE
29# systemtap-client /usr/bin/stap, samples, docs, tapset(bonus), req:-runtime
30# systemtap-initscript /etc/init.d/systemtap, req:systemtap
31# systemtap-sdt-devel /usr/include/sys/sdt.h /usr/bin/dtrace
32# systemtap-testsuite /usr/share/systemtap/testsuite*, req:systemtap, req:sdt-devel
016a35ea
FCE
33#
34# Typical scenarios:
35#
36# stap-client: systemtap-client
37# stap-server: systemtap-server
38# local user: systemtap
39#
40# Unusual scenarios:
41#
42# intermediary stap-client for --remote: systemtap-client (-runtime unused)
43# intermediary stap-server for --use-server: systemtap-server (-devel unused)
44
45Summary: Programmable system-wide instrumentation system
7d838f63 46Group: Development/System
6a1cd8a7 47License: GPLv2+
a2c9eba7 48URL: http://sourceware.org/systemtap/
47b0655b 49Source: ftp://sourceware.org/pub/%{name}/releases/%{name}-%{version}.tar.gz
a2c9eba7 50
016a35ea 51# Build*
37b99e78 52BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
4c895683 53BuildRequires: gcc-c++
48fa6b5e
FCE
54BuildRequires: gettext-devel
55BuildRequires: nss-devel avahi-devel pkgconfig
5ecd6999
JS
56%if %{with_dyninst}
57# include the prerelease version for now, but really this is >= 8.0
58BuildRequires: dyninst-devel >= 7.99
75fcc94e 59BuildRequires: libdwarf-devel
51030d84 60BuildRequires: libselinux-devel
5ecd6999 61%endif
a87d23e3 62%if %{with_sqlite}
c3a3c0c9 63BuildRequires: sqlite-devel
d8c3d602 64%endif
469c1a1b
FCE
65# Needed for libstd++ < 4.0, without <tr1/memory>
66%if %{with_boost}
67BuildRequires: boost-devel
68%endif
a87d23e3 69%if %{with_crash}
d2995e6f 70BuildRequires: crash-devel zlib-devel
1e0716d3 71%endif
2ed04863
WC
72%if %{with_rpm}
73BuildRequires: rpm-devel glibc-headers
74%endif
a87d23e3 75%if %{with_bundled_elfutils}
7d838f63
MH
76Source1: elfutils-%{elfutils_version}.tar.gz
77Patch1: elfutils-portability.patch
d79591b3 78BuildRequires: m4
11059140 79%global setup_elfutils -a1
a2c9eba7
RM
80%else
81BuildRequires: elfutils-devel >= %{elfutils_version}
7d838f63 82%endif
465e8fbf
FCE
83%if %{with_docs}
84BuildRequires: /usr/bin/latex /usr/bin/dvips /usr/bin/ps2pdf latex2html
6275c8d7
DS
85# On F10, xmlto's pdf support was broken off into a sub-package,
86# called 'xmlto-tex'. To avoid a specific F10 BuildReq, we'll do a
87# file-based buildreq on '/usr/share/xmlto/format/fo/pdf'.
88BuildRequires: xmlto /usr/share/xmlto/format/fo/pdf
53ade4da
MW
89%if %{with_publican}
90BuildRequires: publican
59c75f19 91BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
53ade4da 92%endif
465e8fbf 93%endif
14df5fde 94
016a35ea
FCE
95# Install requirements
96Requires: systemtap-client = %{version}-%{release}
97Requires: systemtap-devel = %{version}-%{release}
98
7d838f63 99%description
f89ff3e2 100SystemTap is an instrumentation system for systems running Linux.
016a35ea
FCE
101Developers can write instrumentation scripts to collect data on
102the operation of the system. The base systemtap package contains/requires
103the components needed to locally develop and execute systemtap scripts.
104
105# ------------------------------------------------------------------------
106
107%package server
108Summary: Instrumentation System Server
109Group: Development/System
110License: GPLv2+
111URL: http://sourceware.org/systemtap/
112Requires: systemtap-devel = %{version}-%{release}
113# On RHEL[45], /bin/mktemp comes from the 'mktemp' package. On newer
114# distributions, /bin/mktemp comes from the 'coreutils' package. To
115# avoid a specific RHEL[45] Requires, we'll do a file-based require.
116Requires: nss /bin/mktemp
117Requires: zip unzip
118Requires(pre): shadow-utils
119Requires(post): chkconfig
120Requires(preun): chkconfig
121Requires(preun): initscripts
122Requires(postun): initscripts
123BuildRequires: nss-devel avahi-devel
124
125%description server
126This is the remote script compilation server component of systemtap.
127It announces itself to nearby clients with avahi (if available), and
128compiles systemtap scripts to kernel objects on their demand.
129
130
131%package devel
132Summary: Programmable system-wide instrumentation system - development headers, tools
133Group: Development/System
134License: GPLv2+
135URL: http://sourceware.org/systemtap/
136Requires: kernel >= 2.6.9-11
137# Alternate kernel packages kernel-PAE-devel et al. have a virtual
138# provide for kernel-devel, so this requirement does the right thing,
139# at least past RHEL4.
140Requires: kernel-devel
4c895683 141Requires: gcc make
016a35ea
FCE
142# Suggest: kernel-debuginfo
143
144%description devel
145This package contains the components needed to compile a systemtap
146script from source form into executable (.ko) forms. It may be
147installed on a self-contained developer workstation (along with the
148systemtap-client and systemtap-runtime packages), or on a dedicated
149remote server (alongside the systemtap-server package). It includes
150a copy of the standard tapset library and the runtime library C files.
151
7d838f63 152
a63a95dc 153%package runtime
016a35ea 154Summary: Programmable system-wide instrumentation system - runtime
a63a95dc 155Group: Development/System
6a1cd8a7 156License: GPLv2+
a63a95dc
DS
157URL: http://sourceware.org/systemtap/
158Requires: kernel >= 2.6.9-11
378a5245 159Requires(pre): shadow-utils
a63a95dc
DS
160
161%description runtime
016a35ea
FCE
162SystemTap runtime contains the components needed to execute
163a systemtap script that was already compiled into a module
164using a local or remote systemtap-devel installation.
a63a95dc 165
016a35ea
FCE
166
167%package client
168Summary: Programmable system-wide instrumentation system - client
8f3c45cc
FCE
169Group: Development/System
170License: GPLv2+
171URL: http://sourceware.org/systemtap/
016a35ea
FCE
172Requires: zip unzip
173Requires: systemtap-runtime = %{version}-%{release}
174Requires: coreutils grep sed unzip zip
175Requires: openssh-clients
8f3c45cc 176
016a35ea
FCE
177%description client
178This package contains/requires the components needed to develop
179systemtap scripts, and compile them using a local systemtap-devel
180or a remote systemtap-server installation, then run them using a
181local or remote systemtap-runtime. It includes script samples and
182documentation, and a copy of the tapset library for reference.
8f3c45cc 183
016a35ea
FCE
184
185%package initscript
186Summary: Systemtap Initscripts
d9d14e20
DB
187Group: Development/System
188License: GPLv2+
189URL: http://sourceware.org/systemtap/
ad12652e 190Requires: systemtap = %{version}-%{release}
e2a741be
DB
191Requires(post): chkconfig
192Requires(preun): chkconfig
193Requires(preun): initscripts
194Requires(postun): initscripts
d9d14e20 195
016a35ea
FCE
196%description initscript
197Sysvinit scripts to launch selected systemtap scripts at system startup.
198
d9d14e20 199
b899aa79
SC
200%package sdt-devel
201Summary: Static probe support tools
202Group: Development/System
920b103a 203License: GPLv2+ and Public Domain
b899aa79 204URL: http://sourceware.org/systemtap/
b899aa79
SC
205
206%description sdt-devel
016a35ea
FCE
207This package includes the <sys/sdt.h> header file used for static
208instrumentation compiled into userspace programs and libraries, along
209with the optional dtrace-compatibility preprocessor to process related
210.d files into tracing-macro-laden .h headers.
b899aa79 211
016a35ea
FCE
212
213%package testsuite
214Summary: Instrumentation System Testsuite
9a8d8be3
MH
215Group: Development/System
216License: GPLv2+
217URL: http://sourceware.org/systemtap/
016a35ea
FCE
218Requires: systemtap = %{version}-%{release}
219Requires: systemtap-sdt-devel = %{version}-%{release}
d6d8634e 220Requires: systemtap-server = %{version}-%{release}
cf638735 221Requires: dejagnu which elfutils grep nc
4c895683 222Requires: gcc gcc-c++ make glibc-devel
cf638735
SC
223%ifnarch ia64
224Requires: prelink
225%endif
d6d8634e
DS
226# testsuite/systemtap.server/client.exp needs avahi
227Requires: avahi
228%if %{with_crash}
229# testsuite/systemtap.base/crash.exp needs crash
230Requires: crash
231%endif
07547775 232%ifarch x86_64
e2d574cc 233Requires: /usr/lib/libc.so
b9770214
FCE
234# ... and /usr/lib/libgcc_s.so.*
235# ... and /usr/lib/libstdc++.so.*
4c895683 236%endif
016a35ea
FCE
237
238%description testsuite
239This package includes the dejagnu-based systemtap stress self-testing
240suite. This may be used by system administrators to thoroughly check
241systemtap on the current system.
9a8d8be3 242
9a8d8be3 243
016a35ea
FCE
244# ------------------------------------------------------------------------
245
7d838f63 246%prep
a2c9eba7
RM
247%setup -q %{?setup_elfutils}
248
a87d23e3 249%if %{with_bundled_elfutils}
7d838f63
MH
250cd elfutils-%{elfutils_version}
251%patch1 -p1
a2c9eba7
RM
252sleep 1
253find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
254sleep 1
255find . \( -name configure -o -name config.h.in \) -print | xargs touch
7d838f63
MH
256cd ..
257%endif
258
259%build
a2c9eba7 260
a87d23e3 261%if %{with_bundled_elfutils}
7d838f63 262# Build our own copy of elfutils.
11059140 263%global elfutils_config --with-elfutils=elfutils-%{elfutils_version}
a2c9eba7
RM
264
265# We have to prevent the standard dependency generation from identifying
266# our private elfutils libraries in our provides and requires.
11059140
RM
267%global _use_internal_dependency_generator 0
268%global filter_eulibs() /bin/sh -c "%{1} | sed '/libelf/d;/libdw/d;/libebl/d'"
269%global __find_provides %{filter_eulibs /usr/lib/rpm/find-provides}
270%global __find_requires %{filter_eulibs /usr/lib/rpm/find-requires}
4dbd685d
RM
271
272# This will be needed for running stap when not installed, for the test suite.
11059140 273%global elfutils_mflags LD_LIBRARY_PATH=`pwd`/lib-elfutils
7d838f63
MH
274%endif
275
5ecd6999
JS
276# Enable/disable the dyninst pure-userspace backend
277%if %{with_dyninst}
278%global dyninst_config --with-dyninst
279%else
280%global dyninst_config --without-dyninst
281%endif
282
9921a199 283# Enable/disable the sqlite coverage testing support
a87d23e3 284%if %{with_sqlite}
11059140 285%global sqlite_config --enable-sqlite
9921a199 286%else
11059140 287%global sqlite_config --disable-sqlite
d8c3d602
WC
288%endif
289
a87d23e3
DS
290# Enable/disable the crash extension
291%if %{with_crash}
11059140 292%global crash_config --enable-crash
a87d23e3 293%else
11059140 294%global crash_config --disable-crash
a87d23e3
DS
295%endif
296
2ed04863
WC
297# Enable/disable the code to find and suggest needed rpms
298%if %{with_rpm}
11059140 299%global rpm_config --with-rpm
2ed04863 300%else
11059140 301%global rpm_config --without-rpm
2ed04863
WC
302%endif
303
465e8fbf 304%if %{with_docs}
11059140 305%global docs_config --enable-docs
465e8fbf 306%else
11059140 307%global docs_config --disable-docs
465e8fbf
FCE
308%endif
309
e1e3ba36
RA
310# Enable pie as configure defaults to disabling it
311%if %{pie_supported}
11059140 312%global pie_config --enable-pie
e1e3ba36 313%else
11059140 314%global pie_config --disable-pie
e1e3ba36 315%endif
465e8fbf 316
53ade4da 317%if %{with_publican}
11059140 318%global publican_config --enable-publican --with-publican-brand=%{publican_brand}
53ade4da 319%else
11059140 320%global publican_config --disable-publican
53ade4da
MW
321%endif
322
465e8fbf 323
6ea5debd 324%configure %{?elfutils_config} %{dyninst_config} %{sqlite_config} %{crash_config} %{docs_config} %{pie_config} %{publican_config} %{rpm_config} --disable-silent-rules --with-extra-version="rpm %{version}-%{release}"
a2c9eba7 325make %{?_smp_mflags}
2a4b42eb 326
ec4d1558
MW
327%install
328rm -rf ${RPM_BUILD_ROOT}
329make DESTDIR=$RPM_BUILD_ROOT install
9564097a 330%find_lang %{name}
ec4d1558 331
c256c4a6
MW
332# We want the examples in the special doc dir, not the build install dir.
333# We build it in place and then move it away so it doesn't get installed
334# twice. rpm can specify itself where the (versioned) docs go with the
335# %doc directive.
ec4d1558
MW
336mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/examples examples
337
d2995e6f
FCE
338# Fix paths in the example & testsuite scripts
339find examples testsuite -type f -name '*.stp' -print0 | xargs -0 sed -i -r -e '1s@^#!.+stap@#!%{_bindir}/stap@'
7d838f63 340
414e04de
DS
341# To make rpmlint happy, remove any .gitignore files in the testsuite.
342find testsuite -type f -name '.gitignore' -print0 | xargs -0 rm -f
343
b7565b41 344# Because "make install" may install staprun with whatever mode, the
98aab489
DS
345# post-processing programs rpmbuild runs won't be able to read it.
346# So, we change permissions so that they can read it. We'll set the
b7565b41 347# permissions back to 04110 in the %files section below.
98aab489
DS
348chmod 755 $RPM_BUILD_ROOT%{_bindir}/staprun
349
cd4d1d39
WC
350#install the useful stap-prep script
351install -c -m 755 stap-prep $RPM_BUILD_ROOT%{_bindir}/stap-prep
352
8f3c45cc
FCE
353# Copy over the testsuite
354cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
355
4040e9ea 356%if %{with_docs}
7fe437e6 357# We want the manuals in the special doc dir, not the generic doc install dir.
c256c4a6
MW
358# We build it in place and then move it away so it doesn't get installed
359# twice. rpm can specify itself where the (versioned) docs go with the
360# %doc directive.
7fe437e6
MW
361mkdir docs.installed
362mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
5bfd7a37 363mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
53ade4da
MW
364%if %{with_publican}
365mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/SystemTap_Beginners_Guide docs.installed/
366%endif
4040e9ea 367%endif
7fe437e6 368
e2a741be
DB
369mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
370install -m 755 initscript/systemtap $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
9a8d8be3
MH
371mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap
372mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/conf.d
373mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/script.d
e2a741be 374install -m 644 initscript/config.systemtap $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/config
9a8d8be3
MH
375mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/systemtap
376mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/systemtap
09070e8a 377
e2a741be 378install -m 755 initscript/stap-server $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
2f78bee0
DB
379mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server
380mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server/conf.d
c982e923 381mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
e2a741be 382install -m 644 initscript/config.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/stap-server
2648a9b4
DB
383mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server
384touch $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server/log
962906a7
DS
385mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
386install -m 644 initscript/logrotate.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/stap-server
9a8d8be3 387
7d838f63
MH
388%clean
389rm -rf ${RPM_BUILD_ROOT}
390
378a5245 391%pre runtime
9d2b21df
FCE
392getent group stapusr >/dev/null || groupadd -g 156 -r stapusr 2>/dev/null || groupadd -r stapusr
393getent group stapsys >/dev/null || groupadd -g 157 -r stapsys 2>/dev/null || groupadd -r stapsys
394getent group stapdev >/dev/null || groupadd -g 158 -r stapdev 2>/dev/null || groupadd -r stapdev
efc4bf9a 395exit 0
98aab489 396
7433d0cf 397%pre server
9d2b21df 398getent group stap-server >/dev/null || groupadd -g 155 -r stap-server 2>/dev/null || groupadd -r stap-server
2648a9b4 399getent passwd stap-server >/dev/null || \
9d2b21df 400 useradd -c "Systemtap Compile Server" -u 155 -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server 2>/dev/null || \
2648a9b4 401 useradd -c "Systemtap Compile Server" -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server
c33bb0d6 402test -e ~stap-server && chmod 755 ~stap-server
878b2f3f
CM
403
404if [ ! -f ~stap-server/.systemtap/rc ]; then
405 mkdir -p ~stap-server/.systemtap
406 chown stap-server:stap-server ~stap-server/.systemtap
407 echo "--rlimit-as=614400000 --rlimit-cpu=60 --rlimit-nproc=20 --rlimit-stack=1024000 --rlimit-fsize=51200000" > ~stap-server/.systemtap/rc
408 chown stap-server:stap-server ~stap-server/.systemtap/rc
409fi
7433d0cf
DB
410exit 0
411
09070e8a 412%post server
962906a7
DS
413test -e %{_localstatedir}/log/stap-server/log || {
414 touch %{_localstatedir}/log/stap-server/log
415 chmod 664 %{_localstatedir}/log/stap-server/log
416 chown stap-server:stap-server %{_localstatedir}/log/stap-server/log
417}
994e8c2c 418# If it does not already exist, as stap-server, generate the certificate
2648a9b4
DB
419# used for signing and for ssl.
420if test ! -e ~stap-server/.systemtap/ssl/server/stap.cert; then
421 runuser -s /bin/sh - stap-server -c %{_libexecdir}/%{name}/stap-gen-cert >/dev/null
2648a9b4 422fi
03301bc3 423# Activate the service
e2a741be 424/sbin/chkconfig --add stap-server
09070e8a
DB
425exit 0
426
045e193d
FCE
427%triggerin client -- systemtap-server
428if test -e ~stap-server/.systemtap/ssl/server/stap.cert; then
429 # echo Authorizing ssl-peer/trusted-signer certificate for local systemtap-server
430 %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/ssl/client >/dev/null
431 %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/staprun >/dev/null
432fi
433exit 0
434# XXX: corresponding %triggerun?
435
09070e8a 436%preun server
d210cb1c
DB
437# Check that this is the actual deinstallation of the package, as opposed to
438# just removing the old package on upgrade.
e2a741be
DB
439if [ $1 = 0 ] ; then
440 /sbin/service stap-server stop >/dev/null 2>&1
441 /sbin/chkconfig --del stap-server
442fi
443exit 0
444
445%postun server
d210cb1c
DB
446# Check whether this is an upgrade of the package.
447# If so, restart the service if it's running
e2a741be
DB
448if [ "$1" -ge "1" ] ; then
449 /sbin/service stap-server condrestart >/dev/null 2>&1 || :
450fi
09070e8a
DB
451exit 0
452
9a8d8be3 453%post initscript
e2a741be 454/sbin/chkconfig --add systemtap
9a8d8be3
MH
455exit 0
456
457%preun initscript
d210cb1c
DB
458# Check that this is the actual deinstallation of the package, as opposed to
459# just removing the old package on upgrade.
e2a741be
DB
460if [ $1 = 0 ] ; then
461 /sbin/service systemtap stop >/dev/null 2>&1
462 /sbin/chkconfig --del systemtap
463fi
464exit 0
465
466%postun initscript
d210cb1c
DB
467# Check whether this is an upgrade of the package.
468# If so, restart the service if it's running
e2a741be
DB
469if [ "$1" -ge "1" ] ; then
470 /sbin/service systemtap condrestart >/dev/null 2>&1 || :
471fi
9a8d8be3
MH
472exit 0
473
1208cc21
FCE
474%post
475# Remove any previously-built uprobes.ko materials
2648a9b4 476(make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
70f2bd1f 477(/sbin/rmmod uprobes) >/dev/null 2>&1 || true
1208cc21
FCE
478
479%preun
480# Ditto
2648a9b4 481(make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
70f2bd1f 482(/sbin/rmmod uprobes) >/dev/null 2>&1 || true
9a8d8be3 483
016a35ea
FCE
484# ------------------------------------------------------------------------
485
9564097a 486%files -f %{name}.lang
016a35ea
FCE
487# The master "systemtap" rpm doesn't include any files.
488
489%files server -f %{name}.lang
7d838f63 490%defattr(-,root,root)
016a35ea
FCE
491%{_bindir}/stap-server
492%dir %{_libexecdir}/%{name}
493%{_libexecdir}/%{name}/stap-serverd
494%{_libexecdir}/%{name}/stap-start-server
495%{_libexecdir}/%{name}/stap-stop-server
496%{_libexecdir}/%{name}/stap-gen-cert
497%{_libexecdir}/%{name}/stap-sign-module
045e193d 498%{_libexecdir}/%{name}/stap-authorize-cert
39277d64 499%{_libexecdir}/%{name}/stap-env
016a35ea
FCE
500%{_mandir}/man7/stappaths.7*
501%{_mandir}/man8/stap-server.8*
502%{_sysconfdir}/rc.d/init.d/stap-server
503%config(noreplace) %{_sysconfdir}/logrotate.d/stap-server
504%dir %{_sysconfdir}/stap-server
505%dir %{_sysconfdir}/stap-server/conf.d
506%config(noreplace) %{_sysconfdir}/sysconfig/stap-server
507%dir %attr(0755,stap-server,stap-server) %{_localstatedir}/log/stap-server
508%ghost %config(noreplace) %attr(0644,stap-server,stap-server) %{_localstatedir}/log/stap-server/log
509%ghost %attr(0755,stap-server,stap-server) %{_localstatedir}/run/stap-server
462c69cc 510%ghost %attr(0750,stap-server,stap-server) %{_localstatedir}/lib/stap-server
016a35ea
FCE
511%doc initscript/README.stap-server
512%doc README README.unprivileged AUTHORS NEWS COPYING
a2c9eba7 513
a2c9eba7 514
016a35ea 515%files devel -f %{name}.lang
a2c9eba7 516%{_bindir}/stap
cd4d1d39 517%{_bindir}/stap-prep
b0ff684d 518%{_bindir}/stap-report
3451624d 519%dir %{_datadir}/%{name}
bcdfb17d
DS
520%{_datadir}/%{name}/runtime
521%{_datadir}/%{name}/tapset
016a35ea
FCE
522%{_mandir}/man1/stap.1*
523%{_mandir}/man7/stappaths.7*
524%doc README README.unprivileged AUTHORS NEWS COPYING
a87d23e3 525%if %{with_bundled_elfutils}
75ab1a70 526%dir %{_libdir}/%{name}
8f3c45cc 527%{_libdir}/%{name}/lib*.so*
7d838f63 528%endif
a2c9eba7 529
5ecd6999 530
9564097a 531%files runtime -f %{name}.lang
a63a95dc 532%defattr(-,root,root)
b7565b41 533%attr(4110,root,stapusr) %{_bindir}/staprun
e96f2257 534%{_bindir}/stapsh
6c2c4d8e 535%{_bindir}/stap-merge
b0ff684d 536%{_bindir}/stap-report
8ff439fa 537%if %{with_dyninst}
4b682f2a 538%{_bindir}/stapdyn
8ff439fa 539%endif
75ab1a70 540%dir %{_libexecdir}/%{name}
43a03765 541%{_libexecdir}/%{name}/stapio
edecda6c 542%{_libexecdir}/%{name}/stap-authorize-cert
38105915 543%if %{with_crash}
75ab1a70 544%dir %{_libdir}/%{name}
38105915
WC
545%{_libdir}/%{name}/staplog.so*
546%endif
4e47b3c4 547%{_mandir}/man7/stappaths.7*
0bda9740 548%{_mandir}/man8/staprun.8*
b569591a 549%doc README README.security AUTHORS NEWS COPYING
7d838f63 550
8f3c45cc 551
016a35ea 552%files client -f %{name}.lang
d9d14e20 553%defattr(-,root,root)
016a35ea
FCE
554%doc README README.unprivileged AUTHORS NEWS COPYING examples
555%if %{with_docs}
556%doc docs.installed/*.pdf
557%doc docs.installed/tapsets/*.html
558%if %{with_publican}
559%doc docs.installed/SystemTap_Beginners_Guide
560%endif
561%endif
562%{_bindir}/stap
563%{_bindir}/stap-prep
564%{_bindir}/stap-report
565%{_mandir}/man1/stap.1*
566%{_mandir}/man1/stap-merge.1*
567%{_mandir}/man3/*
4e47b3c4 568%{_mandir}/man7/stappaths.7*
016a35ea
FCE
569%dir %{_datadir}/%{name}
570%{_datadir}/%{name}/tapset
571
8f3c45cc 572
b899aa79 573
9a8d8be3
MH
574%files initscript
575%defattr(-,root,root)
e2a741be 576%{_sysconfdir}/rc.d/init.d/systemtap
9a8d8be3
MH
577%dir %{_sysconfdir}/systemtap
578%dir %{_sysconfdir}/systemtap/conf.d
579%dir %{_sysconfdir}/systemtap/script.d
580%config(noreplace) %{_sysconfdir}/systemtap/config
581%dir %{_localstatedir}/cache/systemtap
d1bf48fa 582%ghost %{_localstatedir}/run/systemtap
e2a741be 583%doc initscript/README.systemtap
9a8d8be3 584
016a35ea
FCE
585
586%files sdt-devel -f %{name}.lang
587%defattr(-,root,root)
588%{_bindir}/dtrace
589%{_includedir}/sys/sdt.h
590%{_includedir}/sys/sdt-config.h
591%{_mandir}/man1/dtrace.1*
592%doc README AUTHORS NEWS COPYING
593
594
595%files testsuite
596%defattr(-,root,root)
597%dir %{_datadir}/%{name}
598%{_datadir}/%{name}/testsuite
599
600
016a35ea 601# ------------------------------------------------------------------------
9a8d8be3 602
7d838f63 603%changelog
a63381cc
JS
604* Tue Oct 09 2012 Josh Stone <jistone@redhat.com> - 2.0-1
605- Upstream release.
606
07547775
PR
607* Fri Jul 13 2012 Peter Robinson <pbrobinson@fedoraproject.org>
608- Fix ifarch statement
e2d574cc 609- use file based requires for glibc-devel on x86_64 so that we work in koji
07547775 610
48fa6b5e
FCE
611* Sun Jun 17 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-1
612- Upstream release.
613
83bd2699
FCE
614* Wed Feb 01 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-1
615- Upstream release.
616
87600139
DS
617* Fri Jan 13 2012 David Smith <dsmith@redhat.com> - 1.6-2
618- Fixed /bin/mktemp require.
619
aff1eaa0
FCE
620* Mon Jul 25 2011 Stan Cox <scox@redhat.com> - 1.6-1
621- Upstream release.
622
623* Tue May 23 2011 Stan Cox <scox@redhat.com> - 1.5-1
624- Upstream release.
625
6e0c15da
FCE
626* Mon Jan 17 2011 Frank Ch. Eigler <fche@redhat.com> - 1.4-1
627- Upstream release.
628
e12e958f
JS
629* Wed Jul 21 2010 Josh Stone <jistone@redhat.com> - 1.3-1
630- Upstream release.
631
e36ba31a
FCE
632* Mon Mar 22 2010 Frank Ch. Eigler <fche@redhat.com> - 1.2-1
633- Upstream release.
634
0710d850
DS
635* Mon Dec 21 2009 David Smith <dsmith@redhat.com> - 1.1-1
636- Upstream release.
637
6a7aa1a1
JS
638* Tue Sep 22 2009 Josh Stone <jistone@redhat.com> - 1.0-1
639- Upstream release.
640
1e9b189f
JS
641* Tue Aug 4 2009 Josh Stone <jistone@redhat.com> - 0.9.9-1
642- Upstream release.
643
e1774a7f
JS
644* Thu Jun 11 2009 Josh Stone <jistone@redhat.com> - 0.9.8-1
645- Upstream release.
646
9b055ab2 647* Thu Apr 23 2009 Josh Stone <jistone@redhat.com> - 0.9.7-1
225d8d4b
JS
648- Upstream release.
649
27aba29a
JS
650* Fri Mar 27 2009 Josh Stone <jistone@redhat.com> - 0.9.5-1
651- Upstream release.
652
fab6ce30
WC
653* Wed Mar 18 2009 Will Cohen <wcohen@redhat.com> - 0.9-2
654- Add location of man pages.
655
c8bf931d
FCE
656* Tue Feb 17 2009 Frank Ch. Eigler <fche@redhat.com> - 0.9-1
657- Upstream release.
658
70f5a7b3
FCE
659* Thu Nov 13 2008 Frank Ch. Eigler <fche@redhat.com> - 0.8-1
660- Upstream release.
661
cfaa068c
FCE
662* Tue Jul 15 2008 Frank Ch. Eigler <fche@redhat.com> - 0.7-1
663- Upstream release.
664
d2995e6f
FCE
665* Fri Feb 1 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-3
666- Add zlib-devel to buildreq; missing from crash-devel
667- Process testsuite .stp files for #!stap->#!/usr/bin/stap
668
bfe2b4ab 669* Fri Jan 18 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-1
1e0716d3
FCE
670- Add crash-devel buildreq to build staplog.so crash(8) module.
671- Many robustness & functionality improvements:
672
47b0655b
WC
673* Wed Dec 5 2007 Will Cohen <wcohen@redhat.com> - 0.6-2
674- Correct Source to point to location contain code.
675
98aab489
DS
676* Thu Aug 9 2007 David Smith <dsmith@redhat.com> - 0.6-1
677- Bumped version, added libcap-devel BuildRequires.
678
d8c3d602
WC
679* Wed Jul 11 2007 Will Cohen <wcohen@redhat.com> - 0.5.14-2
680- Fix Requires and BuildRequires for sqlite.
681
c1edaa30
FCE
682* Tue Jul 2 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.14-1
683- Many robustness improvements: 1117, 1134, 1305, 1307, 1570, 1806,
684 2033, 2116, 2224, 2339, 2341, 2406, 2426, 2438, 2583, 3037,
685 3261, 3282, 3331, 3428 3519, 3545, 3625, 3648, 3880, 3888, 3911,
686 3952, 3965, 4066, 4071, 4075, 4078, 4081, 4096, 4119, 4122, 4127,
687 4146, 4171, 4179, 4183, 4221, 4224, 4254, 4281, 4319, 4323, 4326,
688 4329, 4332, 4337, 4415, 4432, 4444, 4445, 4458, 4467, 4470, 4471,
689 4518, 4567, 4570, 4579, 4589, 4609, 4664
690
aa384dcd
FCE
691* Mon Mar 26 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.13-1
692- An emergency / preliminary refresh, mainly for compatibility
693 with 2.6.21-pre kernels.
2a4b42eb 694
31982bd2
FCE
695* Mon Jan 1 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.12-1
696- Many changes, see NEWS file.
697
a63a95dc
DS
698* Tue Sep 26 2006 David Smith <dsmith@redhat.com> - 0.5.10-1
699- Added 'systemtap-runtime' subpackage.
700
d65d6b27
RM
701* Wed Jul 19 2006 Roland McGrath <roland@redhat.com> - 0.5.9-1
702- PRs 2669, 2913
703
c1d6a343
RM
704* Fri Jun 16 2006 Roland McGrath <roland@redhat.com> - 0.5.8-1
705- PRs 2627, 2520, 2228, 2645
706
f6291560 707* Fri May 5 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.7-1
6f231a27
FCE
708- PRs 2511 2453 2307 1813 1944 2497 2538 2476 2568 1341 2058 2220 2437
709 1326 2014 2599 2427 2438 2465 1930 2149 2610 2293 2634 2506 2433
710
611010bf
RM
711* Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.5.5-1
712- Many changes, affected PRs include: 2068, 2293, 1989, 2334,
713 1304, 2390, 2425, 953.
714
be9923ac
FCE
715* Wed Feb 1 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.4-1
716- PRs 1916, 2205, 2142, 2060, 1379
717
db6a8a10
RM
718* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 0.5.3-1
719- Many changes, affected PRs include: 2056, 1144, 1379, 2057,
720 2060, 1972, 2140, 2148
721
dcf0c541
RM
722* Mon Dec 19 2005 Roland McGrath <roland@redhat.com> - 0.5.2-1
723- Fixed build with gcc 4.1, various tapset changes.
724
4d9087fc
RM
725* Wed Dec 7 2005 Roland McGrath <roland@redhat.com> - 0.5.1-1
726- elfutils update, build changes
727
e94c050c 728* Fri Dec 02 2005 Frank Ch. Eigler <fche@redhat.com> - 0.5-1
7d9e8974
FCE
729- Many fixes and improvements: 1425, 1536, 1505, 1380, 1329, 1828, 1271,
730 1339, 1340, 1345, 1837, 1917, 1903, 1336, 1868, 1594, 1564, 1276, 1295
731
ae65ed5c
RM
732* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.4.2-1
733- Many fixes and improvements: PRs 1344, 1260, 1330, 1295, 1311, 1368,
734 1182, 1131, 1332, 1366, 1456, 1271, 1338, 1482, 1477, 1194.
735
66bb48fd
RM
736* Wed Sep 14 2005 Roland McGrath <roland@redhat.com> - 0.4.1-1
737- Many fixes and improvements since 0.2.2; relevant PRs include:
738 1122, 1134, 1155, 1172, 1174, 1175, 1180, 1186, 1187, 1191, 1193, 1195,
739 1197, 1205, 1206, 1209, 1213, 1244, 1257, 1258, 1260, 1265, 1268, 1270,
740 1289, 1292, 1306, 1335, 1257
741
323904e0
FCE
742* Wed Sep 7 2005 Frank Ch. Eigler <fche@redhat.com>
743- Bump version.
744
03f23d0f 745* Wed Aug 16 2005 Frank Ch. Eigler <fche@redhat.com>
83ff1cf9
FCE
746- Bump version.
747
2205d115
MH
748* Wed Aug 3 2005 Martin Hunt <hunt@redhat.com> - 0.2.2-1
749- Add directory /var/cache/systemtap
750- Add stp_check to /usr/libexec/systemtap
751
351e76d3
RM
752* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 0.2.1-1
753- New version 0.2.1, various fixes.
754
4dbd685d
RM
755* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.2-1
756- New version 0.2, requires elfutils 0.111
757
a2c9eba7
RM
758* Mon Jul 25 2005 Roland McGrath <roland@redhat.com>
759- Clean up spec file, build bundled elfutils.
760
7d838f63
MH
761* Thu Jul 21 2005 Martin Hunt <hunt@redhat.com>
762- Set Version to use version from autoconf.
763- Fix up some of the path names.
a2c9eba7
RM
764- Add Requires and BuildRequires.
765
766* Wed Jul 19 2005 Will Cohen <wcohen@redhat.com>
7d838f63 767- Initial creation of RPM.
This page took 0.237825 seconds and 5 git commands to generate.