]> sourceware.org Git - systemtap.git/blame - systemtap.spec
Put man pages from tapset in 3stap (PR9870).
[systemtap.git] / systemtap.spec
CommitLineData
4040e9ea 1%{!?release: %define release 1}
b00e123d 2%{!?with_sqlite: %define with_sqlite 1}
4040e9ea
FCE
3%{!?with_docs: %define with_docs 1}
4%{!?with_crash: %define with_crash 0}
5%{!?with_bundled_elfutils: %define with_bundled_elfutils 0}
6%{!?elfutils_version: %define elfutils_version 0.127}
1074f79d 7
a2c9eba7 8Name: systemtap
bc44995a 9# for version, see also configure.ac
c8bf931d 10Version: 0.9
1074f79d 11Release: %{release}%{?dist}
7d838f63 12Summary: Instrumentation System
7d838f63 13Group: Development/System
6a1cd8a7 14License: GPLv2+
a2c9eba7 15URL: http://sourceware.org/systemtap/
47b0655b 16Source: ftp://sourceware.org/pub/%{name}/releases/%{name}-%{version}.tar.gz
a2c9eba7 17
37b99e78 18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
a2c9eba7
RM
19
20Requires: kernel >= 2.6.9-11
a87d23e3 21%if %{with_sqlite}
c3a3c0c9 22BuildRequires: sqlite-devel
d8c3d602 23%endif
a87d23e3 24%if %{with_crash}
d2995e6f 25BuildRequires: crash-devel zlib-devel
1e0716d3 26%endif
b00e123d
RM
27# Alternate kernel packages kernel-PAE-devel et al have a virtual
28# provide for kernel-devel, so this requirement does the right thing.
29Requires: kernel-devel
aab2b35f 30Requires: gcc make
9ae6172f 31# Suggest: kernel-debuginfo
a63a95dc 32Requires: systemtap-runtime = %{version}-%{release}
6275c8d7 33BuildRequires: nss-devel
7d838f63 34
a87d23e3 35%if %{with_bundled_elfutils}
7d838f63
MH
36Source1: elfutils-%{elfutils_version}.tar.gz
37Patch1: elfutils-portability.patch
38%define setup_elfutils -a1
a2c9eba7
RM
39%else
40BuildRequires: elfutils-devel >= %{elfutils_version}
7d838f63 41%endif
a87d23e3
DS
42%if %{with_crash}
43Requires: crash
44%endif
7d838f63 45
465e8fbf
FCE
46%if %{with_docs}
47BuildRequires: /usr/bin/latex /usr/bin/dvips /usr/bin/ps2pdf latex2html
6275c8d7
DS
48# On F10, xmlto's pdf support was broken off into a sub-package,
49# called 'xmlto-tex'. To avoid a specific F10 BuildReq, we'll do a
50# file-based buildreq on '/usr/share/xmlto/format/fo/pdf'.
51BuildRequires: xmlto /usr/share/xmlto/format/fo/pdf
465e8fbf
FCE
52%endif
53
7d838f63 54%description
a2c9eba7
RM
55SystemTap is an instrumentation system for systems running Linux 2.6.
56Developers can write instrumentation to collect data on the operation
57of the system.
7d838f63 58
a63a95dc
DS
59%package runtime
60Summary: Instrumentation System Runtime
61Group: Development/System
6a1cd8a7 62License: GPLv2+
a63a95dc
DS
63URL: http://sourceware.org/systemtap/
64Requires: kernel >= 2.6.9-11
378a5245 65Requires(pre): shadow-utils
a63a95dc
DS
66
67%description runtime
68SystemTap runtime is the runtime component of an instrumentation
69system for systems running Linux 2.6. Developers can write
70instrumentation to collect data on the operation of the system.
71
8f3c45cc
FCE
72%package testsuite
73Summary: Instrumentation System Testsuite
74Group: Development/System
75License: GPLv2+
76URL: http://sourceware.org/systemtap/
0fda8ffb 77Requires: systemtap dejagnu
8f3c45cc
FCE
78
79%description testsuite
80The testsuite allows testing of the entire SystemTap toolchain
81without having to rebuild from sources.
82
d9d14e20
DB
83%package client
84Summary: Instrumentation System Client
85Group: Development/System
86License: GPLv2+
87URL: http://sourceware.org/systemtap/
88Requires: systemtap-runtime = %{version}-%{release}
1cecb3c5 89Requires: avahi avahi-tools nss nss-tools mktemp
d9d14e20
DB
90
91%description client
92SystemTap client is the client component of an instrumentation
93system for systems running Linux 2.6. Developers can write
94instrumentation to collect data on the operation of the system.
95
96%package server
97Summary: Instrumentation System Server
98Group: Development/System
99License: GPLv2+
100URL: http://sourceware.org/systemtap/
101Requires: systemtap
1cecb3c5 102Requires: avahi avahi-tools nss nss-tools mktemp
d9d14e20
DB
103
104%description server
105SystemTap server is the server component of an instrumentation
106system for systems running Linux 2.6. Developers can write
107instrumentation to collect data on the operation of the system.
108
b899aa79
SC
109%package sdt-devel
110Summary: Static probe support tools
111Group: Development/System
112License: GPLv2+
113URL: http://sourceware.org/systemtap/
114Requires: systemtap
115
116%description sdt-devel
117Support tools to allow applications to use static probes.
118
9a8d8be3
MH
119%package initscript
120Summary: Systemtap Initscript
121Group: Development/System
122License: GPLv2+
123URL: http://sourceware.org/systemtap/
124Requires: systemtap-runtime, initscripts
125
126%description initscript
127Initscript for Systemtap scripts.
128
7d838f63 129%prep
a2c9eba7
RM
130%setup -q %{?setup_elfutils}
131
a87d23e3 132%if %{with_bundled_elfutils}
7d838f63
MH
133cd elfutils-%{elfutils_version}
134%patch1 -p1
a2c9eba7
RM
135sleep 1
136find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
137sleep 1
138find . \( -name configure -o -name config.h.in \) -print | xargs touch
7d838f63
MH
139cd ..
140%endif
141
142%build
a2c9eba7 143
a87d23e3 144%if %{with_bundled_elfutils}
7d838f63 145# Build our own copy of elfutils.
4d9087fc 146%define elfutils_config --with-elfutils=elfutils-%{elfutils_version}
a2c9eba7
RM
147
148# We have to prevent the standard dependency generation from identifying
149# our private elfutils libraries in our provides and requires.
150%define _use_internal_dependency_generator 0
151%define filter_eulibs() /bin/sh -c "%{1} | sed '/libelf/d;/libdw/d;/libebl/d'"
152%define __find_provides %{filter_eulibs /usr/lib/rpm/find-provides}
153%define __find_requires %{filter_eulibs /usr/lib/rpm/find-requires}
4dbd685d
RM
154
155# This will be needed for running stap when not installed, for the test suite.
156%define elfutils_mflags LD_LIBRARY_PATH=`pwd`/lib-elfutils
7d838f63
MH
157%endif
158
9921a199 159# Enable/disable the sqlite coverage testing support
a87d23e3 160%if %{with_sqlite}
9921a199
DS
161%define sqlite_config --enable-sqlite
162%else
163%define sqlite_config --disable-sqlite
d8c3d602
WC
164%endif
165
a87d23e3
DS
166# Enable/disable the crash extension
167%if %{with_crash}
168%define crash_config --enable-crash
169%else
170%define crash_config --disable-crash
171%endif
172
465e8fbf
FCE
173%if %{with_docs}
174%define docs_config --enable-docs
175%else
176%define docs_config --disable-docs
177%endif
178
179
180
181%configure %{?elfutils_config} %{sqlite_config} %{crash_config} %{docs_config}
a2c9eba7 182make %{?_smp_mflags}
2a4b42eb 183
ec4d1558
MW
184%install
185rm -rf ${RPM_BUILD_ROOT}
186make DESTDIR=$RPM_BUILD_ROOT install
187
c256c4a6
MW
188# We want the examples in the special doc dir, not the build install dir.
189# We build it in place and then move it away so it doesn't get installed
190# twice. rpm can specify itself where the (versioned) docs go with the
191# %doc directive.
ec4d1558
MW
192mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/examples examples
193
d2995e6f
FCE
194# Fix paths in the example & testsuite scripts
195find examples testsuite -type f -name '*.stp' -print0 | xargs -0 sed -i -r -e '1s@^#!.+stap@#!%{_bindir}/stap@'
7d838f63 196
8f3c45cc 197# Because "make install" may install staprun with mode 04111, the
98aab489
DS
198# post-processing programs rpmbuild runs won't be able to read it.
199# So, we change permissions so that they can read it. We'll set the
200# permissions back to 04111 in the %files section below.
201chmod 755 $RPM_BUILD_ROOT%{_bindir}/staprun
202
8f3c45cc
FCE
203# Copy over the testsuite
204cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
205
4040e9ea 206%if %{with_docs}
7fe437e6 207# We want the manuals in the special doc dir, not the generic doc install dir.
c256c4a6
MW
208# We build it in place and then move it away so it doesn't get installed
209# twice. rpm can specify itself where the (versioned) docs go with the
210# %doc directive.
7fe437e6
MW
211mkdir docs.installed
212mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
5bfd7a37 213mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
4040e9ea 214%endif
7fe437e6 215
9a8d8be3
MH
216mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d/
217install -m 755 initscript/systemtap $RPM_BUILD_ROOT%{_sysconfdir}/init.d/
218mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap
219mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/conf.d
220mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/script.d
221install -m 644 initscript/config $RPM_BUILD_ROOT%{_sysconfdir}/systemtap
222mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/systemtap
223mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/systemtap
224
7d838f63
MH
225%clean
226rm -rf ${RPM_BUILD_ROOT}
227
378a5245 228%pre runtime
efc4bf9a
DS
229getent group stapdev >/dev/null || groupadd -r stapdev
230getent group stapusr >/dev/null || groupadd -r stapusr
231exit 0
98aab489 232
9a8d8be3
MH
233%post initscript
234chkconfig --add systemtap
235exit 0
236
237%preun initscript
238chkconfig --del systemtap
239exit 0
240
241
7d838f63
MH
242%files
243%defattr(-,root,root)
a2c9eba7 244
94cfa802 245%doc README AUTHORS NEWS COPYING examples
465e8fbf 246%if %{with_docs}
7fe437e6 247%doc docs.installed/*.pdf
5bfd7a37 248%doc docs.installed/tapsets
465e8fbf 249%endif
a2c9eba7
RM
250
251%{_bindir}/stap
b0ff684d 252%{_bindir}/stap-report
4dbd685d 253%{_mandir}/man1/*
ba4a90fd 254%{_mandir}/man5/*
a2c9eba7 255
bcdfb17d
DS
256%dir %{_datadir}/%{name}
257%{_datadir}/%{name}/runtime
258%{_datadir}/%{name}/tapset
a2c9eba7 259
a87d23e3 260%if %{with_bundled_elfutils} || %{with_crash}
7d838f63 261%dir %{_libdir}/%{name}
a87d23e3
DS
262%endif
263%if %{with_bundled_elfutils}
8f3c45cc 264%{_libdir}/%{name}/lib*.so*
7d838f63 265%endif
a87d23e3
DS
266%if %{with_crash}
267%{_libdir}/%{name}/staplog.so*
268%endif
a2c9eba7 269
a87d23e3 270%files runtime
a63a95dc 271%defattr(-,root,root)
98aab489 272%attr(4111,root,root) %{_bindir}/staprun
b0ff684d 273%{_bindir}/stap-report
bcdfb17d 274%{_libexecdir}/%{name}
0bda9740 275%{_mandir}/man8/staprun.8*
be168105
DS
276
277%doc README AUTHORS NEWS COPYING
7d838f63 278
8f3c45cc
FCE
279%files testsuite
280%defattr(-,root,root)
bcdfb17d 281%{_datadir}/%{name}/testsuite
8f3c45cc 282
d9d14e20
DB
283%files client
284%defattr(-,root,root)
285%{_bindir}/stap-client
286%{_bindir}/stap-find-servers
98d7d0bf 287%{_bindir}/stap-find-or-start-server
f1e1c50d
DB
288%{_bindir}/stap-add-server-cert
289%{_bindir}/stap-client-connect
0bda9740 290%{_mandir}/man8/stap-server.8*
d9d14e20
DB
291
292%files server
293%defattr(-,root,root)
294%{_bindir}/stap-server
295%{_bindir}/stap-serverd
296%{_bindir}/stap-start-server
d9d14e20 297%{_bindir}/stap-stop-server
1cecb3c5 298%{_bindir}/stap-gen-server-cert
f1e1c50d 299%{_bindir}/stap-server-connect
0bda9740 300%{_mandir}/man8/stap-server.8*
8f3c45cc 301
b899aa79
SC
302%files sdt-devel
303%defattr(-,root,root)
304%{_bindir}/dtrace
305%{_includedir}/sys/sdt.h
306
9a8d8be3
MH
307%files initscript
308%defattr(-,root,root)
309%{_sysconfdir}/init.d/systemtap
310%dir %{_sysconfdir}/systemtap
311%dir %{_sysconfdir}/systemtap/conf.d
312%dir %{_sysconfdir}/systemtap/script.d
313%config(noreplace) %{_sysconfdir}/systemtap/config
314%dir %{_localstatedir}/cache/systemtap
315%dir %{_localstatedir}/run/systemtap
316%doc initscript/README.initscript
317
318
7d838f63 319%changelog
c8bf931d
FCE
320* Tue Feb 17 2009 Frank Ch. Eigler <fche@redhat.com> - 0.9-1
321- Upstream release.
322
70f5a7b3
FCE
323* Thu Nov 13 2008 Frank Ch. Eigler <fche@redhat.com> - 0.8-1
324- Upstream release.
325
cfaa068c
FCE
326* Tue Jul 15 2008 Frank Ch. Eigler <fche@redhat.com> - 0.7-1
327- Upstream release.
328
d2995e6f
FCE
329* Fri Feb 1 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-3
330- Add zlib-devel to buildreq; missing from crash-devel
331- Process testsuite .stp files for #!stap->#!/usr/bin/stap
332
bfe2b4ab 333* Fri Jan 18 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-1
1e0716d3
FCE
334- Add crash-devel buildreq to build staplog.so crash(8) module.
335- Many robustness & functionality improvements:
336
47b0655b
WC
337* Wed Dec 5 2007 Will Cohen <wcohen@redhat.com> - 0.6-2
338- Correct Source to point to location contain code.
339
98aab489
DS
340* Thu Aug 9 2007 David Smith <dsmith@redhat.com> - 0.6-1
341- Bumped version, added libcap-devel BuildRequires.
342
d8c3d602
WC
343* Wed Jul 11 2007 Will Cohen <wcohen@redhat.com> - 0.5.14-2
344- Fix Requires and BuildRequires for sqlite.
345
c1edaa30
FCE
346* Tue Jul 2 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.14-1
347- Many robustness improvements: 1117, 1134, 1305, 1307, 1570, 1806,
348 2033, 2116, 2224, 2339, 2341, 2406, 2426, 2438, 2583, 3037,
349 3261, 3282, 3331, 3428 3519, 3545, 3625, 3648, 3880, 3888, 3911,
350 3952, 3965, 4066, 4071, 4075, 4078, 4081, 4096, 4119, 4122, 4127,
351 4146, 4171, 4179, 4183, 4221, 4224, 4254, 4281, 4319, 4323, 4326,
352 4329, 4332, 4337, 4415, 4432, 4444, 4445, 4458, 4467, 4470, 4471,
353 4518, 4567, 4570, 4579, 4589, 4609, 4664
354
aa384dcd
FCE
355* Mon Mar 26 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.13-1
356- An emergency / preliminary refresh, mainly for compatibility
357 with 2.6.21-pre kernels.
2a4b42eb 358
31982bd2
FCE
359* Mon Jan 1 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.12-1
360- Many changes, see NEWS file.
361
a63a95dc
DS
362* Tue Sep 26 2006 David Smith <dsmith@redhat.com> - 0.5.10-1
363- Added 'systemtap-runtime' subpackage.
364
d65d6b27
RM
365* Wed Jul 19 2006 Roland McGrath <roland@redhat.com> - 0.5.9-1
366- PRs 2669, 2913
367
c1d6a343
RM
368* Fri Jun 16 2006 Roland McGrath <roland@redhat.com> - 0.5.8-1
369- PRs 2627, 2520, 2228, 2645
370
f6291560 371* Fri May 5 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.7-1
6f231a27
FCE
372- PRs 2511 2453 2307 1813 1944 2497 2538 2476 2568 1341 2058 2220 2437
373 1326 2014 2599 2427 2438 2465 1930 2149 2610 2293 2634 2506 2433
374
611010bf
RM
375* Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.5.5-1
376- Many changes, affected PRs include: 2068, 2293, 1989, 2334,
377 1304, 2390, 2425, 953.
378
be9923ac
FCE
379* Wed Feb 1 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.4-1
380- PRs 1916, 2205, 2142, 2060, 1379
381
db6a8a10
RM
382* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 0.5.3-1
383- Many changes, affected PRs include: 2056, 1144, 1379, 2057,
384 2060, 1972, 2140, 2148
385
dcf0c541
RM
386* Mon Dec 19 2005 Roland McGrath <roland@redhat.com> - 0.5.2-1
387- Fixed build with gcc 4.1, various tapset changes.
388
4d9087fc
RM
389* Wed Dec 7 2005 Roland McGrath <roland@redhat.com> - 0.5.1-1
390- elfutils update, build changes
391
e94c050c 392* Fri Dec 02 2005 Frank Ch. Eigler <fche@redhat.com> - 0.5-1
7d9e8974
FCE
393- Many fixes and improvements: 1425, 1536, 1505, 1380, 1329, 1828, 1271,
394 1339, 1340, 1345, 1837, 1917, 1903, 1336, 1868, 1594, 1564, 1276, 1295
395
ae65ed5c
RM
396* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.4.2-1
397- Many fixes and improvements: PRs 1344, 1260, 1330, 1295, 1311, 1368,
398 1182, 1131, 1332, 1366, 1456, 1271, 1338, 1482, 1477, 1194.
399
66bb48fd
RM
400* Wed Sep 14 2005 Roland McGrath <roland@redhat.com> - 0.4.1-1
401- Many fixes and improvements since 0.2.2; relevant PRs include:
402 1122, 1134, 1155, 1172, 1174, 1175, 1180, 1186, 1187, 1191, 1193, 1195,
403 1197, 1205, 1206, 1209, 1213, 1244, 1257, 1258, 1260, 1265, 1268, 1270,
404 1289, 1292, 1306, 1335, 1257
405
323904e0
FCE
406* Wed Sep 7 2005 Frank Ch. Eigler <fche@redhat.com>
407- Bump version.
408
03f23d0f 409* Wed Aug 16 2005 Frank Ch. Eigler <fche@redhat.com>
83ff1cf9
FCE
410- Bump version.
411
2205d115
MH
412* Wed Aug 3 2005 Martin Hunt <hunt@redhat.com> - 0.2.2-1
413- Add directory /var/cache/systemtap
414- Add stp_check to /usr/libexec/systemtap
415
351e76d3
RM
416* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 0.2.1-1
417- New version 0.2.1, various fixes.
418
4dbd685d
RM
419* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.2-1
420- New version 0.2, requires elfutils 0.111
421
a2c9eba7
RM
422* Mon Jul 25 2005 Roland McGrath <roland@redhat.com>
423- Clean up spec file, build bundled elfutils.
424
7d838f63
MH
425* Thu Jul 21 2005 Martin Hunt <hunt@redhat.com>
426- Set Version to use version from autoconf.
427- Fix up some of the path names.
a2c9eba7
RM
428- Add Requires and BuildRequires.
429
430* Wed Jul 19 2005 Will Cohen <wcohen@redhat.com>
7d838f63 431- Initial creation of RPM.
This page took 0.140946 seconds and 5 git commands to generate.