]> sourceware.org Git - systemtap.git/blame - systemtap.spec
configury: add --with-extra-version=STRING option
[systemtap.git] / systemtap.spec
CommitLineData
11059140
RM
1%{!?with_sqlite: %global with_sqlite 1}
2%{!?with_docs: %global with_docs 1}
38105915 3%{!?with_crash: %global with_crash 1}
11059140
RM
4%{!?with_rpm: %global with_rpm 1}
5%{!?with_bundled_elfutils: %global with_bundled_elfutils 0}
e050d62f 6%{!?elfutils_version: %global elfutils_version 0.142}
11059140 7%{!?pie_supported: %global pie_supported 1}
11059140
RM
8%{!?with_boost: %global with_boost 0}
9%{!?with_publican: %global with_publican 1}
10%{!?publican_brand: %global publican_brand fedora}
1074f79d 11
a2c9eba7 12Name: systemtap
4c4adc41 13Version: 2.0
27aba29a 14Release: 1%{?dist}
59b30bda 15# for version, see also configure.ac
016a35ea
FCE
16
17
18# Packaging abstract:
19#
20# systemtap empty req:-client req:-devel
21# systemtap-server /usr/bin/stap-server*, req:-devel
22# systemtap-devel /usr/bin/stap, runtime, tapset, req:kernel-devel
23# systemtap-runtime /usr/bin/staprun, /usr/bin/stapsh
24# systemtap-client /usr/bin/stap, samples, docs, tapset(bonus), req:-runtime
25# systemtap-initscript /etc/init.d/systemtap, req:systemtap
26# systemtap-sdt-devel /usr/include/sys/sdt.h /usr/bin/dtrace
27# systemtap-testsuite /usr/share/systemtap/testsuite*, req:systemtap, req:sdt-devel
016a35ea
FCE
28#
29# Typical scenarios:
30#
31# stap-client: systemtap-client
32# stap-server: systemtap-server
33# local user: systemtap
34#
35# Unusual scenarios:
36#
37# intermediary stap-client for --remote: systemtap-client (-runtime unused)
38# intermediary stap-server for --use-server: systemtap-server (-devel unused)
39
40Summary: Programmable system-wide instrumentation system
7d838f63 41Group: Development/System
6a1cd8a7 42License: GPLv2+
a2c9eba7 43URL: http://sourceware.org/systemtap/
47b0655b 44Source: ftp://sourceware.org/pub/%{name}/releases/%{name}-%{version}.tar.gz
a2c9eba7 45
016a35ea 46# Build*
37b99e78 47BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
4c895683 48BuildRequires: gcc-c++
48fa6b5e
FCE
49BuildRequires: gettext-devel
50BuildRequires: nss-devel avahi-devel pkgconfig
a87d23e3 51%if %{with_sqlite}
c3a3c0c9 52BuildRequires: sqlite-devel
d8c3d602 53%endif
469c1a1b
FCE
54# Needed for libstd++ < 4.0, without <tr1/memory>
55%if %{with_boost}
56BuildRequires: boost-devel
57%endif
a87d23e3 58%if %{with_crash}
d2995e6f 59BuildRequires: crash-devel zlib-devel
1e0716d3 60%endif
2ed04863
WC
61%if %{with_rpm}
62BuildRequires: rpm-devel glibc-headers
63%endif
a87d23e3 64%if %{with_bundled_elfutils}
7d838f63
MH
65Source1: elfutils-%{elfutils_version}.tar.gz
66Patch1: elfutils-portability.patch
d79591b3 67BuildRequires: m4
11059140 68%global setup_elfutils -a1
a2c9eba7
RM
69%else
70BuildRequires: elfutils-devel >= %{elfutils_version}
7d838f63 71%endif
465e8fbf
FCE
72%if %{with_docs}
73BuildRequires: /usr/bin/latex /usr/bin/dvips /usr/bin/ps2pdf latex2html
6275c8d7
DS
74# On F10, xmlto's pdf support was broken off into a sub-package,
75# called 'xmlto-tex'. To avoid a specific F10 BuildReq, we'll do a
76# file-based buildreq on '/usr/share/xmlto/format/fo/pdf'.
77BuildRequires: xmlto /usr/share/xmlto/format/fo/pdf
53ade4da
MW
78%if %{with_publican}
79BuildRequires: publican
59c75f19 80BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
53ade4da 81%endif
465e8fbf 82%endif
14df5fde 83
016a35ea
FCE
84# Install requirements
85Requires: systemtap-client = %{version}-%{release}
86Requires: systemtap-devel = %{version}-%{release}
87
7d838f63 88%description
f89ff3e2 89SystemTap is an instrumentation system for systems running Linux.
016a35ea
FCE
90Developers can write instrumentation scripts to collect data on
91the operation of the system. The base systemtap package contains/requires
92the components needed to locally develop and execute systemtap scripts.
93
94# ------------------------------------------------------------------------
95
96%package server
97Summary: Instrumentation System Server
98Group: Development/System
99License: GPLv2+
100URL: http://sourceware.org/systemtap/
101Requires: systemtap-devel = %{version}-%{release}
102# On RHEL[45], /bin/mktemp comes from the 'mktemp' package. On newer
103# distributions, /bin/mktemp comes from the 'coreutils' package. To
104# avoid a specific RHEL[45] Requires, we'll do a file-based require.
105Requires: nss /bin/mktemp
106Requires: zip unzip
107Requires(pre): shadow-utils
108Requires(post): chkconfig
109Requires(preun): chkconfig
110Requires(preun): initscripts
111Requires(postun): initscripts
112BuildRequires: nss-devel avahi-devel
113
114%description server
115This is the remote script compilation server component of systemtap.
116It announces itself to nearby clients with avahi (if available), and
117compiles systemtap scripts to kernel objects on their demand.
118
119
120%package devel
121Summary: Programmable system-wide instrumentation system - development headers, tools
122Group: Development/System
123License: GPLv2+
124URL: http://sourceware.org/systemtap/
125Requires: kernel >= 2.6.9-11
126# Alternate kernel packages kernel-PAE-devel et al. have a virtual
127# provide for kernel-devel, so this requirement does the right thing,
128# at least past RHEL4.
129Requires: kernel-devel
4c895683 130Requires: gcc make
016a35ea
FCE
131# Suggest: kernel-debuginfo
132
133%description devel
134This package contains the components needed to compile a systemtap
135script from source form into executable (.ko) forms. It may be
136installed on a self-contained developer workstation (along with the
137systemtap-client and systemtap-runtime packages), or on a dedicated
138remote server (alongside the systemtap-server package). It includes
139a copy of the standard tapset library and the runtime library C files.
140
7d838f63 141
a63a95dc 142%package runtime
016a35ea 143Summary: Programmable system-wide instrumentation system - runtime
a63a95dc 144Group: Development/System
6a1cd8a7 145License: GPLv2+
a63a95dc
DS
146URL: http://sourceware.org/systemtap/
147Requires: kernel >= 2.6.9-11
378a5245 148Requires(pre): shadow-utils
a63a95dc
DS
149
150%description runtime
016a35ea
FCE
151SystemTap runtime contains the components needed to execute
152a systemtap script that was already compiled into a module
153using a local or remote systemtap-devel installation.
a63a95dc 154
016a35ea
FCE
155
156%package client
157Summary: Programmable system-wide instrumentation system - client
8f3c45cc
FCE
158Group: Development/System
159License: GPLv2+
160URL: http://sourceware.org/systemtap/
016a35ea
FCE
161Requires: zip unzip
162Requires: systemtap-runtime = %{version}-%{release}
163Requires: coreutils grep sed unzip zip
164Requires: openssh-clients
8f3c45cc 165
016a35ea
FCE
166%description client
167This package contains/requires the components needed to develop
168systemtap scripts, and compile them using a local systemtap-devel
169or a remote systemtap-server installation, then run them using a
170local or remote systemtap-runtime. It includes script samples and
171documentation, and a copy of the tapset library for reference.
8f3c45cc 172
016a35ea
FCE
173
174%package initscript
175Summary: Systemtap Initscripts
d9d14e20
DB
176Group: Development/System
177License: GPLv2+
178URL: http://sourceware.org/systemtap/
ad12652e 179Requires: systemtap = %{version}-%{release}
e2a741be
DB
180Requires(post): chkconfig
181Requires(preun): chkconfig
182Requires(preun): initscripts
183Requires(postun): initscripts
d9d14e20 184
016a35ea
FCE
185%description initscript
186Sysvinit scripts to launch selected systemtap scripts at system startup.
187
d9d14e20 188
b899aa79
SC
189%package sdt-devel
190Summary: Static probe support tools
191Group: Development/System
920b103a 192License: GPLv2+ and Public Domain
b899aa79 193URL: http://sourceware.org/systemtap/
b899aa79
SC
194
195%description sdt-devel
016a35ea
FCE
196This package includes the <sys/sdt.h> header file used for static
197instrumentation compiled into userspace programs and libraries, along
198with the optional dtrace-compatibility preprocessor to process related
199.d files into tracing-macro-laden .h headers.
b899aa79 200
016a35ea
FCE
201
202%package testsuite
203Summary: Instrumentation System Testsuite
9a8d8be3
MH
204Group: Development/System
205License: GPLv2+
206URL: http://sourceware.org/systemtap/
016a35ea
FCE
207Requires: systemtap = %{version}-%{release}
208Requires: systemtap-sdt-devel = %{version}-%{release}
d6d8634e 209Requires: systemtap-server = %{version}-%{release}
df7d2178 210Requires: dejagnu which prelink elfutils grep nc
4c895683 211Requires: gcc gcc-c++ make glibc-devel
d6d8634e
DS
212# testsuite/systemtap.server/client.exp needs avahi
213Requires: avahi
214%if %{with_crash}
215# testsuite/systemtap.base/crash.exp needs crash
216Requires: crash
217%endif
4c895683
SC
218%if %{_arch} == x86_64
219Requires: glibc-devel(%{__isa_name}-32)
220%endif
016a35ea
FCE
221
222%description testsuite
223This package includes the dejagnu-based systemtap stress self-testing
224suite. This may be used by system administrators to thoroughly check
225systemtap on the current system.
9a8d8be3 226
9a8d8be3 227
016a35ea
FCE
228# ------------------------------------------------------------------------
229
7d838f63 230%prep
a2c9eba7
RM
231%setup -q %{?setup_elfutils}
232
a87d23e3 233%if %{with_bundled_elfutils}
7d838f63
MH
234cd elfutils-%{elfutils_version}
235%patch1 -p1
a2c9eba7
RM
236sleep 1
237find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
238sleep 1
239find . \( -name configure -o -name config.h.in \) -print | xargs touch
7d838f63
MH
240cd ..
241%endif
242
243%build
a2c9eba7 244
a87d23e3 245%if %{with_bundled_elfutils}
7d838f63 246# Build our own copy of elfutils.
11059140 247%global elfutils_config --with-elfutils=elfutils-%{elfutils_version}
a2c9eba7
RM
248
249# We have to prevent the standard dependency generation from identifying
250# our private elfutils libraries in our provides and requires.
11059140
RM
251%global _use_internal_dependency_generator 0
252%global filter_eulibs() /bin/sh -c "%{1} | sed '/libelf/d;/libdw/d;/libebl/d'"
253%global __find_provides %{filter_eulibs /usr/lib/rpm/find-provides}
254%global __find_requires %{filter_eulibs /usr/lib/rpm/find-requires}
4dbd685d
RM
255
256# This will be needed for running stap when not installed, for the test suite.
11059140 257%global elfutils_mflags LD_LIBRARY_PATH=`pwd`/lib-elfutils
7d838f63
MH
258%endif
259
9921a199 260# Enable/disable the sqlite coverage testing support
a87d23e3 261%if %{with_sqlite}
11059140 262%global sqlite_config --enable-sqlite
9921a199 263%else
11059140 264%global sqlite_config --disable-sqlite
d8c3d602
WC
265%endif
266
a87d23e3
DS
267# Enable/disable the crash extension
268%if %{with_crash}
11059140 269%global crash_config --enable-crash
a87d23e3 270%else
11059140 271%global crash_config --disable-crash
a87d23e3
DS
272%endif
273
2ed04863
WC
274# Enable/disable the code to find and suggest needed rpms
275%if %{with_rpm}
11059140 276%global rpm_config --with-rpm
2ed04863 277%else
11059140 278%global rpm_config --without-rpm
2ed04863
WC
279%endif
280
465e8fbf 281%if %{with_docs}
11059140 282%global docs_config --enable-docs
465e8fbf 283%else
11059140 284%global docs_config --disable-docs
465e8fbf
FCE
285%endif
286
e1e3ba36
RA
287# Enable pie as configure defaults to disabling it
288%if %{pie_supported}
11059140 289%global pie_config --enable-pie
e1e3ba36 290%else
11059140 291%global pie_config --disable-pie
e1e3ba36 292%endif
465e8fbf 293
53ade4da 294%if %{with_publican}
11059140 295%global publican_config --enable-publican --with-publican-brand=%{publican_brand}
53ade4da 296%else
11059140 297%global publican_config --disable-publican
53ade4da
MW
298%endif
299
465e8fbf 300
62cb4be9 301%configure %{?elfutils_config} %{sqlite_config} %{crash_config} %{docs_config} %{pie_config} %{publican_config} %{rpm_config} --disable-silent-rules
a2c9eba7 302make %{?_smp_mflags}
2a4b42eb 303
ec4d1558
MW
304%install
305rm -rf ${RPM_BUILD_ROOT}
306make DESTDIR=$RPM_BUILD_ROOT install
9564097a 307%find_lang %{name}
ec4d1558 308
c256c4a6
MW
309# We want the examples in the special doc dir, not the build install dir.
310# We build it in place and then move it away so it doesn't get installed
311# twice. rpm can specify itself where the (versioned) docs go with the
312# %doc directive.
ec4d1558
MW
313mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/examples examples
314
d2995e6f
FCE
315# Fix paths in the example & testsuite scripts
316find examples testsuite -type f -name '*.stp' -print0 | xargs -0 sed -i -r -e '1s@^#!.+stap@#!%{_bindir}/stap@'
7d838f63 317
414e04de
DS
318# To make rpmlint happy, remove any .gitignore files in the testsuite.
319find testsuite -type f -name '.gitignore' -print0 | xargs -0 rm -f
320
b7565b41 321# Because "make install" may install staprun with whatever mode, the
98aab489
DS
322# post-processing programs rpmbuild runs won't be able to read it.
323# So, we change permissions so that they can read it. We'll set the
b7565b41 324# permissions back to 04110 in the %files section below.
98aab489
DS
325chmod 755 $RPM_BUILD_ROOT%{_bindir}/staprun
326
cd4d1d39
WC
327#install the useful stap-prep script
328install -c -m 755 stap-prep $RPM_BUILD_ROOT%{_bindir}/stap-prep
329
8f3c45cc
FCE
330# Copy over the testsuite
331cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
332
4040e9ea 333%if %{with_docs}
7fe437e6 334# We want the manuals in the special doc dir, not the generic doc install dir.
c256c4a6
MW
335# We build it in place and then move it away so it doesn't get installed
336# twice. rpm can specify itself where the (versioned) docs go with the
337# %doc directive.
7fe437e6
MW
338mkdir docs.installed
339mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
5bfd7a37 340mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
53ade4da
MW
341%if %{with_publican}
342mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/SystemTap_Beginners_Guide docs.installed/
343%endif
4040e9ea 344%endif
7fe437e6 345
e2a741be
DB
346mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
347install -m 755 initscript/systemtap $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
9a8d8be3
MH
348mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap
349mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/conf.d
350mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/script.d
e2a741be 351install -m 644 initscript/config.systemtap $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/config
9a8d8be3
MH
352mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/systemtap
353mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/systemtap
09070e8a 354
e2a741be 355install -m 755 initscript/stap-server $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
2f78bee0
DB
356mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server
357mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server/conf.d
c982e923 358mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
e2a741be 359install -m 644 initscript/config.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/stap-server
2648a9b4
DB
360mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server
361touch $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server/log
962906a7
DS
362mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
363install -m 644 initscript/logrotate.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/stap-server
9a8d8be3 364
7d838f63
MH
365%clean
366rm -rf ${RPM_BUILD_ROOT}
367
378a5245 368%pre runtime
826d96f8
DB
369getent group stapusr >/dev/null || groupadd -g 156 -r stapusr || groupadd -r stapusr
370getent group stapsys >/dev/null || groupadd -g 157 -r stapsys || groupadd -r stapsys
371getent group stapdev >/dev/null || groupadd -g 158 -r stapdev || groupadd -r stapdev
efc4bf9a 372exit 0
98aab489 373
7433d0cf 374%pre server
016a35ea 375getent group stap-server >/dev/null || groupadd -g 155 -r stap-server || groupadd -r stap-server
2648a9b4
DB
376getent passwd stap-server >/dev/null || \
377 useradd -c "Systemtap Compile Server" -u 155 -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server || \
378 useradd -c "Systemtap Compile Server" -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server
c33bb0d6 379test -e ~stap-server && chmod 755 ~stap-server
878b2f3f
CM
380
381if [ ! -f ~stap-server/.systemtap/rc ]; then
382 mkdir -p ~stap-server/.systemtap
383 chown stap-server:stap-server ~stap-server/.systemtap
384 echo "--rlimit-as=614400000 --rlimit-cpu=60 --rlimit-nproc=20 --rlimit-stack=1024000 --rlimit-fsize=51200000" > ~stap-server/.systemtap/rc
385 chown stap-server:stap-server ~stap-server/.systemtap/rc
386fi
7433d0cf
DB
387exit 0
388
09070e8a 389%post server
962906a7
DS
390test -e %{_localstatedir}/log/stap-server/log || {
391 touch %{_localstatedir}/log/stap-server/log
392 chmod 664 %{_localstatedir}/log/stap-server/log
393 chown stap-server:stap-server %{_localstatedir}/log/stap-server/log
394}
878b2f3f 395
994e8c2c 396# If it does not already exist, as stap-server, generate the certificate
2648a9b4
DB
397# used for signing and for ssl.
398if test ! -e ~stap-server/.systemtap/ssl/server/stap.cert; then
399 runuser -s /bin/sh - stap-server -c %{_libexecdir}/%{name}/stap-gen-cert >/dev/null
400 # Authorize the certificate as a trusted ssl peer and as a trusted signer
401 # on the local host.
f0d23fa8
DB
402 %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/ssl/client >/dev/null
403 %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/staprun >/dev/null
2648a9b4 404fi
829fc0c4 405
03301bc3 406# Activate the service
e2a741be 407/sbin/chkconfig --add stap-server
09070e8a
DB
408exit 0
409
410%preun server
d210cb1c
DB
411# Check that this is the actual deinstallation of the package, as opposed to
412# just removing the old package on upgrade.
e2a741be
DB
413if [ $1 = 0 ] ; then
414 /sbin/service stap-server stop >/dev/null 2>&1
415 /sbin/chkconfig --del stap-server
416fi
417exit 0
418
419%postun server
d210cb1c
DB
420# Check whether this is an upgrade of the package.
421# If so, restart the service if it's running
e2a741be
DB
422if [ "$1" -ge "1" ] ; then
423 /sbin/service stap-server condrestart >/dev/null 2>&1 || :
424fi
09070e8a
DB
425exit 0
426
9a8d8be3 427%post initscript
e2a741be 428/sbin/chkconfig --add systemtap
9a8d8be3
MH
429exit 0
430
431%preun initscript
d210cb1c
DB
432# Check that this is the actual deinstallation of the package, as opposed to
433# just removing the old package on upgrade.
e2a741be
DB
434if [ $1 = 0 ] ; then
435 /sbin/service systemtap stop >/dev/null 2>&1
436 /sbin/chkconfig --del systemtap
437fi
438exit 0
439
440%postun initscript
d210cb1c
DB
441# Check whether this is an upgrade of the package.
442# If so, restart the service if it's running
e2a741be
DB
443if [ "$1" -ge "1" ] ; then
444 /sbin/service systemtap condrestart >/dev/null 2>&1 || :
445fi
9a8d8be3
MH
446exit 0
447
1208cc21
FCE
448%post
449# Remove any previously-built uprobes.ko materials
2648a9b4 450(make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
70f2bd1f 451(/sbin/rmmod uprobes) >/dev/null 2>&1 || true
1208cc21
FCE
452
453%preun
454# Ditto
2648a9b4 455(make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
70f2bd1f 456(/sbin/rmmod uprobes) >/dev/null 2>&1 || true
9a8d8be3 457
016a35ea
FCE
458# ------------------------------------------------------------------------
459
9564097a 460%files -f %{name}.lang
016a35ea
FCE
461# The master "systemtap" rpm doesn't include any files.
462
463%files server -f %{name}.lang
7d838f63 464%defattr(-,root,root)
016a35ea
FCE
465%{_bindir}/stap-server
466%dir %{_libexecdir}/%{name}
467%{_libexecdir}/%{name}/stap-serverd
468%{_libexecdir}/%{name}/stap-start-server
469%{_libexecdir}/%{name}/stap-stop-server
470%{_libexecdir}/%{name}/stap-gen-cert
471%{_libexecdir}/%{name}/stap-sign-module
472%{_mandir}/man7/stappaths.7*
473%{_mandir}/man8/stap-server.8*
474%{_sysconfdir}/rc.d/init.d/stap-server
475%config(noreplace) %{_sysconfdir}/logrotate.d/stap-server
476%dir %{_sysconfdir}/stap-server
477%dir %{_sysconfdir}/stap-server/conf.d
478%config(noreplace) %{_sysconfdir}/sysconfig/stap-server
479%dir %attr(0755,stap-server,stap-server) %{_localstatedir}/log/stap-server
480%ghost %config(noreplace) %attr(0644,stap-server,stap-server) %{_localstatedir}/log/stap-server/log
481%ghost %attr(0755,stap-server,stap-server) %{_localstatedir}/run/stap-server
482%doc initscript/README.stap-server
483%doc README README.unprivileged AUTHORS NEWS COPYING
a2c9eba7 484
a2c9eba7 485
016a35ea 486%files devel -f %{name}.lang
a2c9eba7 487%{_bindir}/stap
cd4d1d39 488%{_bindir}/stap-prep
b0ff684d 489%{_bindir}/stap-report
016a35ea 490%dir %{_datadir}/%{name}/runtime
bcdfb17d 491%{_datadir}/%{name}/runtime
016a35ea 492%dir %{_datadir}/%{name}/tapset
bcdfb17d 493%{_datadir}/%{name}/tapset
016a35ea
FCE
494%{_mandir}/man1/stap.1*
495%{_mandir}/man7/stappaths.7*
496%doc README README.unprivileged AUTHORS NEWS COPYING
a87d23e3 497%if %{with_bundled_elfutils}
75ab1a70 498%dir %{_libdir}/%{name}
8f3c45cc 499%{_libdir}/%{name}/lib*.so*
7d838f63 500%endif
a2c9eba7 501
9564097a 502%files runtime -f %{name}.lang
a63a95dc 503%defattr(-,root,root)
b7565b41 504%attr(4110,root,stapusr) %{_bindir}/staprun
e96f2257 505%{_bindir}/stapsh
6c2c4d8e 506%{_bindir}/stap-merge
b0ff684d 507%{_bindir}/stap-report
75ab1a70 508%dir %{_libexecdir}/%{name}
43a03765 509%{_libexecdir}/%{name}/stapio
961588fd 510%{_libexecdir}/%{name}/stap-env
edecda6c 511%{_libexecdir}/%{name}/stap-authorize-cert
38105915 512%if %{with_crash}
75ab1a70 513%dir %{_libdir}/%{name}
38105915
WC
514%{_libdir}/%{name}/staplog.so*
515%endif
4e47b3c4 516%{_mandir}/man7/stappaths.7*
0bda9740 517%{_mandir}/man8/staprun.8*
b569591a 518%doc README README.security AUTHORS NEWS COPYING
7d838f63 519
8f3c45cc 520
016a35ea 521%files client -f %{name}.lang
d9d14e20 522%defattr(-,root,root)
016a35ea
FCE
523%doc README README.unprivileged AUTHORS NEWS COPYING examples
524%if %{with_docs}
525%doc docs.installed/*.pdf
526%doc docs.installed/tapsets/*.html
527%if %{with_publican}
528%doc docs.installed/SystemTap_Beginners_Guide
529%endif
530%endif
531%{_bindir}/stap
532%{_bindir}/stap-prep
533%{_bindir}/stap-report
534%{_mandir}/man1/stap.1*
535%{_mandir}/man1/stap-merge.1*
536%{_mandir}/man3/*
4e47b3c4 537%{_mandir}/man7/stappaths.7*
016a35ea
FCE
538%dir %{_datadir}/%{name}
539%{_datadir}/%{name}/tapset
540
8f3c45cc 541
b899aa79 542
9a8d8be3
MH
543%files initscript
544%defattr(-,root,root)
e2a741be 545%{_sysconfdir}/rc.d/init.d/systemtap
9a8d8be3
MH
546%dir %{_sysconfdir}/systemtap
547%dir %{_sysconfdir}/systemtap/conf.d
548%dir %{_sysconfdir}/systemtap/script.d
549%config(noreplace) %{_sysconfdir}/systemtap/config
550%dir %{_localstatedir}/cache/systemtap
d1bf48fa 551%ghost %{_localstatedir}/run/systemtap
e2a741be 552%doc initscript/README.systemtap
9a8d8be3 553
016a35ea
FCE
554
555%files sdt-devel -f %{name}.lang
556%defattr(-,root,root)
557%{_bindir}/dtrace
558%{_includedir}/sys/sdt.h
559%{_includedir}/sys/sdt-config.h
560%{_mandir}/man1/dtrace.1*
561%doc README AUTHORS NEWS COPYING
562
563
564%files testsuite
565%defattr(-,root,root)
566%dir %{_datadir}/%{name}
567%{_datadir}/%{name}/testsuite
568
569
016a35ea 570# ------------------------------------------------------------------------
9a8d8be3 571
7d838f63 572%changelog
48fa6b5e
FCE
573* Sun Jun 17 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-1
574- Upstream release.
575
83bd2699
FCE
576* Wed Feb 01 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-1
577- Upstream release.
578
87600139
DS
579* Fri Jan 13 2012 David Smith <dsmith@redhat.com> - 1.6-2
580- Fixed /bin/mktemp require.
581
aff1eaa0
FCE
582* Mon Jul 25 2011 Stan Cox <scox@redhat.com> - 1.6-1
583- Upstream release.
584
585* Tue May 23 2011 Stan Cox <scox@redhat.com> - 1.5-1
586- Upstream release.
587
6e0c15da
FCE
588* Mon Jan 17 2011 Frank Ch. Eigler <fche@redhat.com> - 1.4-1
589- Upstream release.
590
e12e958f
JS
591* Wed Jul 21 2010 Josh Stone <jistone@redhat.com> - 1.3-1
592- Upstream release.
593
e36ba31a
FCE
594* Mon Mar 22 2010 Frank Ch. Eigler <fche@redhat.com> - 1.2-1
595- Upstream release.
596
0710d850
DS
597* Mon Dec 21 2009 David Smith <dsmith@redhat.com> - 1.1-1
598- Upstream release.
599
6a7aa1a1
JS
600* Tue Sep 22 2009 Josh Stone <jistone@redhat.com> - 1.0-1
601- Upstream release.
602
1e9b189f
JS
603* Tue Aug 4 2009 Josh Stone <jistone@redhat.com> - 0.9.9-1
604- Upstream release.
605
e1774a7f
JS
606* Thu Jun 11 2009 Josh Stone <jistone@redhat.com> - 0.9.8-1
607- Upstream release.
608
9b055ab2 609* Thu Apr 23 2009 Josh Stone <jistone@redhat.com> - 0.9.7-1
225d8d4b
JS
610- Upstream release.
611
27aba29a
JS
612* Fri Mar 27 2009 Josh Stone <jistone@redhat.com> - 0.9.5-1
613- Upstream release.
614
fab6ce30
WC
615* Wed Mar 18 2009 Will Cohen <wcohen@redhat.com> - 0.9-2
616- Add location of man pages.
617
c8bf931d
FCE
618* Tue Feb 17 2009 Frank Ch. Eigler <fche@redhat.com> - 0.9-1
619- Upstream release.
620
70f5a7b3
FCE
621* Thu Nov 13 2008 Frank Ch. Eigler <fche@redhat.com> - 0.8-1
622- Upstream release.
623
cfaa068c
FCE
624* Tue Jul 15 2008 Frank Ch. Eigler <fche@redhat.com> - 0.7-1
625- Upstream release.
626
d2995e6f
FCE
627* Fri Feb 1 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-3
628- Add zlib-devel to buildreq; missing from crash-devel
629- Process testsuite .stp files for #!stap->#!/usr/bin/stap
630
bfe2b4ab 631* Fri Jan 18 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-1
1e0716d3
FCE
632- Add crash-devel buildreq to build staplog.so crash(8) module.
633- Many robustness & functionality improvements:
634
47b0655b
WC
635* Wed Dec 5 2007 Will Cohen <wcohen@redhat.com> - 0.6-2
636- Correct Source to point to location contain code.
637
98aab489
DS
638* Thu Aug 9 2007 David Smith <dsmith@redhat.com> - 0.6-1
639- Bumped version, added libcap-devel BuildRequires.
640
d8c3d602
WC
641* Wed Jul 11 2007 Will Cohen <wcohen@redhat.com> - 0.5.14-2
642- Fix Requires and BuildRequires for sqlite.
643
c1edaa30
FCE
644* Tue Jul 2 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.14-1
645- Many robustness improvements: 1117, 1134, 1305, 1307, 1570, 1806,
646 2033, 2116, 2224, 2339, 2341, 2406, 2426, 2438, 2583, 3037,
647 3261, 3282, 3331, 3428 3519, 3545, 3625, 3648, 3880, 3888, 3911,
648 3952, 3965, 4066, 4071, 4075, 4078, 4081, 4096, 4119, 4122, 4127,
649 4146, 4171, 4179, 4183, 4221, 4224, 4254, 4281, 4319, 4323, 4326,
650 4329, 4332, 4337, 4415, 4432, 4444, 4445, 4458, 4467, 4470, 4471,
651 4518, 4567, 4570, 4579, 4589, 4609, 4664
652
aa384dcd
FCE
653* Mon Mar 26 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.13-1
654- An emergency / preliminary refresh, mainly for compatibility
655 with 2.6.21-pre kernels.
2a4b42eb 656
31982bd2
FCE
657* Mon Jan 1 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.12-1
658- Many changes, see NEWS file.
659
a63a95dc
DS
660* Tue Sep 26 2006 David Smith <dsmith@redhat.com> - 0.5.10-1
661- Added 'systemtap-runtime' subpackage.
662
d65d6b27
RM
663* Wed Jul 19 2006 Roland McGrath <roland@redhat.com> - 0.5.9-1
664- PRs 2669, 2913
665
c1d6a343
RM
666* Fri Jun 16 2006 Roland McGrath <roland@redhat.com> - 0.5.8-1
667- PRs 2627, 2520, 2228, 2645
668
f6291560 669* Fri May 5 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.7-1
6f231a27
FCE
670- PRs 2511 2453 2307 1813 1944 2497 2538 2476 2568 1341 2058 2220 2437
671 1326 2014 2599 2427 2438 2465 1930 2149 2610 2293 2634 2506 2433
672
611010bf
RM
673* Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.5.5-1
674- Many changes, affected PRs include: 2068, 2293, 1989, 2334,
675 1304, 2390, 2425, 953.
676
be9923ac
FCE
677* Wed Feb 1 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.4-1
678- PRs 1916, 2205, 2142, 2060, 1379
679
db6a8a10
RM
680* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 0.5.3-1
681- Many changes, affected PRs include: 2056, 1144, 1379, 2057,
682 2060, 1972, 2140, 2148
683
dcf0c541
RM
684* Mon Dec 19 2005 Roland McGrath <roland@redhat.com> - 0.5.2-1
685- Fixed build with gcc 4.1, various tapset changes.
686
4d9087fc
RM
687* Wed Dec 7 2005 Roland McGrath <roland@redhat.com> - 0.5.1-1
688- elfutils update, build changes
689
e94c050c 690* Fri Dec 02 2005 Frank Ch. Eigler <fche@redhat.com> - 0.5-1
7d9e8974
FCE
691- Many fixes and improvements: 1425, 1536, 1505, 1380, 1329, 1828, 1271,
692 1339, 1340, 1345, 1837, 1917, 1903, 1336, 1868, 1594, 1564, 1276, 1295
693
ae65ed5c
RM
694* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.4.2-1
695- Many fixes and improvements: PRs 1344, 1260, 1330, 1295, 1311, 1368,
696 1182, 1131, 1332, 1366, 1456, 1271, 1338, 1482, 1477, 1194.
697
66bb48fd
RM
698* Wed Sep 14 2005 Roland McGrath <roland@redhat.com> - 0.4.1-1
699- Many fixes and improvements since 0.2.2; relevant PRs include:
700 1122, 1134, 1155, 1172, 1174, 1175, 1180, 1186, 1187, 1191, 1193, 1195,
701 1197, 1205, 1206, 1209, 1213, 1244, 1257, 1258, 1260, 1265, 1268, 1270,
702 1289, 1292, 1306, 1335, 1257
703
323904e0
FCE
704* Wed Sep 7 2005 Frank Ch. Eigler <fche@redhat.com>
705- Bump version.
706
03f23d0f 707* Wed Aug 16 2005 Frank Ch. Eigler <fche@redhat.com>
83ff1cf9
FCE
708- Bump version.
709
2205d115
MH
710* Wed Aug 3 2005 Martin Hunt <hunt@redhat.com> - 0.2.2-1
711- Add directory /var/cache/systemtap
712- Add stp_check to /usr/libexec/systemtap
713
351e76d3
RM
714* Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 0.2.1-1
715- New version 0.2.1, various fixes.
716
4dbd685d
RM
717* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.2-1
718- New version 0.2, requires elfutils 0.111
719
a2c9eba7
RM
720* Mon Jul 25 2005 Roland McGrath <roland@redhat.com>
721- Clean up spec file, build bundled elfutils.
722
7d838f63
MH
723* Thu Jul 21 2005 Martin Hunt <hunt@redhat.com>
724- Set Version to use version from autoconf.
725- Fix up some of the path names.
a2c9eba7
RM
726- Add Requires and BuildRequires.
727
728* Wed Jul 19 2005 Will Cohen <wcohen@redhat.com>
7d838f63 729- Initial creation of RPM.
This page took 0.28696 seconds and 5 git commands to generate.