Bug 9978 - DW_OP_bit_piece does not allow DW_OP_reg
Summary: DW_OP_bit_piece does not allow DW_OP_reg
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: gdb (show other bugs)
Version: unknown
: P2 normal
Target Milestone: 7.2
Assignee: Tom Tromey
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-21 22:56 UTC by Jan Hubicka
Modified: 2010-05-21 21:34 UTC (History)
2 users (show)

See Also:
Host: x86_64-pc-linux-gnu
Target:
Build:
Last reconfirmed: 2010-05-07 21:02:53


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Hubicka 2009-03-21 22:56:27 UTC
DW_op_reg in DW_OP_bit_piece is refused:
DWARF-2 expression error: DW_OP_reg operations must be used either alone or in
conjuction with DW_OP_piece.

I believe it is wrong, since DW_OP_bit_piece has same restrictions as
DW_OP_piece.  I would like to use DW_OP_bit_piece in GCC to output SRAed
structures, so it would be cool to fix this ;)
Comment 1 Tom Tromey 2009-03-22 01:03:45 UTC
Confirmed.

AFAICT DW_OP_bit_piece is not handled at all.
Comment 2 Tom Tromey 2010-05-21 21:34:40 UTC
I checked in a fix.