Bug 9780 - X clients running on Solaris terminate on any keypress with BadAlloc on XkbSetNamedIndicator
Summary: X clients running on Solaris terminate on any keypress with BadAlloc on XkbSe...
Status: RESOLVED FIXED
Alias: None
Product: cygwin
Classification: Unclassified
Component: Cygwin/X (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Yaakov Selkowitz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-23 18:52 IST by Jon Turney
Modified: 2009-10-02 16:24 IST (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Patch to improve authorization behaviour of internal clients in XDMCP mode (2.85 KB, patch)
2009-07-13 18:09 IST, Jon Turney
Details | Diff
Patch to workaround a bug in iiimx by ensuring WM_STATE exists in multiwindow mode (685 bytes, patch)
2009-07-13 18:10 IST, Jon Turney
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Turney 2009-01-23 18:52:28 IST
X clients running on Solaris terminate on the first keypress, e.g.:

X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  136 (XKEYBOARD)
  Minor opcode of failed request:  16 (XkbSetNamedIndicator)
  Serial number of failed request:  117
  Current serial number in output stream:  130

http://cygwin.com/ml/cygwin-xfree/2008-11/msg00182.html
http://cygwin.com/ml/cygwin-xfree/2008-12/msg00001.html
http://cygwin.com/ml/cygwin-xfree/2009-01/msg00057.html

Workaround: upgrade X.Org on the Solaris machine fixes (sometimes)
Note: XIM-enabled clients also seem to fail, but for different reasons.
Comment 1 Jon Turney 2009-05-16 10:06:16 IST
http://cgit.freedesktop.org/xorg/xserver/commit/?id=557dbadf3be273255e8fdb12d9321f4e88bf2b65
looks like it is relevant to this.
Comment 2 Yaakov Selkowitz 2009-06-25 00:44:20 IST
Should I add this to the queue for 1.6.1.901?
Comment 3 Jon Turney 2009-06-25 00:58:09 IST
(In reply to comment #2)
> Should I add this to the queue for 1.6.1.901?

That patch has been merged to the X.Org 1.6 branch, so it will be in 1.6.2 when
that emerges.
Comment 4 Yaakov Selkowitz 2009-06-30 01:38:04 IST
Pushed in 1.6.1.902.  Leaving open for now to see if this fixes the problem.
Comment 5 Jon Turney 2009-07-13 18:09:28 IST
Created attachment 4049 [details]
Patch to improve authorization behaviour of internal clients in XDMCP mode
Comment 6 Jon Turney 2009-07-13 18:10:04 IST
Created attachment 4050 [details]
Patch to workaround a bug in iiimx by ensuring WM_STATE exists in multiwindow mode
Comment 7 Jon Turney 2009-07-13 18:11:07 IST
Added a couple of patches to fix other issues seen interworking with Solaris
Comment 8 Yaakov Selkowitz 2009-07-13 19:05:21 IST
Thanks for the patches.  Should I release 1.6.2-2 immediately with these patches?
Comment 9 Jon Turney 2009-07-13 20:41:58 IST
(In reply to comment #8)
> Thanks for the patches.  Should I release 1.6.2-2 immediately with these patches?

I'll probably have a few more bits and pieces this week so might be worth
waiting for those
Comment 10 Yaakov Selkowitz 2009-07-13 21:14:55 IST
(In reply to comment #9)
> I'll probably have a few more bits and pieces this week so might be worth
> waiting for those

Fine.  In the meantime, I've committed these to Ports SVN.
Comment 11 Jon Turney 2009-07-22 19:07:51 IST
(In reply to comment #10)
> (In reply to comment #9)
> > I'll probably have a few more bits and pieces this week so might be worth
> > waiting for those
> 
> Fine.  In the meantime, I've committed these to Ports SVN.

You might as well push out a built with these changes when you have time.  I'm
not very productive at the moment due to various problems after rebuilding my
development environment...
Comment 12 Yaakov Selkowitz 2009-07-22 20:48:39 IST
Shipped in 1.6.2-2; leaving open until fix is confirmed.
Comment 13 Yaakov Selkowitz 2009-10-02 16:24:59 IST
Apparent confirmation:
http://cygwin.com/ml/cygwin-xfree/2009-10/msg00020.html

Closing.