Bug 9622 - tui over-eagerly initializes readline
Summary: tui over-eagerly initializes readline
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: tui (show other bugs)
Version: 7.0
: P3 enhancement
Target Milestone: 7.1
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 11250 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-03 16:58 UTC by Tom Tromey
Modified: 2010-02-04 17:39 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Tromey 2008-09-03 16:58:05 UTC
[Converted from Gnats 2517]

The TUI initializes readline eagerly, resulting in
some terminal-setting control characters being emitted
even if using -batch and redirecting stdout to a file.

See this thread for more details:

http://sourceware.org/ml/gdb-patches/2008-08/msg00599.html

Release:
unknown
Comment 1 Tom Tromey 2010-02-04 16:06:25 UTC
*** Bug 11250 has been marked as a duplicate of this bug. ***
Comment 2 H.J. Lu 2010-02-04 17:07:44 UTC
A patch is posted at

http://sourceware.org/ml/gdb-patches/2010-02/msg00120.html
Comment 3 cvs-commit@gcc.gnu.org 2010-02-04 17:38:12 UTC
Subject: Bug 9622

CVSROOT:	/cvs/src
Module name:	src
Changes by:	hjl@sourceware.org	2010-02-04 17:38:00

Modified files:
	gdb            : ChangeLog 
	gdb/tui        : tui-interp.c 

Log message:
	Call tui_initialize_readline only if gdb_stdout is a tty.
	
	2010-02-04  H.J. Lu  <hongjiu.lu@intel.com>
	
	PR tui/9622
	* tui/tui-interp.c (tui_init): Call tui_initialize_readline
	only if gdb_stdout is a tty.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gdb/ChangeLog.diff?cvsroot=src&r1=1.11325&r2=1.11326
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gdb/tui/tui-interp.c.diff?cvsroot=src&r1=1.23&r2=1.24

Comment 4 H.J. Lu 2010-02-04 17:39:43 UTC
Fixed.