Bug 844 - elf/Makefile isn't parallel safe and has unnecessary dependency
Summary: elf/Makefile isn't parallel safe and has unnecessary dependency
Status: RESOLVED INVALID
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: GOTO Masanori
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-12 21:41 UTC by H.J. Lu
Modified: 2005-12-30 09:45 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.J. Lu 2005-04-12 21:41:01 UTC
elf/Makefile isn't parallel safe and has unnecessary dependency.
When I did

[hjl@gnu-10 build-i686-linux]$ make xcheck subdirs=elf -j4
make -r PARALLELMFLAGS="" CVSOPTS="" -C /net/gnu/export/gnu/src/glibc/libc
objdir=`pwd` xcheck
make[1]: Entering directory `/net/gnu/export/gnu/src/glibc/libc'
make  -C elf xtests
make[2]: Entering directory `/net/gnu/export/gnu/src/glibc/libc/elf'
make -f /export/build/gnu/glibc-3.4/build-i686-linux/elf/librtld.mk -f rtld-Rules
make[3]: Entering directory `/net/gnu/export/gnu/src/glibc/libc/elf'
make -C ../csu objdir=/export/build/gnu/glibc-3.4/build-i686-linux -f Makefile
-f ../elf/rtld-Rules rtld-all rtld-modules='rtld-check_fds.os rtld-errno-loc.os
rtld-divdi3.os rtld-errno.os'

Why does "make xcheck" cause libc.so/ld.so to be rebuilt? Also "makc xcheck"
isn't parallel build safe since it starts building test files and libc.so/ld.so
at the same time, which can lead to:

/export/build/gnu/glibc-3.4/build-i686-linux/elf/order2mod1.os: In function
`putchar':
../libio/bits/stdio.h:68: undefined reference to `stdout'
../libio/bits/stdio.h:68: undefined reference to `_IO_putc'
collect2: ld returned 1 exit status
make[4]: *** [/export/build/gnu/glibc-3.4/build-i686-linux/elf/order2mod1.so]
Error 1

At that time, libc.so was partially built.
Comment 1 Ulrich Drepper 2005-09-27 05:46:58 UTC
Works fine for me.  If you see problems, attach a patch.  Otherwise close the bug.
Comment 2 Andreas Jaeger 2005-12-30 09:45:43 UTC
No further comments for quite some time.