Bug 833 - glibc CVS head build failure
Summary: glibc CVS head build failure
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Uttam Pawar
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-07 17:47 IST by Uttam Pawar
Modified: 2005-04-07 20:19 IST (History)
1 user (show)

See Also:
Host: powerpc-linux
Target: powerpc-linux
Build: powerpc-linux
Last reconfirmed:


Attachments
This patch fixes the build problem (289 bytes, patch)
2005-04-07 17:48 IST, Uttam Pawar
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Uttam Pawar 2005-04-07 17:47:28 IST
glibc from CVS head failed to build on PowerPC.
Error output:
gcc -B/home/pawar/glibc/obj_ppc/ dl-support.c -c -std=gnu99 -O2 -Wall -Winline
-Wstrict-prototypes -Wwrite-strings -g -mnew-mnemonics      -I../include -I.
-I/home/pawar/glibc/obj_ppc/elf -I.. -I../libio -I../nptl
-I/home/pawar/glibc/obj_ppc -I../sysdeps/powerpc/powerpc32/elf
-I../sysdeps/powerpc/elf -I../libidn/sysdeps/unix
-I../nptl/sysdeps/unix/sysv/linux/powerpc/powerpc32
-I../nptl/sysdeps/unix/sysv/linux/powerpc -I../nptl/sysdeps/unix/sysv/linux
-I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../nptl/sysdeps/unix/sysv
-I../nptl/sysdeps/unix -I../nptl/sysdeps/powerpc -I../nptl/sysdeps/generic
-I../ports/sysdeps/unix/sysv/linux -I../ports/sysdeps/unix/sysv
-I../ports/sysdeps/unix -I../sysdeps/unix/sysv/linux/powerpc/powerpc32
-I../sysdeps/unix/sysv/linux/powerpc -I../sysdeps/unix/sysv/linux
-I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman
-I../sysdeps/unix/inet -I../sysdeps/unix/sysv -I../sysdeps/unix/powerpc
-I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/powerpc/powerpc32/fpu
-I../sysdeps/powerpc/powerpc32 -I../sysdeps/wordsize-32
-I../sysdeps/powerpc/soft-fp -I../sysdeps/powerpc/fpu -I../sysdeps/powerpc
-I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754
-I../sysdeps/generic/elf -I../sysdeps/generic -nostdinc -isystem
/opt/gcc-nightly/mline-20050311/lib/gcc/powerpc64-linux/4.1.0/include -isystem
/home/pawar/glibc/ppc/usr/include -D_LIBC_REENTRANT -D_LIBC_REENTRANT -include
../include/libc-symbols.h       -o /home/pawar/glibc/obj_ppc/elf/dl-support.o
-MD -MP -MF /home/pawar/glibc/obj_ppc/elf/dl-support.o.dt -MT
/home/pawar/glibc/obj_ppc/elf/dl-support.o
dl-support.c:124: error: conflicting types for ‘_dl_hwcap’
../sysdeps/generic/ldsodefs.h:614: error: previous declaration of ‘_dl_hwcap’
was here
make[2]: *** [/home/pawar/glibc/obj_ppc/elf/dl-support.o] Error 1
make[2]: Leaving directory `/home/pawar/glibc/libc/elf'
make[1]: *** [elf/subdir_lib] Error 2
make[1]: Leaving directory `/home/pawar/glibc/libc'
make: *** [all] Error 2
Comment 1 Uttam Pawar 2005-04-07 17:48:20 IST
Created attachment 452 [details]
This patch fixes the build problem
Comment 2 Roland McGrath 2005-04-07 20:19:28 IST

*** This bug has been marked as a duplicate of 333 ***