Bug 802 - glibc fails to compile with post gcc-4.0-20050312 snapshots
Summary: glibc fails to compile with post gcc-4.0-20050312 snapshots
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: math (show other bugs)
Version: 2.3.4
: P2 normal
Target Milestone: ---
Assignee: Andreas Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-24 10:37 UTC by Imad R. faiad
Modified: 2005-03-24 15:34 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Imad R. faiad 2005-03-24 10:37:24 UTC
glibc fails to compile with post gcc-4.0-20050312 snapshots:
in brief:-
../sysdeps/ieee754/dbl-64/s_isinf.c:29: error: 'isinf' aliased to undefined
symbol '__isinf'
in full and at length:-
glibc 
i686-pc-linux-gnu-gcc ../sysdeps/ieee754/dbl-64/s_isinf.c -c -std=gnu99 -O2
-Wall -Winline -Wst
rict-prototypes -Wwrite-strings -march=pentium4 -mtune=pentium4 -pipe
-mpreferred-stack-boundar
y=4  -fPIC -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES  
-Wno-uninitialized -D__NO_MAT
H_INLINES -D__LIBC_INTERNAL_MATH_INLINES -I../include -I.
-I/var/tmp/portage/glibc-2.3.4.200501
25-r1/work/build-default-i686-pc-linux-gnu-nptl/math -I.. -I../libio -I../nptl
-I/var/tmp/porta
ge/glibc-2.3.4.20050125-r1/work/build-default-i686-pc-linux-gnu-nptl
-I../sysdeps/i386/elf -I..
/nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386
-I../nptl/sysdep
s/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread
-I../nptl/sysdeps/unix/sysv -I
../nptl/sysdeps/unix -I../nptl/sysdeps/i386/i686 -I../nptl/sysdeps/i386
-I../libidn/sysdeps/uni
x -I../sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux
-I../sysdeps/gnu -I../sysdeps/
unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet
-I../sysdeps/unix/sysv/i386 -I../sysd
eps/unix/sysv -I../sysdeps/unix/i386 -I../sysdeps/unix -I../sysdeps/posix
-I../sysdeps/i386/i68
6/fpu -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486
-I../sysdeps/i3
86/fpu -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96
-I../sysdeps/iee       e754/dbl-64 -I../sysdeps/ieee754/flt-32
-I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysd       eps/generic
-nostdinc -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.0.0/include -isystem
/usr/inclu       de -D_LIBC_REENTRANT -D_LIBC_REENTRANT -include
../include/libc-symbols.h  -DPIC -DSHARED     -       o
/var/tmp/portage/glibc-2.3.4.20050125-r1/work/build-default-i686-pc-linux-gnu-nptl/math/s_isi
      nf.os -MD -MP -MF
/var/tmp/portage/glibc-2.3.4.20050125-r1/work/build-default-i686-pc-linux-gnu  
    -nptl/math/s_isinf.os.dt -MT
/var/tmp/portage/glibc-2.3.4.20050125-r1/work/build-default-i686-p      
c-linux-gnu-nptl/math/s_isinf.os
../sysdeps/ieee754/dbl-64/s_isinf.c:29: error: 'isinf' aliased to undefined
symbol '__isinf'
make[2]: ***
[/var/tmp/portage/glibc-2.3.4.20050125-r1/work/build-default-i686-pc-linux-gnu-npt
      l/math/s_isinf.os] Error 1
make[2]: Leaving directory
`/var/tmp/portage/glibc-2.3.4.20050125-r1/work/glibc-2.3.4/math'
make[1]: *** [math/subdir_lib] Error 2
make[1]: Leaving directory
`/var/tmp/portage/glibc-2.3.4.20050125-r1/work/glibc-2.3.4'
make: *** [all] Error 2

!!! ERROR: sys-libs/glibc-2.3.4.20050125-r1 failed.
!!! Function toolchain-glibc_src_compile, Line 241, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
HTH
Comment 1 Jakub Jelinek 2005-03-24 10:45:12 UTC
glibc-2_3-branch ATM does not support GCC 4+, only CVS HEAD does.

*** This bug has been marked as a duplicate of 333 ***
Comment 2 Imad R. faiad 2005-03-24 11:55:13 UTC
FYI same problem with CVS HEAD.
Comment 3 Imad R. faiad 2005-03-24 15:34:04 UTC
my appologies, had checkout the wrong branch from cvs, it compiled fine