Bug 764 - getconf installation problem
Summary: getconf installation problem
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.4
: P2 normal
Target Milestone: ---
Assignee: GOTO Masanori
Depends on:
Reported: 2005-02-25 00:15 UTC by Jim Gifford
Modified: 2005-02-25 00:54 UTC (History)
1 user (show)

See Also:
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Jim Gifford 2005-02-25 00:15:35 UTC
I build my glibc with the line --libexecdir=/usr/lib/glibc. Usually you would
see a directory under that named getconf. Not on my last few builds, the
/usr/lib/getconf, gets placed into /usr/bin/getconf and the getconf executable
doesn't even get installed.

During the build I noticed a lot of messages like
mkdir /usr/src/temp-build/login, but on the getconf stuff I saw the following
mkdir /usr/bin/getconf. Also during the build a lot of messages like this would
appear Makefile:267: warning: overriding commands for target `/usr/bin/getconf'
../Makerules:1033: warning: ignoring old commands for target `/usr/bin/getconf'

I posted a message a long time back, and was never satisfied with the answer,
but decided to investigate this a lot further. I have seen this error on various
platforms. http://sources.redhat.com/ml/libc-alpha/2005-01/msg00063.html

Upon checking /usr/bin/getconf, he found the getconf was a directory with 2
files in it

Comment 1 Roland McGrath 2005-02-25 00:54:17 UTC
The line numbers do not jibe with any current sources, making your report
suspect.  The errors indicate that you have set libexecdir to /usr/bin.
There is no evidence here of an actual problem, probably just configuration
errors  in your build.

*** This bug has been marked as a duplicate of 333 ***