Bug 727 - __environ can get reset
Summary: __environ can get reset
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.4
: P2 normal
Target Milestone: ---
Assignee: Roland McGrath
URL:
Keywords:
: 863 (view as bug list)
Depends on:
Blocks: libc235
  Show dependency treegraph
 
Reported: 2005-02-16 04:29 UTC by Roland McGrath
Modified: 2005-09-27 05:53 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland McGrath 2005-02-16 04:29:28 UTC
This trunk change is needed on the 2.3 branch.

2005-01-03  Ulrich Drepper  <drepper@redhat.com>

	* sysdeps/generic/libc-start.c [SHARED] (__libc_start_main): Don't
	initialize __environ again.
	* stdlib/Makefile: Add rules to build and run tst-putenv.
	* stdlib/tst-putenv.c: New file.
	* stdlib/tst-putenvmod.c: New file.
Comment 1 cvs-commit@gcc.gnu.org 2005-02-16 09:41:18 UTC
Subject: Bug 727

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-02-16 09:40:57

Modified files:
	stdlib         : Makefile 
	sysdeps/generic: libc-start.c 
Added files:
	stdlib         : tst-putenv.c tst-putenvmod.c 

Log message:
	2005-01-03  Ulrich Drepper  <drepper@redhat.com>
	
	[BZ #727]
	* sysdeps/generic/libc-start.c [SHARED] (__libc_start_main): Don't
	initialize __environ again.
	* stdlib/Makefile: Add rules to build and run tst-putenv.
	* stdlib/tst-putenv.c: New file.
	* stdlib/tst-putenvmod.c: New file.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/stdlib/tst-putenv.c.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=NONE&r2=1.1.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/stdlib/tst-putenvmod.c.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=NONE&r2=1.1.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/stdlib/Makefile.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.95&r2=1.95.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/generic/libc-start.c.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.52&r2=1.52.4.1

Comment 2 Roland McGrath 2005-04-05 23:59:27 UTC
These changes are in the 2.3 branch as well as the trunk now.
Comment 3 Ulrich Drepper 2005-09-27 05:53:48 UTC
*** Bug 863 has been marked as a duplicate of this bug. ***