Bug 721 - glibc-2.3.4 fails to build with gcc-4.0-20050213
Summary: glibc-2.3.4 fails to build with gcc-4.0-20050213
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.4
: P2 normal
Target Milestone: ---
Assignee: GOTO Masanori
URL:
Keywords:
Depends on:
Blocks: libc236
  Show dependency treegraph
 
Reported: 2005-02-14 21:08 UTC by Matthew Burgess
Modified: 2005-10-17 05:00 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
GCC 4 compile fix (880 bytes, patch)
2005-03-02 23:40 UTC, Mark Loeser
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Burgess 2005-02-14 21:08:40 UTC
glibc-2.3.4 + the patch from Alexandre Oliva at
http://sourceware.org/ml/libc-hacker/2005-02/msg00000.html fails to compile on
i686-pc-linux-gnu with the following error when using the latest gcc-4.0
snapshot (20050213):

rtld.c: In function '_dl_start':
dynamic-link.h:50: error: nested function 'elf_machine_rela_relative' declared
but never defined
dynamic-link.h:47: error: nested function 'elf_machine_rela' declared but never
defined
make[3]: *** [/sources/glibc-build/elf/rtld.os] Error 1

Even though Alexandre's patch adds some #if guards around the declarations, this
apparently isn't enough on i686.  Same error occurs without that portion of the
patch too (and yes, I've noticed the other 2 hunks have been applied to CVS already)

Regards,

Matt.
Comment 1 cvs-commit@gcc.gnu.org 2005-02-17 01:16:31 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Changes by:	roland@sources.redhat.com	2005-02-17 01:16:20

Modified files:
	elf            : dynamic-link.h 

Log message:
	2005-02-03  Alexandre Oliva  <aoliva@redhat.com>
	
	[BZ #721]
	* elf/dynamic-link.h: Don't declare nested auto functions that are
	not going to be defined.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/elf/dynamic-link.h.diff?cvsroot=glibc&r1=1.52&r2=1.53

Comment 2 cvs-commit@gcc.gnu.org 2005-02-17 01:17:17 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Changes by:	roland@sources.redhat.com	2005-02-17 01:16:35

Modified files:
	sysdeps/sh     : dl-machine.h 
	sysdeps/i386   : dl-machine.h 
	sysdeps/powerpc/powerpc32: dl-machine.h 
	sysdeps/powerpc/powerpc64: dl-machine.h 

Log message:
	2005-02-16  Roland McGrath  <roland@redhat.com>
	
	[BZ #721]
	* sysdeps/i386/dl-machine.h (ELF_MACHINE_NO_RELA): Define this outside
	of [RESOLVE_MAP].
	* sysdeps/sh/dl-machine.h (ELF_MACHINE_NO_REL): Likewise.
	* sysdeps/powerpc/powerpc32/dl-machine.h
	(elf_machine_rel, elf_machine_rel_relative): Removed.
	* sysdeps/powerpc/powerpc64/dl-machine.h
	(elf_machine_rel, elf_machine_rel_relative): Removed.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/sh/dl-machine.h.diff?cvsroot=glibc&r1=1.35&r2=1.36
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/i386/dl-machine.h.diff?cvsroot=glibc&r1=1.132&r2=1.133
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/powerpc/powerpc32/dl-machine.h.diff?cvsroot=glibc&r1=1.12&r2=1.13
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/powerpc/powerpc64/dl-machine.h.diff?cvsroot=glibc&r1=1.22&r2=1.23

Comment 3 Matthew Burgess 2005-02-26 12:31:53 UTC
Wel, this is odd.  I've tried compiling the latest snapshot (20050221) with
gcc-4.0-20050220 and still get:

rtld.c: In function '_dl_start':
dynamic-link.h:50: error: nested function 'elf_machine_rela_relative' declared
but never defined
dynamic-link.h:47: error: nested function 'elf_machine_rela' declared but never
defined

Maybe something's wrong with my build environment - if you need/want any further
info to help track this down, let me know.

Meanwhile, the 2.3-20050221 obviously fails much earlier as the pthread.h and
other related patches haven't been applied to the 2.3 branch yet.  Neither is
this bug marked as a dependency of 724.  Do I take that to mean that there is no
intention to have glibc-2.3.5 compilable with gcc-4.0?

Thanks,

Matt.
Comment 4 cvs-commit@gcc.gnu.org 2005-03-01 20:34:52 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Changes by:	roland@sources.redhat.com	2005-03-01 20:34:41

Modified files:
	sysdeps/arm    : dl-machine.h 

Log message:
	2005-03-01  Roland McGrath  <roland@redhat.com>
	
	[BZ #721]
	* sysdeps/arm/dl-machine.h (ELF_MACHINE_NO_RELA): Define this outside
	of [RESOLVE_MAP].

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/arm/dl-machine.h.diff?cvsroot=glibc&r1=1.49&r2=1.50

Comment 5 Mark Loeser 2005-03-02 23:40:46 UTC
Created attachment 427 [details]
GCC 4 compile fix

It seems to me that the ifdefs that were added to dynamic-link.h aren't very
useful since the only time ELF_MACHINE_NO_RELA or ELF_MACHINE_NO_REL are
defined is within dl-machine.h, which isn't included until after those checks
are run.  Even after moving the include to before the ifdefs, it still does not
compile.  I believe that might be a GCC 4 bug, because its seeing the
definitions, and then declarations after that.	My fix was to remove the entire
ifdef block from dynamic-link.h entirely since it seems redundant anyway, since
they will all be defined in dl-machine.h.  I have no idea if this is the best
approach, but it works for me so far.  This is the first time I'm poking my
nose in glibc sources, so please tell me if any of the above is horribly wrong.


Attached is my patch.
Comment 6 Roland McGrath 2005-03-03 00:34:45 UTC
2.3.4 does not support being compiled with GCC 4, which, btw, doesn't actually
exist yet.  You can compile the glibc trunk with GCC development snapshots now.
For the 2.3 branch, this will be addressed later.  Regardless, see bug #333.

*** This bug has been marked as a duplicate of 333 ***
Comment 7 Matthew Burgess 2005-03-03 10:32:23 UTC
So, do you want me to raise a separate bug then for the fact that latest CVS
HEAD doesn't compile on i686-pc-linux-gnu with the gcc-4.0-20050226 snapshot. 
FYI I'm building with the following command line:

matthew@kyoto:~/libc-build$ CC=/opt/gcc-4.0-20050226/bin/gcc ../libc/configure
--prefix=/usr --disable-profile --enable-add-ons --enable-kernel=2.6.0
--without-cvs --libexecdir=/usr/lib/glibc

and get the following error:

rtld.c: In function '_dl_start':
dynamic-link.h:50: error: nested function 'elf_machine_rela_relative' declared
but never defined
dynamic-link.h:47: error: nested function 'elf_machine_rela' declared but never
defined
Comment 8 Mark Loeser 2005-03-03 19:12:37 UTC
Matthew, please try my patch and see if that fixes the compile issue for you. 
It has worked for a few people already.
Comment 9 cvs-commit@gcc.gnu.org 2005-10-17 04:52:18 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:15

Modified files:
	sysdeps/powerpc/powerpc32: dl-machine.h 

Log message:
	2005-02-14  Alan Modra  <amodra@bigpond.net.au>
	
	[BZ #721]
	* sysdeps/powerpc/powerpc32/dl-machine.h (elf_machine_rela): Define
	with auto inline, and attribute always_inline.
	(elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	(elf_machine_rel, elf_machine_rel_relative): Likewise.
	* sysdeps/powerpc/powerpc64/dl-machine.h (elf_machine_rela): Likewise.
	(elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	(elf_machine_rel, elf_machine_rel_relative): Likewise.
	(elf_machine_tprel): Likewise.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/powerpc/powerpc32/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.9&r2=1.9.4.1

Comment 10 cvs-commit@gcc.gnu.org 2005-10-17 04:52:20 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:17

Modified files:
	sysdeps/ia64   : dl-machine.h 

Log message:
	2005-04-13  Andreas Schwab  <schwab@suse.de>
	
	[BZ #721]
	* sysdeps/ia64/dl-machine.h (ELF_MACHINE_RUNTIME_TRAMPOLINE)
	[PROF]: Open code strong_alias because the original name is not
	visible to the compiler.
	* sysdeps/powerpc/powerpc64/dl-machine.h
	(ELF_MACHINE_RUNTIME_TRAMPOLINE) [PROF]: Likewise.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/ia64/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.36&r2=1.36.2.1

Comment 11 cvs-commit@gcc.gnu.org 2005-10-17 04:52:25 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:22

Modified files:
	sysdeps/sh     : dl-machine.h 

Log message:
	2005-02-16  Roland McGrath  <roland@redhat.com>
	
	[BZ #721]
	* sysdeps/i386/dl-machine.h (ELF_MACHINE_NO_RELA): Define this outside
	of [RESOLVE].
	* sysdeps/sh/dl-machine.h (ELF_MACHINE_NO_REL): Likewise.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/sh/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.33&r2=1.33.2.1

Comment 12 cvs-commit@gcc.gnu.org 2005-10-17 04:52:27 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:23

Modified files:
	elf            : dynamic-link.h 

Log message:
	2005-03-15  Jakub Jelinek  <jakub@redhat.com>
	
	[BZ #721]
	* elf/dynamic-link.h (elf_machine_rel, elf_machine_rel_relative,
	elf_machine_rela, elf_machine_rela_relative, elf_machine_lazy_rel):
	Add inline keyword.
	* sysdeps/alpha/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Add always_inline
	attribute.
	* sysdeps/sparc/sparc32/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.  Change
	static inline into auto inline.
	* sysdeps/sparc/sparc64/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	* sysdeps/generic/dl-machine.h (elf_machine_rel, elf_machine_rela):
	Likewise.
	* sysdeps/arm/dl-machine.h (elf_machine_rel, elf_machine_rel_relative,
	elf_machine_rela, elf_machine_rela_relative, elf_machine_lazy_rel):
	Likewise.
	2005-02-03  Alexandre Oliva  <aoliva@redhat.com>
	
	[BZ #721]
	* elf/dynamic-link.h: Don't declare nested auto functions that are
	not going to be defined.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/elf/dynamic-link.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.51&r2=1.51.2.1

Comment 13 cvs-commit@gcc.gnu.org 2005-10-17 04:52:29 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:25

Modified files:
	include        : libc-symbols.h 

Log message:
	2005-03-16  Richard Henderson  <rth@redhat.com>
	
	[BZ #721]
	* include/libc-symbols.h (__hidden_proto): Remove bogus declaration
	of internal.
	(__hidden_def1, __hidden_dot_def1): Remove.
	(__hidden_def2, __hidden_def3): Remove.
	(__hidden_ver1): New.
	(hidden_ver, hidden_def, hidden_weak): Use it.
	(hidden_data_ver, hidden_data_ver, hidden_data_weak): Use non-data
	version of the macro.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/include/libc-symbols.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.69&r2=1.69.2.1

Comment 14 cvs-commit@gcc.gnu.org 2005-10-17 04:52:31 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:27

Modified files:
	sysdeps/i386   : dl-machine.h 

Log message:
	2005-03-05  Jakub Jelinek  <jakub@redhat.com>
	
	[BZ #721]
	* sysdeps/i386/dl-machine.h (ELF_MACHINE_NO_RELA): Define
	unconditionally to (defined RTLD_BOOTSTRAP).
	* sysdeps/arm/dl-machine.h (ELF_MACHINE_NO_RELA): Likewise.
	2005-02-16  Roland McGrath  <roland@redhat.com>
	
	[BZ #721]
	* sysdeps/i386/dl-machine.h (ELF_MACHINE_NO_RELA): Define this outside
	of [RESOLVE].
	* sysdeps/sh/dl-machine.h (ELF_MACHINE_NO_REL): Likewise.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/i386/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.128.2.1&r2=1.128.2.2

Comment 15 cvs-commit@gcc.gnu.org 2005-10-17 04:52:34 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:30

Modified files:
	sysdeps/generic: dl-machine.h 
	sysdeps/sparc/sparc32: dl-machine.h 
	sysdeps/sparc/sparc64: dl-machine.h 
	sysdeps/alpha  : dl-machine.h 

Log message:
	2005-03-15  Jakub Jelinek  <jakub@redhat.com>
	
	[BZ #721]
	* elf/dynamic-link.h (elf_machine_rel, elf_machine_rel_relative,
	elf_machine_rela, elf_machine_rela_relative, elf_machine_lazy_rel):
	Add inline keyword.
	* sysdeps/alpha/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Add always_inline
	attribute.
	* sysdeps/sparc/sparc32/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.  Change
	static inline into auto inline.
	* sysdeps/sparc/sparc64/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	* sysdeps/generic/dl-machine.h (elf_machine_rel, elf_machine_rela):
	Likewise.
	* sysdeps/arm/dl-machine.h (elf_machine_rel, elf_machine_rel_relative,
	elf_machine_rela, elf_machine_rela_relative, elf_machine_lazy_rel):
	Likewise.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/generic/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.8&r2=1.8.6.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/sparc/sparc32/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.53&r2=1.53.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/sparc/sparc64/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.47&r2=1.47.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/alpha/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.78&r2=1.78.2.1

Comment 16 cvs-commit@gcc.gnu.org 2005-10-17 04:52:37 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:33

Modified files:
	math           : math_private.h 
	sysdeps/alpha/fpu/bits: mathinline.h 

Log message:
	2005-01-07  Richard Henderson  <rth@redhat.com>
	
	[BZ #721]
	* math/math_private.h (__copysign): Define as builtin for gcc 4.
	(__copysignf, __copysignl): Likewise.
	* sysdeps/alpha/fpu/bits/mathinline.h (copysign): Don't define
	for gcc 4.0.
	(copysignf, copysignl, fabsf, fabs): Likewise.
	(__copysign, __copysignf, __copysignl): Remove.
	(__fabs, __fabsf): Remove.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/math/math_private.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.18&r2=1.18.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/alpha/fpu/bits/mathinline.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.14&r2=1.14.2.1

Comment 17 cvs-commit@gcc.gnu.org 2005-10-17 04:52:39 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:35

Modified files:
	sysdeps/generic: wcstoul_l.c 

Log message:
	2005-03-25  Jakub Jelinek  <jakub@redhat.com>
	
	[BZ #721]
	* sysdeps/generic/wcstoul_l.c: Include "wcstol_l.c" rather than
	<wcstol_l.c>.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/generic/wcstoul_l.c.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.4&r2=1.4.4.1

Comment 18 cvs-commit@gcc.gnu.org 2005-10-17 04:52:40 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:36

Modified files:
	sysdeps/arm    : dl-machine.h 

Log message:
	2005-03-05  Jakub Jelinek  <jakub@redhat.com>
	
	[BZ #721]
	* sysdeps/i386/dl-machine.h (ELF_MACHINE_NO_RELA): Define
	unconditionally to (defined RTLD_BOOTSTRAP).
	* sysdeps/arm/dl-machine.h (ELF_MACHINE_NO_RELA): Likewise.
	2005-03-15  Jakub Jelinek  <jakub@redhat.com>
	
	[BZ #721]
	* elf/dynamic-link.h (elf_machine_rel, elf_machine_rel_relative,
	elf_machine_rela, elf_machine_rela_relative, elf_machine_lazy_rel):
	Add inline keyword.
	* sysdeps/alpha/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Add always_inline
	attribute.
	* sysdeps/sparc/sparc32/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.  Change
	static inline into auto inline.
	* sysdeps/sparc/sparc64/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	* sysdeps/generic/dl-machine.h (elf_machine_rel, elf_machine_rela):
	Likewise.
	* sysdeps/arm/dl-machine.h (elf_machine_rel, elf_machine_rel_relative,
	elf_machine_rela, elf_machine_rela_relative, elf_machine_lazy_rel):
	Likewise.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/arm/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.49&r2=1.49.2.1

Comment 19 cvs-commit@gcc.gnu.org 2005-10-17 04:52:44 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:39

Modified files:
	iconvdata      : jis0208.h 

Log message:
	2005-02-07  Richard Henderson  <rth@redhat.com>
	
	[BZ #721]
	* iconvdata/jis0208.h (struct jisx0208_ucs_idx): Move before use.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/iconvdata/jis0208.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.9&r2=1.9.4.1

Comment 20 cvs-commit@gcc.gnu.org 2005-10-17 04:52:46 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:41

Modified files:
	sysdeps/powerpc/powerpc64: dl-machine.h 

Log message:
	2005-04-13  Andreas Schwab  <schwab@suse.de>
	
	[BZ #721]
	* sysdeps/ia64/dl-machine.h (ELF_MACHINE_RUNTIME_TRAMPOLINE)
	[PROF]: Open code strong_alias because the original name is not
	visible to the compiler.
	* sysdeps/powerpc/powerpc64/dl-machine.h
	(ELF_MACHINE_RUNTIME_TRAMPOLINE) [PROF]: Likewise.
	2005-02-14  Alan Modra  <amodra@bigpond.net.au>
	
	[BZ #721]
	* sysdeps/powerpc/powerpc32/dl-machine.h (elf_machine_rela): Define
	with auto inline, and attribute always_inline.
	(elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	(elf_machine_rel, elf_machine_rel_relative): Likewise.
	* sysdeps/powerpc/powerpc64/dl-machine.h (elf_machine_rela): Likewise.
	(elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	(elf_machine_rel, elf_machine_rel_relative): Likewise.
	(elf_machine_tprel): Likewise.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/powerpc/powerpc64/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.19&r2=1.19.4.1

Comment 21 cvs-commit@gcc.gnu.org 2005-10-17 04:52:49 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:52:44

Modified files:
	include        : wchar.h 
	string         : strcoll.c 
	wcsmbs         : wcscoll.c 

Log message:
	2005-03-16  Richard Henderson  <rth@redhat.com>
	
	[BZ #721]
	* include/wchar.h (__wcscoll): Remove.
	* wcsmbs/wcscoll.c: Define wcscoll directly instead of via __wcscoll.
	* string/strcoll.c: Don't issue libc_hidden_def STRCOLL redefined.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/include/wchar.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.26&r2=1.26.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/string/strcoll.c.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.33&r2=1.33.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/wcsmbs/wcscoll.c.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.13&r2=1.13.4.1

Comment 22 cvs-commit@gcc.gnu.org 2005-10-17 04:53:29 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:53:27

Modified files:
	linuxthreads/sysdeps/powerpc: tcb-offsets.sym 

Log message:
	2005-03-05  Jakub Jelinek  <jakub@redhat.com>
	
	[BZ #721]
	* sysdeps/powerpc/tcb-offsets.sym (thread_offsetof): Rework for GCC 4.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/linuxthreads/sysdeps/powerpc/tcb-offsets.sym.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.7&r2=1.7.4.1

Comment 23 cvs-commit@gcc.gnu.org 2005-10-17 04:53:46 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:53:44

Modified files:
	nptl/sysdeps/powerpc: tcb-offsets.sym 

Log message:
	2005-02-14  Alan Modra  <amodra@bigpond.net.au>
	
	[BZ #721]
	* sysdeps/powerpc/tcb-offsets.sym (thread_offsetof): Redefine to suit
	gcc4.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/nptl/sysdeps/powerpc/tcb-offsets.sym.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.5&r2=1.5.2.1

Comment 24 cvs-commit@gcc.gnu.org 2005-10-17 04:57:31 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-10-17 04:57:27

Modified files:
	sysdeps/s390/s390-64: dl-machine.h 
	sysdeps/s390/s390-32: dl-machine.h 

Log message:
	2005-03-15  Jakub Jelinek  <jakub@redhat.com>
	
	[BZ #721]
	* elf/dynamic-link.h (elf_machine_rel, elf_machine_rel_relative,
	elf_machine_rela, elf_machine_rela_relative, elf_machine_lazy_rel):
	Add inline keyword.
	* sysdeps/alpha/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Add always_inline
	attribute.
	* sysdeps/sparc/sparc32/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.  Change
	static inline into auto inline.
	* sysdeps/sparc/sparc64/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	* sysdeps/generic/dl-machine.h (elf_machine_rel, elf_machine_rela):
	Likewise.
	* sysdeps/arm/dl-machine.h (elf_machine_rel, elf_machine_rel_relative,
	elf_machine_rela, elf_machine_rela_relative, elf_machine_lazy_rel):
	Likewise.
	* sysdeps/s390/s390-32/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.
	* sysdeps/s390/s390-64/dl-machine.h (elf_machine_rela,
	elf_machine_rela_relative, elf_machine_lazy_rel): Likewise.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/s390/s390-64/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.19&r2=1.19.4.1
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/s390/s390-32/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.20&r2=1.20.4.1

Comment 25 cvs-commit@gcc.gnu.org 2005-12-05 23:12:07 UTC
Subject: Bug 721

CVSROOT:	/cvs/glibc
Module name:	libc
Branch: 	glibc-2_3-branch
Changes by:	roland@sources.redhat.com	2005-12-05 23:12:04

Modified files:
	sysdeps/mips   : dl-machine.h 

Log message:
	2005-11-30  Bruno Haible  <bruno@clisp.org>
	
	[BZ #721]
	* sysdeps/mips/dl-machine.h: Declare functions with 'auto inline',
	not 'static inline'.

Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/libc/sysdeps/mips/dl-machine.h.diff?cvsroot=glibc&only_with_tag=glibc-2_3-branch&r1=1.77&r2=1.77.2.1