Bug 675 - [i386]: compillation fail in intl with "error: can't find a register in class `GENERAL_REGS' while reloading `asm'"
Summary: [i386]: compillation fail in intl with "error: can't find a register in class...
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.4
: P2 normal
Target Milestone: ---
Assignee: GOTO Masanori
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-18 04:23 UTC by Tomasz Kłoczko
Modified: 2005-01-18 08:27 UTC (History)
1 user (show)

See Also:
Host:
Target: i386
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Kłoczko 2005-01-18 04:23:19 UTC
I can't compile glibc from glibc-2_3-branch. It fails on:

i386-pld-linux-gcc loadmsgcat.c -c -std=gnu99 -O2 -Wall -Winline
-Wstrict-prototypes -Wwrite-strings -march=i386 -mpreferred-stack-boundary=2 
-fPIC -
g0 -fomit-frame-pointer -D__USE_STRING_INLINES    -I../include -I.
-I/home/users/builder/rpm/BUILD/glibc-2.3.4/builddir/intl -I.. -I../libio  -I/home/
users/builder/rpm/BUILD/glibc-2.3.4/builddir -I../sysdeps/i386/elf
-I../linuxthreads/sysdeps/unix/sysv/linux/i386 -I../linuxthreads/sysdeps/unix/sysv/
linux -I../linuxthreads/sysdeps/pthread -I../sysdeps/pthread
-I../linuxthreads/sysdeps/unix/sysv -I../linuxthreads/sysdeps/unix
-I../linuxthreads/sysd
eps/i386 -I../sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux
-I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/
unix/inet -I../sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv
-I../sysdeps/unix/i386 -I../sysdeps/unix -I../sysdeps/posix
-I../sysdeps/i386/fpu -I../sy
sdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96
-I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754
-I../sys
deps/generic/elf -I../sysdeps/generic  -D_LIBC_REENTRANT -include
../include/libc-symbols.h  -DPIC -DSHARED     -D'LOCALEDIR="/usr/share/locale"' -D'L
OCALE_ALIAS_PATH="/usr/share/locale"' -o
/home/users/builder/rpm/BUILD/glibc-2.3.4/builddir/intl/loadmsgcat.os -MD -MP
-MF /home/users/builder/rpm/BUI
LD/glibc-2.3.4/builddir/intl/loadmsgcat.os.dt -MT
/home/users/builder/rpm/BUILD/glibc-2.3.4/builddir/intl/loadmsgcat.os
loadmsgcat.c: In function `_nl_init_domain_conv':
../sysdeps/i386/bits/string.h:655: error: can't find a register in class
`GENERAL_REGS' while reloading `asm'
make[2]: ***
[/home/users/builder/rpm/BUILD/glibc-2.3.4/builddir/intl/loadmsgcat.os] Error 1
make[2]: Leaving directory `/home/users/builder/rpm/BUILD/glibc-2.3.4/intl'

The same source builded in the same enviroment but optimized for i686, i586,
athlon and sparc compiles correctly.

Full build log avalaible
on:http://buildlogs.pld.org.pl/index.php?idx=1&ok=0&ns=0&cnt=16&off=0&id=c1736055cea944fc96160cd807d0b762&action=text

Build enviroment contain gcc 3.4.3 and binutils 2.15.94.0.2.
Comment 1 Andreas Jaeger 2005-01-18 08:27:20 UTC
This is an error coming from GCC not from glibc, there's nothing we can do. 

*** This bug has been marked as a duplicate of 333 ***