Bug 6551 - Watch support for variables bigger than max length of a single watch register
Summary: Watch support for variables bigger than max length of a single watch register
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Teresa Thomas
URL:
Keywords:
: 6482 (view as bug list)
Depends on:
Blocks: 1625
  Show dependency treegraph
 
Reported: 2008-05-23 17:03 UTC by Teresa Thomas
Modified: 2008-05-23 21:04 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Teresa Thomas 2008-05-23 17:03:58 UTC
Example types:
double or long long on IA32, an array of size 32 on X86_64

Requires multiple watchpoint registers watching one variable or datatype.

Note:
IA32 has 4 debug regs that can watch 4 bytes each
x86_64 has 4 debug registers that can watch 8 bytes each
Comment 1 Teresa Thomas 2008-05-23 21:01:32 UTC
    Add support for watching variables bigger than the max length a watch
register can watch.
    
    frysk-core/frysk/hpd/ChangeLog:
    2008-05-23 Teresa Thomas  <tthomas@redhat.com>
    
    	* WatchCommand.java (interpret): Install multiple
    	watchobservers if necessary.
    	* TestWatchCommand.java: New tests added.


commit 8bbe39bf404b507702d7d561bbcedf3d9103c9ba
Author: Teresa Thomas <tthomas@redhat.com>
Date:   Fri May 23 14:01:41 2008 -0400

    Schedule an actionpoint done event in blockedByAction.
    
    frysk-core/frysk/stepping/ChangeLog:
    2008-05-23    Teresa Thomas  <tthomas@redhat.com>
    
    	* SteppingEngine.java (messages): New.
    	(blockedByActionPoint(Task,TaskObserver,String,PrintWriter)): New.
Comment 2 Teresa Thomas 2008-05-23 21:04:46 UTC
*** Bug 6482 has been marked as a duplicate of this bug. ***