Bug 614 - ld vinfo %C error messages do not conform to GNU Coding standard
Summary: ld vinfo %C error messages do not conform to GNU Coding standard
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: ld (show other bugs)
Version: 2.15
: P2 normal
Target Milestone: ---
Assignee: Nick Clifton
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-22 12:15 UTC by Nick Clifton
Modified: 2005-01-05 16:03 UTC (History)
1 user (show)

See Also:
Host: any
Target: any
Build: any
Last reconfirmed:


Attachments
Testcase with makefile and source files (378 bytes, text/plain)
2004-12-22 12:20 UTC, Nick Clifton
Details
Potential fix (1.19 KB, patch)
2004-12-22 12:25 UTC, Nick Clifton
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clifton 2004-12-22 12:15:45 UTC
This case was originally submitted tot he binutils project by Richard Stallman.
 He said:

> I think this is a matter of incorrect output from ld, because the
> second error message doesn't follow the specs in the GNU Coding
> Standards.  Outputting that extra information (in parens) may
> be useful, but please don't put it into the beginning of the error
> message which is the part that's supposed to be parsable by programs.

This was in reference to an emacs bug report submitted by ceder@ingate.com where
was talking about parsing this error message from the linker:

> sip/sip.a(Receiver.o)(.text+0x1ec0): In function `Receiver::ProcessMsg(int)':
> /opt/users/ceder/sipfw/sip/src/Receiver.cpp:776: undefined reference to 
> `scAccept(int, int)'
>sip/sip.a(Receiver.o)(.text+0x1fc8):/opt/users/ceder/sipfw/sip/src/Receiver.cpp:798:
undefined reference to `scAccept(int, int)'
Comment 1 Nick Clifton 2004-12-22 12:20:45 UTC
Created attachment 318 [details]
Testcase with makefile and source files

A small testcase to reproduce the incorrect error messages
Comment 2 Nick Clifton 2004-12-22 12:21:21 UTC
I have created a testcase to reproduce this problem
Comment 3 Nick Clifton 2004-12-22 12:25:10 UTC
Created attachment 319 [details]
Potential fix

Possible fix for PR614 - regression testing currently in progress
Comment 4 Nick Clifton 2004-12-22 12:31:10 UTC
Oops - the testcase is broken.  Please replace "-L" with "-L." in the last line
of the "doit" target.
Comment 5 Nick Clifton 2004-12-22 15:40:13 UTC
Regression checking complete - no regressions.

No waiting on RMS's approval for the output format before committing.
Comment 6 Nick Clifton 2005-01-05 16:03:55 UTC
Patch applied.

ld/ChangeLog
2005-01-05  Nick Clifton  <nickc@redhat.com>

	PR binutils/614
	* ldmisc.c (vfinfo): Alter output to conform to the GNU Coding
	Standard's specification for parsable error messages.