Bug 607 - Thread Local Storage (TLS) unsupported and '--withou-tls' ignored
Summary: Thread Local Storage (TLS) unsupported and '--withou-tls' ignored
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.3
: P2 critical
Target Milestone: ---
Assignee: GOTO Masanori
Depends on:
Reported: 2004-12-13 12:45 UTC by Gustavo Martins Bastos
Modified: 2004-12-13 14:34 UTC (History)
1 user (show)

See Also:
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Martins Bastos 2004-12-13 12:45:26 UTC
I was trying to install non Mandrake10.1-included softwares and I was getting 
several error messages saying libs were not ok or not there from all softwares. 
So I came up with that glibc was not installed. 
So I went to the Free Software Directory, and downloaded the tarball for 
version 2.3.3. 
Some tools required for compiling were missing too: autoconf and texinfo. These 
I have already installed the latest versions available (2.59 and 4.7, 
respectively). All other tools versions required, as mentioned on the INSTALL 
file, were already exceeded. 
But, as I was committed to compile just for i586 and higher processors, I 
didn't care about and proceeded using '--without-tls'. 
Then 'make' returned one error message with 3 * (I mean: ***) telling TLS 
support was required. 
I don't know where could I find the files required for TLS support, which my 
newly installed from scratch Mandrake 10.1 (using only the first 2 of a 3 CD 
set) happens to miss.  
I can send you the config.log generated in the proccess, if you would like.
Comment 1 Andreas Jaeger 2004-12-13 14:34:44 UTC

*** This bug has been marked as a duplicate of 333 ***