Bug 593 - Trouble compiling glibc2.3.3
Summary: Trouble compiling glibc2.3.3
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: admin (show other bugs)
Version: 2.3.3
: P2 critical
Target Milestone: ---
Assignee: Andreas Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-30 18:46 UTC by sincereli
Modified: 2012-02-22 00:33 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sincereli 2004-11-30 18:46:14 UTC
I want to install glibc-2.3.3 on my Redhat9. Follow the install instruction in
the package, I make a seperate directory glibc-build to be built.  My
environment is:
build-system-type: i686-pc-linux-gnu
gcc: 3.2.2
binutils: 2.15
kernel: 2.4.20.18
make: 3.80

# ../glibc-2.3.3/configure --enable-add-ons

but after a while, I got an error like this:
...
checking size of long double... 12
running configure fragment for sysdeps/i386/elf
running configure fragment for nptl/sysdeps/pthread
checking for forced unwind support... no
configure: error: forced unwind support is required

I have resorted to Google and the exist bug records in Bugzilla, but I found
nothing valuable to me. I think it may not be a bug, but I could not get through
of it. Anybody can give me an advice?
    Thanks in advance for your help.
Comment 1 Andreas Jaeger 2004-12-18 15:16:54 UTC
Update your compiler to newer versions.

*** This bug has been marked as a duplicate of 333 ***