Bug 5767 - /usr/bin/ld: BFD (Linux/GNU Binutils) internal error, aborting at ../../binutils- line 202 in arange_set_new
Summary: /usr/bin/ld: BFD (Linux/GNU Binutils) internal error, ab...
Alias: None
Product: binutils
Classification: Unclassified
Component: ld (show other bugs)
Version: 2.18
: P2 critical
Target Milestone: ---
Assignee: unassigned
Depends on:
Reported: 2008-02-17 14:29 UTC by Philip Miller
Modified: 2008-02-17 15:51 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Philip Miller 2008-02-17 14:29:47 UTC
I tried to compile avidemux-2.4-r3791 in x86 branch for my linux distribution
paldo. In x86_64 all went ok but in x86 I got this error message:

[code]libADM_library.a ./ADM_colorspace/libADM_colorspace.a
./ADM_osSupport/libADM_ossupport.a ./ADM_libraries/ADM_libswscale/libswscale.a 
   -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread -lfreetype -lz     -L/usr/lib
-lxml2 -lz -lm  -lglib-2.0   -lXv -lfontconfig -lmp3lame -lvorbis -lvorbisenc
-lvorbis -lfaac -lfaad -lasound -lpng -lxvidcore -lxvidcore -lamrnb -lx264 -laften 
/usr/bin/ld: size of bfd_vma > size of splay_tree types
/usr/bin/ld: BFD (Linux/GNU Binutils) internal error,
aborting at ../../binutils- line 202 in arange_set_new

/usr/bin/ld: Please report this bug.

collect2: ld returned 1 exit status
make[3]: *** [avidemux2_cli] Error 1
make[3]: Leaving directory `/usr/src/avidemux-2.4-r3791/avidemux'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/avidemux-2.4-r3791/avidemux'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/avidemux-2.4-r3791'
make: *** [all] Error 2
*** Error: make[/code]

The full logs you can read here:


With version binutils- it is also ok in x86.
Comment 1 Philip Miller 2008-02-17 15:00:49 UTC
On powerpc it is fixed I assume:


... hope on i686-pc-linux-gnu also soon.
Comment 2 H.J. Lu 2008-02-17 15:10:30 UTC

*** This bug has been marked as a duplicate of 5755 ***
Comment 3 Philip Miller 2008-02-17 15:15:11 UTC
It is i686-pc-linux-gnu and not powerpc !!! So it is a new bug, or same bug in a
different arch.
Comment 4 Philip Miller 2008-02-17 15:51:56 UTC
So the bug was solved after all. I compiled the snapshot of binutils of today
(ftp://sourceware.org/pub/binutils/snapshots/binutils-2.18.50.tar.bz2) and
recompiled avidemux with it. It worked.