Bug 5397 - fdebugrpm assumes incorrect debuginfo repository name
Summary: fdebugrpm assumes incorrect debuginfo repository name
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Teresa Thomas
URL:
Keywords:
Depends on:
Blocks: 5656
  Show dependency treegraph
 
Reported: 2007-11-24 00:00 UTC by Thomas Fitzsimmons
Modified: 2008-01-21 22:14 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Fitzsimmons 2007-11-24 00:00:17 UTC
On a Fedora 8 machine:

$ fdebugrpm `pgrep firefox`

Missing Debuginfo package(s)
============================
firefox-debuginfo-2.0.0.6-10.fc8

Do you wish to install the above packages? [y/n]: y
Loading "refresh-updatesd" plugin


Error getting repository data for core-debuginfo, repository not found

fdebugrpm should query yum for the available repositories.
Comment 1 Teresa Thomas 2007-11-27 23:41:54 UTC
    Update enabled repo list in fdebugrpm. (Bug# 5397)
    
    frysk-core/frysk/bindir/ChangeLog
    2007-11-27 Teresa  Thomas <tthomas@redhat.com>
    
       * fdebugrpm.sh: Update enabled repos list for fc7
       and fc8 support.

Note updated debuginfo repositories:
       fedora-debuginfo, 
       updates-debuginfo, 
       updates-testing-debuginfo, 
       development-debuginfo

Should this just enable *-debuginfo repos instead?
Comment 2 Thomas Fitzsimmons 2007-11-28 06:11:21 UTC
(In reply to comment #1)

> Should this just enable *-debuginfo repos instead?

Yes, since I might want to debug packages from external repositories, for
example rpm.livna.org.

Are there plans to integrate debuginfo downloading into fhpd?
Comment 3 Teresa Thomas 2007-11-28 15:46:48 UTC
About enabling all debuginfo repos, there was debate over whether this should be
done explicitly by the user, or by the fdebugrpm scripts. Finally, it was
decided to enable the more commonly used repos by default. But as a user, if you
want all enabled, then sure thats what you get! :)

Debuginfo downloading, for the time being does not have plans to be integrated
into fhpd. For one, its implemented as a script and this means having it in hpd
will make it a little too fedora specific. Moreover, is downloading debuginfo
really an fhpd task?

Commit:
    Enable all debuginfo repos for fdebugrpm.
    
    frysk-core/frysk/bindir/ChangeLog
    2007-11-28 Teresa Thomas <tthomas@redhat.com>
    
       * fdebugrpm.sh: Enable all debuginfo repos.
Comment 4 Thomas Fitzsimmons 2007-11-28 18:13:38 UTC
(In reply to comment #3)

> Debuginfo downloading, for the time being does not have plans to be integrated
> into fhpd. For one, its implemented as a script and this means having it in hpd
> will make it a little too fedora specific.

Ideally Frysk would have a PackageKit component for debuginfo package handling.

> Moreover, is downloading debuginfo
> really an fhpd task?

For convenience, I'd say so.  When I debug a system-installed (i.e. packaged)
binary with gdb, this is my typical usage pattern:

1) run gdb on the binary
2) try to debug the binary
3) discover I'm missing debuginfo for the package or one of its dependencies
4) quit gdb
5) yum --enablerepo=development-debuginfo install <missing debuginfo package>
6) goto 1

debuginfo packages don't have interdependencies so it's not enough just to
install the package-to-debug's debuginfo before starting gdb.  (Solving this
problem is fdebugrpm's raison-d'être).

A more efficient pattern would be:

1) run fhpd on the binary
2) type 'y' when fhpd asks me if I want to install debuginfo for this package
   and all its dependencies
3) debug the binary
Comment 5 Teresa Thomas 2008-01-21 22:14:43 UTC
    Enable all debuginfo repos for fdebugrpm.
    
    frysk-core/frysk/bindir/ChangeLog
    2007-11-28 Teresa Thomas <tthomas@redhat.com>
    
       * fdebugrpm.sh: Enable all debuginfo repos.