Bug 531 - New locale entries for Cyprus el_CY and tr_CY
Summary: New locale entries for Cyprus el_CY and tr_CY
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: localedata (show other bugs)
Version: unspecified
: P2 enhancement
Target Milestone: ---
Assignee: Petter Reinholdtsen
URL:
Keywords:
: 436 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-09 17:42 UTC by Konstantinos Margaritis
Modified: 2006-05-02 16:54 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
The el_CY entry (1.22 KB, text/plain)
2004-11-09 17:44 UTC, Konstantinos Margaritis
Details
The tr_CY entry (25.69 KB, application/octet-stream)
2004-11-09 17:46 UTC, Konstantinos Margaritis
Details
Fixed locale entry (783 bytes, text/plain)
2006-01-07 09:31 UTC, Konstantinos Margaritis
Details
tr_CY locale from Debian belocs-locale (1.10 KB, text/plain)
2006-05-02 14:19 UTC, Recai Oktaş
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantinos Margaritis 2004-11-09 17:42:38 UTC
We (Recai Oktas and me) have written two new locale entries for Cyprus. These 
will be attached to the bug report.  
 
For el_CY, some relevant info that justifies the values in the locale entry 
can be found on these pages: 
 
http://europa.eu.int/abc/european_countries/eu_members/cyprus/index_en.htm 
http://en.wikipedia.org/wiki/Cyprus 
http://www.studentsoftheworld.info/pageinfo_pays.php3?Pays=CYP 
 
For tr_CY, some more explanation will be needed, given by Recai: 
----- 
Attached is the tr_CY locale prepared by basing on the latest tr_TR 
locale (grabbed from CVS, release 1.18.2.1).  I'm also sending a unified 
diff file which makes easier to follow the changes.  I think, in its 
early stage, this locale could be helpful for Turkish Cypriots using a 
glibc based system.  We could expect further modifications, according to 
the changes in Cyprus's situation. 
 
Turkish locale for Cyprus almost completely follows the Turkey's 
counterpart, indeed only a few items has been changed.  Due to its 
current political conjecture, I can only supply some unofficial 
information sources for justification: 
 
    * Wikipedia:  
      http://en.wikipedia.org/wiki/Turkish_Republic_of_Northern_Cyprus 
 
    * North Cyprus online: 
      http://www.northcyprusonline.com/facts.php 
     
    * Official pages from UN which may be helpful to get an idea for the 
      current situation: 
      http://www.cyprus-un-plan.org/ 
 
* Here are the obvious changes which are self-explanatory (excerpts from 
  the diff file): 
 
    -% Turkish Language Locale for Turkey 
    +% Turkish Language Locale for Cyprus 
 
    -% Territory: TR 
    +% Territory: CY 
 
 
    +% Adapted from tr_TR by Recai Okta?? <roktas@omu.edu.tr>, 2004 
    + 
 
    -title      "Turkish locale for Turkey" 
    +title      "Turkish locale for Cyprus" 
 
 
    -territory  "Turkey" 
    +territory  "Cyprus" 
 
 
    -date       "2000-06-29" 
    +date       "2004-10-23" 
 
* Although, there is no such official country (in a sense, recognized by 
  UN) as 'Northern Cyprus' or 'Turkish Republic of Northern Cyprus' (aka 
  TRNC), there are two separate regions in Cyprus, of which one of them, 
  the Southern region is officially recognized as 'Cyprus'.  The 
  suggested change, IMO, appears to be a reasonable choice which 
  reflects the current situation. 
 
    -% Turkey 
    -country_name       "<U0054><U0075><U0072><U006B><U0065><U0079>" 
    +% Northern Cyprus 
    +country_name       
"<U004E><U006F><U0072><U0074><U0068><U0065><U0072><U006E>/ 
    +<U0020><U0043><U0079><U0070><U0072><U0075><U0073>" 
 
* I haven't touched the other parts of tr_TR locale, because they all 
  are the same as in tr_TR.  Following issues could be justified from 
  the given sources above. 
 
    + Currency is Turkish Lira (TL). 
    + Northern Cypriots use the Turkey's postal code and intl tel code; 
      they don't have any separate intl car plate, and so on... 
----- 
 
Regards 
 
Konstantinos Margaritis <markos@debian.org> 
Recai Oktas <roktas@omu.edu.tr>
Comment 1 Konstantinos Margaritis 2004-11-09 17:44:41 UTC
Created attachment 268 [details]
The el_CY entry
Comment 2 Konstantinos Margaritis 2004-11-09 17:46:15 UTC
Created attachment 269 [details]
The tr_CY entry
Comment 3 Andreas Jaeger 2004-12-19 14:55:18 UTC
*** Bug 436 has been marked as a duplicate of this bug. ***
Comment 4 Ulrich Drepper 2005-09-24 17:00:41 UTC
About el_CY: if the data matches the el_GR locale, use

copy "el_GR"

in the categories.  This would also correct bugs like

yesexpr "^[<U03bd><U039d>yY].*"

(see the el_GR locale for how it would have to be done).  Update the file and
I'll add it.

For tr_CY the same applies, just use copy to ge the data from tr_TR.  But here
the situtation is different since I have no interest to get into a political
dispute.  So I'll not add the locale at all until there is more clarity.
Comment 5 Konstantinos Margaritis 2006-01-07 09:31:48 UTC
Created attachment 819 [details]
Fixed locale entry

Replaced some entries with copy "el_GR" as suggested by Ulrich.
Comment 6 Ulrich Drepper 2006-05-01 18:29:31 UTC
The new locale data still isn't in the correct form.  Look at the other locale
source files.  I fixed it up to avoid another round.  Test the code which is in
CVS now.

This still leaves the tr_CY locale.  Somebody better look at fixing it or I'll
close the bug.
Comment 7 Recai Oktaş 2006-05-02 14:19:55 UTC
Created attachment 995 [details]
tr_CY locale from Debian belocs-locale

(In reply to comment #6)
[...]
> This still leaves the tr_CY locale.  Somebody better look at fixing it or
I'll
> close the bug.

Attached is the tr_CY locale from Debian belocs-locale[1].

[1] http://belocs.alioth.debian.org/
Comment 8 Ulrich Drepper 2006-05-02 16:37:49 UTC
The proposed tr_CY file had to be seriously cleaned up.  I did that now and
checked the result in.
Comment 9 Recai Oktaş 2006-05-02 16:54:07 UTC
(In reply to comment #8)
> The proposed tr_CY file had to be seriously cleaned up.  I did that now and
> checked the result in.

Sorry for the mess.  Thanks for your time and efforts!