Bug 5207 - man page of ld: hashstyle=both missing
Summary: man page of ld: hashstyle=both missing
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: ld (show other bugs)
Version: 2.18
: P2 normal
Target Milestone: ---
Assignee: unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-22 11:02 UTC by Armin Mohring
Modified: 2007-11-08 19:17 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Armin Mohring 2007-10-22 11:02:47 UTC
man ld:

hashstyle=both or hashstyle=gnu is missing.
Comment 1 Armin Mohring 2007-10-22 13:16:09 UTC
--hash-style=both or --hash-style=gnu is missing.
Comment 2 Nick Clifton 2007-11-07 16:48:56 UTC
Hi Armin,

  Please could you explain more about this bug ?

  I looked at the manpage for ld and saw this:

       --hash-style=style
           Set the type of linker's hash table(s).  style can be either "sysv"
           for  classic  ELF  ".hash"  section,  "gnu"  for  new   style   GNU
           ".gnu.hash"  section or "both" for both the classic ELF ".hash" and
           new style GNU ".gnu.hash" hash tables.  The default is "sysv".

  Are you saying that this information is not enough ?

Cheers
  Nick
Comment 3 Armin Mohring 2007-11-07 18:25:41 UTC
I have man pages version 1.6e installed.
I haven´t found any entry, which discribes --hash-style=*.
Comment 4 Armin Mohring 2007-11-07 18:45:03 UTC
Correction of last post:
I have man-pages version 2.67 installed and no entry for hash-style=*
Comment 5 Nick Clifton 2007-11-07 19:18:19 UTC
Hi Armin,

  Err, sorry, there seems to be some confusion here.  The latest release of the
linker (and its man page) is version 2.18.  The current mainline development
version is 2.18.50.20071107.  There is no version 2.67 nor a version 1.6e.  How
are you obtaining the version numbers you reported ?

Cheers
  Nick
Comment 6 Armin Mohring 2007-11-07 21:06:26 UTC
I have binutils version 2.18 installed.
Version of man pages is 2.67.
Comment 7 drow@false.org 2007-11-07 22:29:06 UTC
Subject: Re:  man page of ld: hashstyle=both missing

On Wed, Nov 07, 2007 at 09:06:27PM -0000, mohringarmin at hotmail dot de wrote:
> I have binutils version 2.18 installed.
> Version of man pages is 2.67.

The binutils man page comes from binutils, not from the man-pages
package.

Comment 8 Nick Clifton 2007-11-08 10:44:18 UTC
Hi Armin,

  Please can you upload a compressed copy of the linker manpage then.  In the
version I have here (from the 2.18 sources) there definitely is an entry for the
--hash-style option which mentions "sysv", "gnu" and "both".

  Can you also tell me how you built this manpage ?

Cheers
  Nick
Comment 9 Armin Mohring 2007-11-08 12:26:19 UTC
You can download the tar.bz2 image from here:
http://www.gentoo.org/main/en/mirrors.xml

and navigate to gentoo->distfiles and binutils-2.18.

I could not upload this file, since it was too large.
Comment 10 Nick Clifton 2007-11-08 13:13:01 UTC
Hi Armin,

> You can download the tar.bz2 image from here:
> http://www.gentoo.org/main/en/mirrors.xml
> and navigate to gentoo->distfiles and binutils-2.18. 

I did that.  I built the linker and checked the manual page and sure enough,
there was the entry for --hash-style and it does mention all three possible
arguments for the switch's value.

What does your linker manual page look like ?

Cheers
  Nick
Comment 11 Armin Mohring 2007-11-08 19:17:31 UTC
Actually I check the latest version binutils and the manual did contain
--hash-style=*