Bug 5182 - Scripts won't exit on 2.6.23-mm1
Summary: Scripts won't exit on 2.6.23-mm1
Alias: None
Product: systemtap
Classification: Unclassified
Component: runtime (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
Depends on:
Reported: 2007-10-15 18:58 UTC by Mike Mason
Modified: 2007-10-23 18:00 UTC (History)
0 users

See Also:
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Mike Mason 2007-10-15 18:58:07 UTC
Scripts I run using the latest cvs code (as of 10/15/07 @ 11:15 AM PDT) will not
exit.  A Ctrl-C or explicit exit() displays the following:

stapio:sigproc:22 sigproc 2 (Interrupt)
stapio:stp_main_loop:293 got STP_EXIT, closed=0
stapio:cleanup_and_exit:216 CLEANUP AND EXIT  closed=0
stapio:close_relayfs:220 closing
stapio:close_relayfs:239 done
stapio:cleanup_and_exit:229 closing control channel
staprun:cleanup:179 rc=3, inserted_module=1
staprun:stop_symbol_thread:464 Stopping symbol thread.
staprun:cleanup:194 removing module stap_14f450c36f752aed577949ccb1f8d21b_501

then it just hangs.

"rmmod <stap_module>" indicates the module is still in use:

ERROR: Module stap_14f450c36f752aed577949ccb1f8d21b_501 is in use

"ps -e | grep stap" indicates stap and staprun are still running:

24153 pts/4    00:00:00 stap
24155 pts/4    00:00:00 staprun

"kill -9 <staprun_pid>" causes staprun and stap to exit and the module to be

I'm running the 2.6.23-mm1 kernel on x86_64.
Comment 1 Martin Hunt 2007-10-15 19:41:30 UTC
Does this always happen?

Was there something unusual about the scripts you were running?

I tested on x86_64 but not on the mm1 kernel you are using. It seems unlikely the 
problem would be kernel related.  I'll widen my testing.  Hanging on the  module
removal indicates some resource is still in use.
Comment 2 Mike Mason 2007-10-15 20:09:33 UTC
I tried several scripts in the examples directory and all hang on exit.

I didn't think this would be kernel version related either, but I just tried and 2.6.23-rc8-mm2 and both work fine.  No hangs.  I'm only
seeing the problem on 2.6.23-mm1.  I'm using this kernel because it has the
latest marker patches.
Comment 3 Mike Mason 2007-10-17 23:26:32 UTC
FYI... I just tried 2.6.23-mm1 on i386 and scripts hang there too.

Comment 4 Martin Hunt 2007-10-18 12:50:15 UTC
There seems to be no shortage of complaints about the bugs in that kernel.  In
particular threads seem messed up. 

Comment 5 Mike Mason 2007-10-20 15:30:53 UTC
(In reply to comment #4)
> There seems to be no shortage of complaints about the bugs in that kernel.  In
> particular threads seem messed up. 
> http://lkml.org/lkml/2007/10/13/175

Should we close this for now?
Comment 6 Frank Ch. Eigler 2007-10-20 15:39:42 UTC
You might try the current linus git tree instead.
As of yesterday, it has markers.
Comment 7 Mike Mason 2007-10-20 16:28:15 UTC
Funny you should mention that.  I just tried linus' git tree with markers and
they work fine, although I had to add 'source "kernel/Kconfig.instrumentation"'
to the x86_64 Kconfig file.  Probably an x86/x86_64 merge issue, since all other
archs besides i386 and x86_64 do source that file.

I'm also not seeing the "hang on script exit" problem on linus' git tree.
Comment 8 Frank Ch. Eigler 2007-10-23 18:00:21 UTC
Let's disregard illness in this -mm tree.