Bug 5021 - configure does not recognize makeinfo-4.11
Summary: configure does not recognize makeinfo-4.11
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: admin (show other bugs)
Version: 2.18
: P1 normal
Target Milestone: ---
Assignee: Daniel Jacobowitz
URL:
Keywords:
: 5022 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-11 09:29 UTC by gabriele balducci
Modified: 2007-09-15 02:48 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gabriele balducci 2007-09-11 09:29:57 UTC
Apologies if I'm missing something.

It seems to me that configure does not correctly recognize makeinfo version
>=4.10 (texinfo-4.11 has been just released)

The following patch fixes things for me (don't know if it's acceptable):

*** configure.ac.ORIG   Tue Sep 11 11:29:01 2007
--- mom Tue Sep 11 11:29:13 2007
***************
*** 2403,2409 ****
      # For an installed makeinfo, we require it to be from texinfo 4.4 or
      # higher, else we use the "missing" dummy.
      if ${MAKEINFO} --version \
!        | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null 2>&1; then
        :
      else
        MAKEINFO="$MISSING makeinfo"
--- 2403,2409 ----
      # For an installed makeinfo, we require it to be from texinfo 4.4 or
      # higher, else we use the "missing" dummy.
      if ${MAKEINFO} --version \
!        | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|4.[1-9][0-9])' >/dev/null
2>&1; then
        :
      else
        MAKEINFO="$MISSING makeinfo"


ciao
gabriele
Comment 1 Daniel Jacobowitz 2007-09-11 12:21:47 UTC
*** Bug 5022 has been marked as a duplicate of this bug. ***
Comment 2 Alan Modra 2007-09-15 02:48:25 UTC
Fixed.  http://gcc.gnu.org/ml/gcc-patches/2007-09/msg01271.html