Bug 4683 - Fedora 7 java.lang.NullPointerException on starting Sourcewindow on bash.
Summary: Fedora 7 java.lang.NullPointerException on starting Sourcewindow on bash.
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Rick Moseley
Depends on:
Blocks: 1633
  Show dependency treegraph
Reported: 2007-06-21 15:18 UTC by Nurdin Premji
Modified: 2007-08-01 19:51 UTC (History)
0 users

See Also:
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Nurdin Premji 2007-06-21 15:18:59 UTC
start a Debug session on bash and once the source window is supposed to come up
there are an endless supply of these:

   at org.eclipse.cdt.internal.core.parser.Parser.consume(FryskGui)
   at org.eclipse.cdt.internal.core.parser.Parser.errorHandling(FryskGui)
   at org.eclipse.cdt.internal.core.parser.Parser.translationUnit(FryskGui)
   at org.eclipse.cdt.internal.core.parser.Parser.parse(FryskGui)
   at frysk.dom.cparser.CDTParser.parse(FryskGui)
   at frysk.dom.DOMImage.addSource(FryskGui)
   at frysk.rt.Line.getDOMSource(FryskGui)
   at frysk.gui.srcwin.CurrentStackView.appendRows(FryskGui)
   at frysk.gui.srcwin.CurrentStackView.buildTree(FryskGui)
   at frysk.gui.srcwin.CurrentStackView.<init>(FryskGui)
   at frysk.gui.srcwin.SourceWindow.populateStackBrowser(FryskGui)
   at frysk.gui.srcwin.SourceWindow.finishSourceWin(FryskGui)
   at frysk.gui.srcwin.SourceWindow.access$32(FryskGui)
   at frysk.gui.srcwin.SourceWindow$2.run(FryskGui)
   at org.gnu.glib.CustomEvents.runEvents(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.gtk_main(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.main(libgtkjava-2.8.so)
   at frysk.gui.Gui.gui(FryskGui)
   at frysk.gui.FryskGui.main(FryskGui)
Comment 1 Rick Moseley 2007-07-03 19:05:27 UTC
This also occurs when starting the source window on a "sleep" program.
Comment 2 Rick Moseley 2007-07-05 14:34:31 UTC
Hmmmm, at second glance this error is different.

I fixed the "sleep" problem I mentioned in the earlier comment.  I just tried
this with the latest cvs checkout and I don't see this error now trying to
attach to bash.

Do you have the bash debuginfo installed or something else?

Could you verify you still get this?

Comment 3 Rick Moseley 2007-08-01 19:51:01 UTC
Fixed.  Now when the parser gets an NPE on a source file it leaves it unmarked
and marks it as "unparsed" in it DOMSource element.