Bug 4207 - backtrace when source window is brought up
Summary: backtrace when source window is brought up
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Mike Cvet
URL:
Keywords:
Depends on:
Blocks: 1633
  Show dependency treegraph
 
Reported: 2007-03-16 17:33 UTC by Rick Moseley
Modified: 2007-03-16 18:36 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick Moseley 2007-03-16 17:33:10 UTC
When I try to bring up the source window on my x86/FC5 machine running
2.6.20-1.2300.fc5 I get the following:

Call stack is broken - couldn't unwind!
ptrace: No such process
   at frysk.sys.Errno.throwErrno(Errno.cxx:157)
   at frysk.sys.Ptrace$PtraceThread.notifyPtraceThread(Ptrace.java:266)
   at frysk.sys.Ptrace.peekRegisters(Ptrace.cxx:227)
   at frysk.sys.RegisterSetBuffer.refresh(RegisterSetBuffer.java:91)
   at frysk.sys.RegisterSetBuffer.peek(RegisterSetBuffer.java:109)
   at inua.eio.ByteBuffer.peekFully(ByteBuffer.java:93)
   at inua.eio.ByteBuffer.get(ByteBuffer.java:334)
   at frysk.proc.Register.get(Register.java:112)
   at frysk.rt.StackCallbacks.accessReg(StackCallbacks.java:109)
   at lib.unwind.StackTraceCreator.unwind_setup(StackTraceCreator.cxx:229)
   at lib.unwind.StackTraceCreator.createStackTrace(StackTraceCreator.java:71)
   at frysk.rt.StackFactory.createStackFrame(StackFactory.java:76)
   at frysk.rt.StackFactory.createStackFrame(StackFactory.java:119)
   at frysk.cli.hpd.ExprSymTab.<init>(ExprSymTab.java:127)
   at frysk.cli.hpd.SymTab.<init>(SymTab.java:107)
   at frysk.gui.srcwin.SourceWindow.<init>(SourceWindow.java:306)
   at
frysk.gui.srcwin.SourceWindowFactory.createSourceWindow(SourceWindowFactory.java:121)
   at
frysk.gui.druid.CreateFryskSessionDruid$10.buttonEvent(CreateFryskSessionDruid.java:885)
   at org.gnu.gtk.Button.fireButtonEvent(libgtkjava-2.8.so)
   at org.gnu.gtk.Button.handleClick(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.gtk_main(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.main(libgtkjava-2.8.so)
   at frysk.gui.Gui.gui(Gui.java:244)
   at frysk.gui.FryskGui.main(FryskGui.java:59)
Comment 1 Rick Moseley 2007-03-16 17:33:44 UTC
redo summary to correct spelling
Comment 2 Mike Cvet 2007-03-16 18:30:15 UTC
This is because the new symTab variable in the source window is being 
initialized before the process is blocked - I'll fix this one
Comment 3 Mike Cvet 2007-03-16 18:36:03 UTC
2007-03-16  Mike Cvet  <mcvet@redhat.com>

	* SourceWindow.java (SourceWindow): Removed initialization of SymTab
	variable.
	(SourceWindow): Now initializes the DOM and calls populateStackBrowser
	from here instead of finishSourceWin().
	(finishSourceWin): Generate a stack trace only when the process is
	blocked, same for populating the stack browser window.
	(generateProcStackTrace): Initialize SymTab variable here. Fixes #4207.