Bug 3906 - shouldn't bits/in.h's IPV6_RXINFO 2 be called IPV6_PKTINFO?
Summary: shouldn't bits/in.h's IPV6_RXINFO 2 be called IPV6_PKTINFO?
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: hurd (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Roland McGrath
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-23 02:48 UTC by Samuel Thibault
Modified: 2012-05-11 01:50 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Thibault 2007-01-23 02:48:22 UTC
bits/in.h #defines IPV6_RXINFO 2, while sysdeps/unix/sysv/linux/bits/in.h defines IPV6_PKTINFO (and no RXINFO). For better compatibility, shouldn't IPV6_RXINFO be deprecated and IPV6_PKTINFO defined as a replacement?
Comment 1 Thomas Schwinge 2012-05-11 01:50:51 UTC
bcfe3a546e831ff3e43a8782f65a95fab7bb864d