Bug 3900 - glibc 2.5, make check, dlfcn testcase bug-atexit3 fails segm'n viol'n
Summary: glibc 2.5, make check, dlfcn testcase bug-atexit3 fails segm'n viol'n
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-22 04:39 UTC by John Lumby
Modified: 2007-01-22 06:22 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Lumby 2007-01-22 04:39:51 UTC
environment is intel i686, linux 2.6.19.1, gcc 4.1.1
downloaded glibc 2.5 from http://ftp.gnu.org/gnu/glibc/   (not from cvs).
configure and make are ok
make check runs to the dlfcn tests and fails on bug-atexit3
output to stdout is
statclass
but then output to stderr is
Didn't expect signal from child: got `Segmentation fault'

This was first reported in 
http://sourceware.org/ml/glibc-bugs/2006-11/msg00050.html

I tried bypassing this problem and make check failed in some nptl testcase
tst-mutex8.

I am not clear about status of this release 2.5 :
  gnu.org says current rel is 2.4
  this bugzilla does not know about 2.5
     but
   it is downloadable from mirrors
   FedoraCore6 seems to have it and there it describes itself as 
     GNU C Library stable release version 2.5    (note "stable")

Are you in fact accepting bugzillas on 2.5 yet?   
Is it worth it for me to try make install of this build? (after backup of course)
Or do you advise drop back to 2.4?

Thanks for advice

John
Comment 1 Ulrich Drepper 2007-01-22 06:22:53 UTC

*** This bug has been marked as a duplicate of 333 ***