Bug 3865 - Testsuite frysk3525/ext47 test fails
Summary: Testsuite frysk3525/ext47 test fails
Status: RESOLVED DUPLICATE of bug 3525
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-12 17:09 UTC by Kris Van Hees
Modified: 2007-01-22 15:05 UTC (History)
0 users

See Also:
Host: x86_64-redhat-linux-gnu
Target: x86_64-redhat-linux-gnu
Build: x86_64-redhat-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kris Van Hees 2007-01-12 17:09:41 UTC
Here is the output:

12737 installing signal handler and mask
12737 forking
12739 signaling 12737 with User defined signal 1
12739 waiting for signals
12737 calling waitpid 12738 for << child exit creating daemon >> returns 0x0
WIFEXITED 0 -- ok
12737 waiting for signals
12737 received User defined signal 1
12737 calling ptrace 16 (ATTACH) 12739 0
12737 calling waitpid 12739 for << daemon attached >> returns 0x137f WIFSTOPPED
19 -- ok
12737 calling ptrace 7 (CONT) 12739 0
12737 signaling 12739 with User defined signal 1
12737 calling waitpid 12739 for << daemon receives SIGUSR1 >> returns 0xa7f
WIFSTOPPED 10 -- ok
12737 calling ptrace 7 (CONT) 12739 10
12737 calling waitpid 12739 for << daemon does exit(47) >>12739 received User
defined signal 1
 returns 0x2f WIFSIGNALED 47 -- WIFEXITED 47 expected
Aborted
Comment 1 Kris Van Hees 2007-01-12 17:20:26 UTC
Note that this problem occurs on FC6 x86_64, Linux kernel 2.6.18-1.2798.dc6.
Comment 2 Andrew Cagney 2007-01-22 15:05:15 UTC
See:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=216020

Note that this kernel bug causes corresponding testsuite failures.


*** This bug has been marked as a duplicate of 3525 ***