Bug 385 - MIPS build fails with assembler errors in rtld.c
Summary: MIPS build fails with assembler errors in rtld.c
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.3
: P2 normal
Target Milestone: ---
Assignee: GOTO Masanori
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-15 00:35 UTC by David Daney
Modified: 2004-09-15 00:38 UTC (History)
1 user (show)

See Also:
Host: mipsel-linux
Target: mipsel-linux
Build: i686-linux
Last reconfirmed:


Attachments
Patch (363 bytes, text/plain)
2004-09-15 00:38 UTC, David Daney
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Daney 2004-09-15 00:35:03 UTC
Configured with:

../glibc-2.3.3/configure --build=i686-linux --host=mipsel-linux
--enable-add-ons=linuxthreads --prefix=/usr

mipsel-linux-gcc is GCC-3.3.1
binutils are 2.15

make
.
.
.mipsel-linux-gcc -mabi=32 rtld.c -c -std=gnu99 -O2 -Wall -Winline
-Wstrict-prototypes -Wwrite-strings -g   -fPIC    -I../include -I.
-I/newdisk/programs/mipsel-glibc233/elf -I.. -I../libio 
-I/newdisk/programs/mipsel-glibc233 -I../sysdeps/mips/elf
-I../linuxthreads/sysdeps/unix/sysv/linux/mips
-I../linuxthreads/sysdeps/unix/sysv/linux -I../linuxthreads/sysdeps/pthread
-I../sysdeps/pthread -I../linuxthreads/sysdeps/unix/sysv
-I../linuxthreads/sysdeps/unix -I../linuxthreads/sysdeps/mips
-I../sysdeps/unix/sysv/linux/mips/mips32 -I../sysdeps/unix/sysv/linux/mips
-I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common
-I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../sysdeps/unix/sysv
-I../sysdeps/unix/mips/mips32 -I../sysdeps/unix/mips -I../sysdeps/unix
-I../sysdeps/posix -I../sysdeps/mips/mips32 -I../sysdeps/mips
-I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/wordsize-32
-I../sysdeps/mips/fpu -I../sysdeps/ieee754 -I../sysdeps/generic/elf
-I../sysdeps/generic  -D_LIBC_REENTRANT -include ../include/libc-symbols.h 
-DPIC -DSHARED -DNOT_IN_libc=1 -DIS_IN_rtld=1     -o
/newdisk/programs/mipsel-glibc233/elf/rtld.os -MD -MP -MF
/newdisk/programs/mipsel-glibc233/elf/rtld.os.dt
/tmp/ccefhYhh.s: Assembler messages:
/tmp/ccefhYhh.s:125: Warning: missing .end
/tmp/ccefhYhh.s:157: Warning: No .frame pseudo-op used in PIC code
/tmp/ccefhYhh.s:165: Warning: .end directive without a preceding .ent
directive./tmp/ccefhYhh.s:165: Error: junk at end of line, first unrecognized
character is `.'

Patch to follow.
Comment 1 Roland McGrath 2004-09-15 00:37:38 UTC

*** This bug has been marked as a duplicate of 333 ***
Comment 2 David Daney 2004-09-15 00:38:41 UTC
Created attachment 193 [details]
Patch

Applying this patch allows me to build and seems to run with no problems.

The binutils-2.15 assembler seems not to like nested functions.  So I made
_dl_start_user not be an '.ent'.  This allows it to compile, but I am uncertian
if there might be hidden bad things happening.