Bug 382 - CFLAGS messed up
Summary: CFLAGS messed up
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: GOTO Masanori
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-13 14:10 UTC by Ervin Németh
Modified: 2004-12-19 15:06 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Patch to avoid sorting the CFLAGS (291 bytes, patch)
2004-09-14 07:24 UTC, Ervin Németh
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ervin Németh 2004-09-13 14:10:35 UTC
If I specify CFLAGS="-O2 --param max-reload-search-insns=200" for configure,
during make, gcc will be run with "--param -O2 max-reload-search-insns=200" and
so the compilation fails.
Comment 1 Roland McGrath 2004-09-13 19:02:04 UTC

*** This bug has been marked as a duplicate of 333 ***
Comment 2 Ervin Németh 2004-09-14 07:24:35 UTC
Created attachment 192 [details]
Patch to avoid sorting the CFLAGS

Is it documented that glibc can be compiled with gcc? Yes it is.

Is it documented that glibc can be compiled with user supplied CFLAGS? Yes it
is.

Is it documented that gcc accepts "--param NAME=VALUE"? Yes it is.
Comment 3 Ervin Németh 2004-09-14 07:29:17 UTC
Not related to bug #333

I fully understand why my build fails.
Comment 4 Andreas Schwab 2004-09-27 13:03:45 UTC
You can use --param=foo instead. 
Comment 5 Andreas Jaeger 2004-12-19 15:06:43 UTC
Fixed according to comments #3 and #4.