Bug 3817 - Compile time error on glibc 2.5
Summary: Compile time error on glibc 2.5
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: nscd (show other bugs)
Version: unspecified
: P1 critical
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-29 22:00 IST by Greg Chandler
Modified: 2006-12-29 22:18 IST (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Chandler 2006-12-29 22:00:38 IST
/usr/src/build/nscd/nscd.o: In function `nscd_open_socket':
/usr/src/glibc-2.5/nscd/nscd.c:414: undefined reference to `__stack_chk_guard'
/usr/src/glibc-2.5/nscd/nscd.c:432: undefined reference to `__stack_chk_guard'
/usr/src/build/nscd/connections.o: In function `restart':
/usr/src/glibc-2.5/nscd/connections.c:1129: undefined reference to
`__stack_chk_guard'
/usr/src/glibc-2.5/nscd/connections.c:1257: undefined reference to
`__stack_chk_guard'
/usr/src/build/nscd/connections.o: In function `nscd_run':
/usr/src/glibc-2.5/nscd/connections.c:1289: undefined reference to 
`__stack_chk_guard'
/usr/src/build/nscd/connections.o:/usr/src/glibc-2.5/nscd/connections.c:438:
more undefined references to `__stack_chk_guard' follow
collect2: ld returned 1 exit status
make[2]: *** [/usr/src/build/nscd/nscd] Error 1
make[1]: *** [nscd/others] Error 2
make: *** [all] Error 2



LDFLAGS="--static" ../glibc-2.5/configure --target=x86_64-linux
--host=x86_64-linux --with-headers=/usr/src/linux-2.6.19.1/include
--prefix=/usr/x86_64

x86_64-unknown-linux-gnu-gcc --version
x86_64-unknown-linux-gnu-gcc (GCC) 4.1.0
Comment 1 Ulrich Drepper 2006-12-29 22:18:37 IST

*** This bug has been marked as a duplicate of 333 ***