Bug 3403 - glibc 2.5 does not build on alpha
Summary: glibc 2.5 does not build on alpha
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: unspecified
: P2 critical
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-20 10:00 UTC by Aurelien Jarno
Modified: 2006-10-20 14:42 UTC (History)
1 user (show)

See Also:
Host: alphaev56-unknown-linux-gnu
Target: alphaev56-unknown-linux-gnu
Build: alphaev56-unknown-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aurelien Jarno 2006-10-20 10:00:07 UTC
The glibc 2.5 fails to build on alpha with the following error:

mv -f /build/buildd/glibc-2.5/build-tree/alpha-libc/shlib.ldsT /build/buildd/glibc-2.5/build-tree/alpha-libc/shlib.lds
gcc-4.1   -shared -static-libgcc -Wl,-O1  -Wl,-z,defs -Wl,-dynamic-linker=/lib/ld-linux.so.2  -B/build/buildd/glibc-2.5/build-tree/alpha-libc/csu/  -Wl,--version-script=/build/buildd/glibc-2.5/build-tree/alpha-libc/libc.map -Wl,-soname=libc.so.6.1 -Wl,-z,combreloc -Wl,-z,relro -nostdlib -nostartfiles -e 
__libc_main -L/build/buildd/glibc-2.5/build-tree/alpha-libc -L/build/buildd/glibc-2.5/build-tree/alpha-libc/math -L/build/buildd/glibc-2.5/build-tree/alpha-libc/elf -L/build/buildd/glibc-2.5/build-tree/alpha-libc/dlfcn -L/build/buildd/glibc-2.5/build-tree/alpha-libc/nss -L/build/buildd/glibc-2.5/build-tree/alpha-libc/nis -L/build/buildd/glibc-2.5/build-tree/alpha-libc/rt -L/build/buildd/glibc-2.5/build-tree/alpha-libc/resolv -L/build/buildd/glibc-2.5/build-tree/alpha-libc/crypt -L/build/buildd/glibc-2.5/build-tree/alpha-libc/nptl -Wl,-rpath-link=/build/buildd/glibc-2.5/build-tree/alpha-libc:/build/buildd/glibc-2.5/build-tree/alpha-libc/math:/build/buildd/glibc-2.5/build-tree/alpha-libc/elf:/build/buildd/glibc-2.5/build-tree/alpha-libc/dlfcn:/build/buildd/glibc-2.5/build-tree/alpha-libc/nss:/build/buildd/glibc-2.5/build-tree/alpha-libc/nis:/build/buildd/glibc-2.5/build-tree/alpha-libc/rt:/build/buildd/glibc-2.5/build-tree/alpha-libc/resolv:/build/buildd/glibc-2.5/build-tree/alpha-libc/crypt:/build/buildd/glibc-2.5/build-tree/alpha-libc/nptl -o /build/buildd/glibc-2.5/build-tree/alpha-libc/libc.so -T /build/buildd/glibc-2.5/build-tree/alpha-libc/shlib.lds /build/buildd/glibc-2.5/build-tree/alpha-libc/csu/abi-note.o /build/buildd/glibc-2.5/build-tree/alpha-libc/elf/soinit.os /build/buildd/glibc-2.5/build-tree/alpha-libc/libc_pic.os /build/buildd/glibc-2.5/build-tree/alpha-libc/elf/sofini.os /build/buildd/glibc-2.5/build-tree/alpha-libc/elf/interp.os /build/buildd/glibc-2.5/build-tree/alpha-libc/elf/ld.so -lgcc
/build/buildd/glibc-2.5/build-tree/alpha-libc/libc_pic.os: In function 
`__pause_nocancel':
./sysdeps/posix/pause.c:55: undefined reference to `__sigsuspend_nocancel'
collect2: ld returned 1 exit status

The problem comes from the fact that the following lines have been added to 
sysdeps/unix/sysv/linux/sigsuspend.c, but not to 
sysdeps/unix/sysv/linux/alpha/sigsuspend.S

#ifndef NO_CANCELLATION
int
__sigsuspend_nocancel (set)
     const sigset_t *set;
{
  return do_sigsuspend (set);
}
#endif

I don't know how to write that in assembly code for alpha, so I can't propose a 
patch.
Comment 1 Ulrich Drepper 2006-10-20 14:42:10 UTC

*** This bug has been marked as a duplicate of 333 ***