Bug 331 - CVS 20040815 make check fails nptl/tst-cancelx17
Summary: CVS 20040815 make check fails nptl/tst-cancelx17
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: nptl (show other bugs)
Version: 2.3.3
: P2 normal
Target Milestone: ---
Assignee: Ulrich Drepper
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-16 12:02 UTC by duncan_roe
Modified: 2004-08-16 20:41 UTC (History)
1 user (show)

See Also:
Host: i486-pc-linux-gnu
Target: i486-pc-linux-gnu
Build: i486-pc-linux-gnu
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description duncan_roe 2004-08-16 12:02:52 UTC
Running "make check" on CVS 20040815, get:-

GCONV_PATH=/build/glibc-2.3.3/iconvdata LC_ALL=C  
/build/glibc-2.3.3/elf/ld-linux.so.2 --library-path
/build/glibc-2.3.3:/build/glibc-2.3.3/math:/build/glibc-2.3.3/elf:/build/glibc-2.3.3/dlfcn:/build/glibc-2.3.3/nss:/build/glibc-2.3.3/nis:/build/glibc-2.3.3/rt:/build/glibc-2.3.3/resolv:/build/glibc-2.3.3/crypt:/build/glibc-2.3.3/nptl
/build/glibc-2.3.3/nptl/tst-cancelx17  > /build/glibc-2.3.3/nptl/tst-cancelx17.out
Didn't expect signal from child: got `Segmentation fault'
make[2]: *** [/build/glibc-2.3.3/nptl/tst-cancelx17.out] Error 1
make[2]: Leaving directory `/usr/src/glibc-2.3.3/nptl'
make[1]: *** [nptl/tests] Error 2
make[1]: Leaving directory `/usr/src/glibc-2.3.3'
make: *** [check] Error 2

/build/glibc-2.3.3/nptl/tst-cancelx17.out contains:
going to cancel tf in-time

SOFTWARE REVISIONS
gcc (GCC) 3.4.1
linux 2.6.7
/usr/src/glibc-2.3.3/configure \
  --prefix=/usr \
  --enable-add-ons=nptl \
  --build=i486-pc-linux-gnu \
  --host=i486-pc-linux-gnu \
  --target=i486-pc-linux-gnu \
  --with-tls \
  CFLAGS="-g -O2 -march=opteron" \
  --without-cvs

glibc-2.3.3 is actually CVS 20040815
Comment 1 Ulrich Drepper 2004-08-16 17:27:17 UTC
It works fine if you have the right tools and environment.  We do not encourage
people to compile glibc themselves for just this reason: it is not easy to get
the correct environment up and running.  Use a distribution's package if you
fail to compile it yourself.  We do not provide support to anybody who has problems.
Comment 2 Roland McGrath 2004-08-16 20:40:53 UTC
Testing making this a dup of the placeholder bug.
Comment 3 Roland McGrath 2004-08-16 20:41:08 UTC

*** This bug has been marked as a duplicate of 333 ***