Bug 326 - undefined reference to `passwd2des_internal' while compiling iconvconfig
Summary: undefined reference to `passwd2des_internal' while compiling iconvconfig
Status: RESOLVED DUPLICATE of bug 333
Alias: None
Product: glibc
Classification: Unclassified
Component: libc (show other bugs)
Version: 2.3.3
: P2 critical
Target Milestone: ---
Assignee: GOTO Masanori
Depends on:
Reported: 2004-08-15 12:15 UTC by Guido Trentalancia
Modified: 2004-09-12 19:29 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Guido Trentalancia 2004-08-15 12:15:17 UTC
I get the following error on compiling iconvconfig from libc CVS 040815 and
since a almost a week of previous CVS versions.

gcc -nostdlib -nostartfiles -o
-Wl,-dynamic-linker=/lib/ld-linux.so.2   -Wl,-z,combreloc -Wl,-z,relro
/mnt/source/cvs/build/build-libc/csu/crti.o `gcc --print-file-name=crtbegin.o`
/mnt/source/cvs/build/build-libc/libc_nonshared.a -lgcc -Wl,--as-needed -lgcc_s
-Wl,--no-as-needed `gcc --print-file-name=crtend.o`
/mnt/source/cvs/build/build-libc/libc.so.6: undefined reference to
collect2: ld returned 1 exit status
make[2]: *** [/mnt/source/cvs/build/build-libc/iconv/iconvconfig] Error 1
make[2]: Leaving directory `/mnt/source/cvs/libc/iconv'
make[1]: *** [iconv/others] Error 2
make[1]: Leaving directory `/mnt/source/cvs/libc'
make: *** [all] Error 2

gcc (GCC) 3.5.0 20040811 (experimental)
GNU ld version 040812 20040812
Comment 1 Ulrich Drepper 2004-09-12 19:01:27 UTC
Do not file reports on build problems in bugzilla.  And you should not build
glibc yourself.  If you do, you're on your own.  It certainly builds right
almost all the time if you have a correct environment.  You'll not get any help
from the maintainers to determine what's broken in your environment.  Use the
glibc binary form a distribution.
Comment 2 Ulrich Drepper 2004-09-12 19:28:27 UTC
Let's do it properly...
Comment 3 Ulrich Drepper 2004-09-12 19:29:18 UTC
Let's do it properly...

*** This bug has been marked as a duplicate of 333 ***